Question about 2005 Kia Sorento

1 Answer

2005 Kia Sorento only blows hot and cold air on high. Is it a blower motor resistor and if it is where is it located?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 150 Answers

If the blower moter only works on hi speed it is the blower motor resistor that is bad. The blower motor resistor is located under the passenger side of the dash next to the blower motor. It is not necessary to remove the blower motor to change the resistor.

Posted on May 13, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why would my fan not be blowing hot or cold air?


You could have a relay that is bad , Blower motor relay in the under hood fuse/relay box. Or the blower motor itself could be bad . This is where you need to get a wiring diagram an a component location chart an a DVOM digital volt ohm meter an do some testing . The blower motor resistor , is this the part you changed ? If you haven't high blower operation either it couldn't be the blower motor resistor .

Oct 23, 2015 | 2002 Mercury Mountaineer

1 Answer

My air condition is not blowing


More than likely it's your blower motor resistor, but first thing is first check for blown fuses. If fuses are all intact locate the resistor which is usually located under the dash on the passenger side close to the blower motor case.( which will be a black plastic cylindrical box) The resistor will have a wiring harness running to it. With the key in the on position and the fan turned full on slowly move the harness around if the fan starts working, you have a bad connection or broken resistor. Which is common since people accidentally catch the wires with their feet or stretching on a long trip. If you replace the resistor disconnect your battery first, resistor is usually held in with a couple of screws, remove and be careful when installing new resistor they can be a bit fragile, best of luck!

May 30, 2015 | 2005 Kia Sorento 3.5

1 Answer

Blower motor blows on high only


Fan motor resistor broken. High fan circuit has no resistor so it still works.

Mar 03, 2014 | 2007 Kia Sorento LX 4x4

1 Answer

2005 kia spectra blower only blows 1 & 4 speeds


Could be the blower motor resister,it's located by blower motor,2 screws hold it on,easy to remove,click here to see part.

Dec 30, 2012 | 2005 Kia Spectra

1 Answer

Ac control panel in front quit blowing air at all. middle control panel and rear work good still blow out cold air. please advice


needs blower motor or blower resistor if it blows on high then it is the resistor if not then it is blower motor

Sep 06, 2010 | 2005 Chevrolet Tahoe

2 Answers

BLOWER MOTOR ON 2004 AVALANCHE IS SLOWLY PUMPING OUT AIR


it may not be the blower motor. it may be the blower motor control module which use to be the resistor. it's located under the pas. side. remove the black coyer , 2 scaews above the pas. foot area. then remove the blach unit that has a purple wire going to the back of the motor on the right. price about 140 dollar with tax.

Jul 01, 2009 | 2005 Chevrolet Avalanche

1 Answer

Blower only blows on high not on any other setting


if you locate blower motor wires test for voltage on lower fan speeds if no voltage re rmove the blower motor resistor and look for open or burn marks on it its usally located near the blower motor it will have three or four wires going to it.

Jun 21, 2009 | 2003 Kia Sorento

1 Answer

Fan blower will only blow in dash and not in defroster


this is a vacum problem check all your lines or look at a repair manual for specific locations

Dec 05, 2008 | 2005 Kia Sorento

Not finding what you are looking for?
2005 Kia Sorento Logo

1,192 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...