Question about Mercedes-Benz E320

2 Answers

I have a 1997 Mercedes E320 and the instrument cluster guages

I have a 1997 Mercedes E320 and the instrument cluster gauges have all stopped working at the same time. I checked the fuses and all are okay. The odometer, temperature, and clock still work. The lights also work. Periodically, the gauges do work after the car has not been driven for a while. Do I need a new instrument cluster? Thanks,

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I do not have a solution for it but my Mercedes is doing the exact same thing and also the air conditioning dash does not work but all the fuses are good.

Posted on Dec 13, 2012

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 408 Answers

Hello,good day,maybe your cluster nearly damage,send to your dealer,they have a testing procedure(simulation all the gauges), to determine if your cluster is defective,ty

Posted on May 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why want my gauges work in my 1997 saturn ?


Pull the cluster and make sure the connector is tight that is at the back of the instrument cluster.

Jun 11, 2014 | 1997 Saturn SL

1 Answer

I have a 1997 olds aurora nothing on instrument panel works fuel guage, tach, ect.


If the gauges or cluster fuse is ok, I would check for a problem with the connector or the cluster.

Jul 14, 2012 | Oldsmobile Aurora Cars & Trucks

1 Answer

Guages don't work


That could be the cluster gauge assembly itself and it may have bad connections on its circuit board or the body control module that controls the cluster gauges has a problem.

Dec 18, 2011 | 1997 Pontiac Grand Am

1 Answer

The instrument panel 1996 mercedes benz e320 does not work. the gas gauge, , speedometer, temperature, and oil gauge do not work bu sometime they work what it can be


there is a scart lead type conector on the back of the instrament cluster its probably worked loose if not this is it just the needles sticking i have a 1994 c180 and mine does this it suposed to be caused by static build up on the needle and the small post it sits on i have tryed every thing in the end i scraped off the paint on the small posts and its not as bad as it was another common fault

Nov 17, 2011 | Mercedes-Benz E320 Cars & Trucks

1 Answer

Instrument panel lighting has stopped working.


Fuse on back of gage cluster, and the dimmer switch on the gage cluster.

Apr 24, 2010 | 1993 Mercedes-Benz 190

1 Answer

The car in question is a 1996 Mercedes Benz E320. Not a 2005 E320


First I think the there is poor contact on the plug behind the cluster, but when I see your mention about the needle shaking then I think it needs to replace. I just check on ebay selling for $99 and it is a good price. It is easy to replace. Once the instrument can be pulled out, there are only 2 things to be disconnected: a speedometer cable can be unscrewed and a big plug for all electrical connection to be pulled off. Good luck.

Jul 28, 2009 | 2005 Mercedes-Benz Mercedes Benz E320 Cdi

2 Answers

None of the gauges work


Hi, this is a pretty common problem on these Silverado instrument clusters. We can help you out with that! Click here to learn more about these Silverado instrument cluster problems: Dr Speedometer Instrument Cluster Repair Speedometer Repair Guage...

Jun 15, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

Electrical Instrument cluster does not function


I had the same problem with a car i owned and found out it was a short in the wireing in the dash, you will have too have it re-wired, but too be certain you should have it checked out by a mechanic in your city.........

May 22, 2009 | 1990 Mercedes-Benz E-Class

1 Answer

Chevrolet Blazer 1997.


If sender is new in the fuel tank, you have a wire problem between conection of fuel sender and dashboard gauge most likely place at dasbboard gauge.

Nov 27, 2008 | 1997 Chevrolet Blazer

2 Answers

Instrument gauges in 2004 envoy


ours did this, it was the guage cluster that went bad. It's about $600 to replace

Nov 04, 2008 | 2004 GMC Envoy

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

2,027 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...