Question about 1992 Ford Escort 4 Door

1 Answer

Idle ok,slow acceleration fine,accelerating quickly miss-fires

Idle ok,slow acceleration fine,cruises ok,when accerating quickly it misses and back fires,the alternator had to be replaced earlier,when going to auto-eleatricians car was smoking badly and started to miss eventually had no acceleration at all and had to tow it,alternator replaced,since then have replaced spark plugs and ht leads,it is as if the timing is complelely out but it is an electronic ignition so i'm stumped

Posted by on

  • juggernautxt
    juggernautxt May 11, 2010

    what engine do you have the 1.8spi liter or 1.9spi liter 2.0 spi?
    Is there a high pitch whistling coming from the motor?


×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 76,673 Answers

Sounds like you have a leaking cylinder head gasket

Posted on Jul 18, 2017

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: engine misses when accelerating

Have the same problem with a 2.3, mechanic told me the cat converters were not allowing enough flow causing the problem. Transmission then went out and I wasn't able to confirm.

Posted on May 25, 2009

SOURCE: 302w runs at idle but under acceleration starts to miss

need to check fuel pressure and what output the coil has. This is measured in KV's,

Posted on Nov 18, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2000 ford windstar has a bad stumble when idling like it's missing accelerates fine when reaches cursing speed acks like it's missing also my cruise control stoped working


If your Windstar has the 3.8 liter engine, you are due for head gasket replacement. Just had mine done. The cruise control failure could be due to an open fuse or speed sensor failure.

Jan 10, 2017 | 2000 Ford Windstar

1 Answer

Acceleration problem


Could be a clogged fuel filter, could also be a slight crack in the throttle body gasket. get a spray bottle with water in it, set it to mist, while the vehicle idles, spray around the base of the throttle body, if it bogs down replace the throttle body gasket. Just curious, was it doing it before you changed the plugs and wires? If not make sure you have the firing order correct.

Dec 24, 2013 | 1997 Nissan Pickup

1 Answer

Random multi miss fire, I have replaced MAF sensor, can shaft sensor, plugs, wires, fuel filter, I checked coils, I checked fuel presser; reset computer, cel keeps comming on for random multi miss fire,...


Some general thoughts - -
when you try to accelerate, a couple of things happen. The engine shifts sometimes, and you put it under a load unlike when it is idling.
Is it possible a wiring harness or a hose is moving when you accelerate ? Is it possible the fuel pressure or ignition module is not good enough to handle the engine under load ? Is the EGR opening early or something causing a vac leak and a lean fuel mixture ?

Jul 22, 2013 | Cars & Trucks

2 Answers

2001 Toyota Tacoma keeps stalling on start up.


Check the battery cables. I had the same issues with my 96 tacoma, The battery cable connection at the battery can be cranked down but still be loose. Hard to explain, doesn't make sense, but just check it out.

Jun 23, 2012 | 2001 Toyota Tacoma

1 Answer

Acceleration problems ,at hiway speeds, needing more speed car downshifts sputters misses then eventually snaps backto normal whats up?


Ok. I'll give you my best guess, although I am not a Dodge Stratus expert. Based upon your description of the problem, I am to assume that the vehicle has problems accelerating up to speed, but once there, cruises ok unless you are going uphill or need to accelerate quickly, then power falls off rapidly and acceleration returns very slowly. If that is accurate, I would suspect the EGR valve. This is because at ihighway cruising speeds the EGR valve is pretty much wide open, letting exhaust gases back into the intake. When you need to accelerate, pressing the accelerator results in intake vacuum drop. This is partially compensated for by closing the EGR valve. If the EGR fails to close or sticks partway open, the exhaust gases will lower intake vacuum even further, and rob engine power. This can also cause the onboard computer to force a downshift to the transmission, as vacuum sensors are used to determine engine loading and the need to reduce gearing. In addition, a partially open EGR valve can cause erratic idle as it affects static intake vacuum (EGR is normally closed at idle) and the onboard computer must continually compensate, resulting is unstable idling.

Dec 04, 2011 | Dodge Stratus Cars & Trucks

1 Answer

1988 Toyota Camry 2.5 liter V-6. Engine starts fine, but after started it misses. The car misses terribly under a load, but will sometimes accelerate smoothly if you accelerate at a very slow pace. Will...


most misses are injector related either from dirty injectors , low fuel pressure ow injector wiring faults
use a quality injector cleaner for a tank or two
run the fault codes to check for other related sensor problems

May 23, 2017 | 1988 Toyota Camry

1 Answer

I have a 1998 Mercury Topaz that starts to miss under acceleration and can hardly make 100k per hour. Ignition system is ok. The problem seems to be in the fuel system. New fuel filter installed and...


Even tho the ignition seems ok, I'd check the ignition cables to the plugs. Sometimes these break down over time... it will idle and drive ok, but when you need power for a hill, or acceration, that's when the wires faults start to show up.
A quick test is to put the car in drive with your left foot on the brake FIRMLY while you press the accerator... if the miss and lack of power shows up, it's usually the ignition cables to the plugs.
k

Jun 30, 2009 | Mercury Topaz Cars & Trucks

1 Answer

Loss of power on acceleration. engine bucking.


check transmission fluid.change fuel filter and air filter.try changing up on where you buy gas .because bad gas causes problems.

Jun 26, 2009 | 1999 Ford Taurus

2 Answers

Engine misses when accelerating DOWN THE RD


the idle controls could be the problem

May 02, 2009 | 2001 Ford Expedition

1 Answer

1991 toyota previa 132,000 ml. I have a problem with acceleration. The engine sputters when accelerating. I have completed a tune-up, and there were carbon deposits on the spark plugs.


I had a power problem, when cold idled just fine,when warm it would miss at idle, spudder on acceleration and sound just fine at higher rpm. found number three spark plug wire had burned through lower boot. Spark was firing to head at low idle. same wire burn twice with about 40000 mile between.

Aug 03, 2008 | 1995 Toyota Previa

Not finding what you are looking for?
1992 Ford Escort 4 Door Logo

Related Topics:

194 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...