Question about 1987 GMC Suburban

2 Answers

1987 Chevy Suburban 350 2wd not starting or running right

It only starts when I prime it by spraying something into the throttle body. Once running, it does pretty good in 1st & 2nd gears, but in 3rd, if I try to accelerate, it chokes down & dies. I have replaced: throttle body, a sensor on the side of the throttle body (I forgot the name of it), all spark plugs & wires, exhaust system (pipe, muffler, catalytic converter), fuel filter, & fuel pump. My transmission was rebuilt just a year or so before this problem started. Any help would be very appreciated.

Posted by on

  • timandjulie9 May 12, 2009

    Thanks for the help. I have already replaced the fuel filter & fuel pump. I can hear the pump pressurizing when I turn the key on. What electronic components are you talking about?
    Thanks,
    timandjulie9


×

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 36 Answers

What size engine do you have in it? And, how many miles on it?? Well, I guess it really doesn't matter. At first thought it sounds like you are experienceing a fuel problem, and changing the throttlebody didn't solve your problem. I would start by looking and checking my fuel delivery system. The fact that you had to spray gas into the throttlebody tells me that fuel is not getting there. I would start with the least expensive thing to fix first. Check your gas filters. These are often , OFTEN, overlooked as a sorce of problems, and are rarely changed and often overlooked, and are the problem alot of the time. If that dosen't cure your problem check your fuel pump. Make sure it is delivering the proper pressure. I would bet your problem would be solved, but if it's not then next I would check the electrical components of your fuel system.

Posted on May 12, 2009

  • Charlie Troy
    Charlie Troy May 16, 2009

    I answered this a couple of days ago, but I don't see the answer I posted so I will try again.

    The electrical parts I would test would be the ignition coil pack. You will need an ohm meter and disconnect the coil pack from it's source of power.. Then connect the probe's positive + cable to the positive side of the coil, then test each negitive - terminal of the coil. The resistance should be the same for each one. Next you will want to test the secondary resistance of the coil pack by probing the paired companion cylinders terminals of the coil. I hope I said that so it wasn't too confusing. It kind of sounded that way when I read it back, but it's pretty easy to do. BTW I had a problem real simular to your's on a 95 Bonneville. I thought it was fuel related, but it was the coil pack.

    Good luck my friend.

  • Charlie Troy
    Charlie Troy May 16, 2009

    Opp's, I forgot to mention the other thing I would check if the coil pack tested OK. That would be what is known as the crankshaft position sensor, that is if you vehicle is equipped with one.

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 23 Answers

It is located next to your throttlebody (like a small tube). CATALYTIC CONVERTER. A catalytic converter is a small unit located on the stock h-pipe that heats ... mufflers alone and have them welded into your stock exhaust system. ... Detonation is when the air fuel mixture ignites before the spark plug has fired.
1987 Chevy Suburban 350 2wd not starting or runnin - mac1.gif engine3.gif
(Engine Components d1987 Chevy Suburban 350 2wd not starting or runnin - 96tbp.gif.0 engine. Similar on 4.6L)
96tbp.gif
(Throttle Body)
mshds1.gif
(Shorty Headers)

Posted on May 12, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 89 Chevy Suburban Silverado STILL won't start! New coil, spark plugs, rotor, cap, relay,battery,inline fuel filter, fuel pump,solenoid.


Have you checked for spark at the plugs ? Spray some carb cleaner into the throttle body and see if it attempts to run as this can show a fuel problem .

Nov 07, 2015 | Cars & Trucks

1 Answer

MY 1987 CHEVY MONTE CARLO LS ENGINE RACES WHEN START IT UP.IT WON'T STOP TILL, MAYBE 7 0R 8 MINUTES


Two places to start. First clean the throttle body/carb. Brake clean and a tooth brush. Clean inside as best and deep as you can, clean the back of the throttle plate and were it seats the most. It will take a few seconds, start the car up and spray the cleaner in the throttle as you rev it up. Then after that, I would replace the engine coolant sensor.

Jun 07, 2015 | 1987 Chevrolet Monte Carlo

1 Answer

2006 Ford Explorer shifts hard between 2nd & 3rd gears, both up & down, but shifts normal between 1st & 2nd, and in & out of overdrive. All was normal then almost not working the next


It sounds as though your valve body may have a lot of particulates that have entered into it causing the valves to act sluggishly. Unfortunately, this is a condition that can only be taken care of by your mechanic and is not something that the average person can fix themselves.

Aug 28, 2017 | 2006 Ford Explorer

1 Answer

I have a 84 V65 Magna. When I get on the throttle in 1st & 2nd gear, it clunks (like it's skipping). It only happens only in 1st & 2nd gear. What's the problem?


I use to have the same exact bike. Mine did the same thing. My problem was in the transmission. In mime it was the teeth of my first and second gear were damaged. The bike was too old to invest the money to fix it.The person who owned it before me had miss shifted alot.I did it once and that put the icing on the cake.

Mar 16, 2012 | Cars & Trucks

1 Answer

Wont start


1st-Check Fuel(disconnect intake hose and spray carb cleaner or light fluid in the throttle body). reconnect and try starting. Check and listen to make sure the pump is priming itself when the key is switched on.
2nd-Check Fire(spark). Make sure that spark is getting to the plugs
3rd-Check Air(compression)

Jan 28, 2011 | 1990 Buick LeSabre

Not finding what you are looking for?
Cars & Trucks Logo

461 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...