Question about 1997 Ford Expedition

1 Answer

Radio i tried connecting a after market radio to a 97 expedition. but no sound or light came on any ideas what could be wrong?

Posted by on

  • Mike Wine May 11, 2010

    if no light, then there is a power supply problem. sounds the same with the sound. I would double check all the wiring for solid connections and to ensure you have wired it up correctly before troubleshooting over areas. I am assuming you pulled a working deck/stereo out.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 82 Answers

I hope you used an adapter to plug into the factory wires .... and if all your connections are correct ... I would verify that you have a good ground (touch a wire from a good clean bare metal directly to the radio's metal case) .... and check fuses .... Radio and clock fuses .... certain expeditions have amplifiers and subwoofers built into them and may not be compatible with your radio .... need more info

Posted on May 09, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ford stock amplifier


need to wire the power wire for the amplifier to the remote wire on the aftermarket radio usually a blue wire on the after market radio

Feb 20, 2013 | 1998 Ford Expedition

1 Answer

Battery on 98 Ford Expedition doesn't hold charge


First thing I would do is have someone qualified disconnect the alarm and stereo and start over.
Chances are you have circuits cross-connected and something is draining the battery.

Jan 14, 2013 | 1998 Ford Expedition

1 Answer

1998 Ford Expedition with premium sound system. I removed the factory radio and installed an aftermarket radio had no sound coming from it, so I disconnected and installed the factory radio back in the...


Go to the engine fuse module and check 20A fuse 5 which feeds power to the separate amplifier and subwoofer amplifier. Also check 10A fuse 3 which feeds power to the radio, the CD changer, and the rear integrated control panel.

Oct 16, 2012 | 1998 Ford Expedition

1 Answer

Brake lite wont go off..brought to dealership & after examining the car...it's due to the radio..all the "idiot" lites are connected thru the radio? Sounds funny to me..Thanks


you have misunderstood ,the brake and indicator lights work on one unit unlike europe which is seperate ,so you have a problem with the side lights whch have a feed to the radio for the panel lights ,also the side lights use the same bulb as the stop lights 12v 21watt and 6 watt and somehow the wiring is faulty and i suspect that the radio is connected wrongly using the feed from the lights instead of a different feed ,had this a few times with becker and grundig radios in europeon mercs and BMWs ,rev counter and speedo dont work among other things ,cause a weekend mechanic fitting a after market radio

Jan 17, 2011 | 2004 Buick Century

1 Answer

Map light stays on after starting, 97 Expedition


Trade the bulbs with each other, and see if the problem transfers. The bulb could have a bad connection.

Dec 31, 2009 | 1997 Ford Expedition

1 Answer

Smog


Either a burnt bulb, or a fuse. The check engine light has nothing to do with the radio.

May 29, 2009 | 1997 Ford Expedition

1 Answer

1996/1997 Ford Windstar Audio wiring diagram


1997 Ford Windstar Car Stereo Radio Wiring Diagram
Car Radio Constant 12v+ Wire: Green/Violet
Car Radio Switched 12v+ Wire: Yellow/Black
Car Radio Ground Wire: Black/Light Green
Car Radio Illumination Wire: Green
Car Stereo Dimmer Wire: N/A
Car Stereo Antenna Trigger: N/A
Car Stereo Amp Trigger Wire: N/A
Car Stereo Amplifier Location: N/A
Front Speakers Size: N/A
Front Speakers Location: N/A
Left Front Speaker Positive Wire (+): Orange/Light Green
Left Front Speaker Negative Wire (-): Light Blue/White
Right Front Speaker Positive Wire (+): White/Light Green
Right Front Speaker Negative Wire (-): Dark Green/Orange
Rear Speakers Size: N/A
Rear Speakers Location: N/A
Left Rear Speaker Positive Wire (+): Light Brown/White
Left Rear Speaker Negative Wire (-): Light Brown/Yellow
Right Rear Speaker Positive Wire (+): Light Brown/Green
Right Rear Speaker Negative Wire (-): Brown/Pink

96 and 97 are the same

Apr 07, 2009 | 1997 Ford Expedition

2 Answers

Thermostat lights wont come on


Check the in dash lights to see if they are burnt out or you have a bad connection or bad wire. this could be do to having an after market sound system.I had similar problems with a 97 Plymouth Breeze i.e. loose connection.

Feb 05, 2009 | 1996 Ford Taurus

Not finding what you are looking for?
1997 Ford Expedition Logo

Related Topics:

251 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...