Question about 2001 Mitsubishi Montero

1 Answer

Radio wont go back on

Took off the positive cable to clean it then put it back on the radio wont come back on

Posted by on

  • yadayada
    yadayada May 11, 2010

    u have locked the radio out, u must enter the unique security code to get it working, the dealer is the only one that can get this for you if u don't have it, it came with the car when it was sold new.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 201 Answers

Check fuse block for blown fuse

Posted on May 09, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

2005 Chevy Aveo that won't start. Lights etc. turn on and there is a clicking sound but car won't start.


Check the positive cable going to the start and the negative cable going to the ground,are the cable tight at the battery.

Jun 11, 2017 | Cars & Trucks

1 Answer

2000 f150 not starting


I would start by checking to see if the battery cables are clean and tight. Look for broke or disconnected wiring. Is the shifter all the way in the park position? Chek to see if the starter motor pinion is jammed in flywheel ring gear. Starter solenoid might be faulty. Then check the ignition switch and system. Hope that Helps.

Feb 02, 2014 | GMC Cars & Trucks

1 Answer

I resently did work on my 97 gmc jimmy and took out the battery. when in got done and put the battery back nothing worked. no lights no radio no nothing. now my battery was charged and theres power going...


It's a cable issue. What type of work did you do? Anyway there are two cables coming from positive terminal, one straight to battery one to pdc (fuse block) gm has poor set up there clean retighten not too tight. Or during your work a ground was left loose or undone. Security not the problem. Turn on headlights wiggle either cable till they flicker thats where problem lies.

Mar 17, 2013 | GMC Jimmy Cars & Trucks

1 Answer

I TOOK OFF A BATTERY CABLE TO TURN OFF ENGINE


Turn the ignition to radio position and wait. This may take anything between 10 minutes and four hours, so be patient. When the radio wakes up and asks the code, punch it in.

Dec 21, 2009 | Volvo 960 Cars & Trucks

2 Answers

Car wont start radio,wipers,gauges,turn signals dont work


Check the battery cable ends to be sure they are tight and wont twist, I had this happen on my 96 grand caravan two years ago.

Aug 21, 2009 | 1996 Dodge Caravan

1 Answer

Took off the battery to clean positive cable radio wouldnt come on so what is the problem?


most likly the car you are working on has a radio code for anti theft check your owners manual for the step by step and the code to be able to turn it back on

May 09, 2009 | 2001 Mitsubishi Montero

1 Answer

I took the HOTT battery cable off and put it back on and now it will only click i think its the starter relay its a 2000 mercury sable 24v


First clean your cables and the posts on the battery make sure they are tight and clean also check the positive cable going to your selonid it could be loose and at the starter

Mar 17, 2009 | 2000 Mercury Sable

1 Answer

Radio wont work but navigation and tv working


Dude, i had the same problem. I tightened up the relay from the positive terminal on the battery that sits right next to the terminal, i took off the negative and put it back on, and unplugged the wires that go from amp to speakers and plugged them back in. started working fine. It would be your best bet to reset the comp by taking off neg. and putting back on.

Feb 04, 2009 | 2003 BMW 330

Not finding what you are looking for?
2001 Mitsubishi Montero Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...