Question about 1990 Jeep Wagoneer Limited

2 Answers

Car runs good for about 15 minutes then just dies. Starts right back up and runs good but when you take your foot off the pedal it dies. Put it away for the night, got in next day to see if it still does it. It goes again real good, then half way across town it just dies when you take foot off accellerator. It doesn't spit or sputter, no indication, just dies. It is a 2003 Mtz. Elclipse GS 4 cyl.

Posted by on

  • David Bellis Nov 28, 2013

    Hi sbaret , I want to help you with your problem, but I need more information from you. Can you please add details in the comment box?

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jeep Master
  • 5,648 Answers

DID YOU change,air filter,fuel filter,clean throttle body.One more thing you can bring up low idle.Rpm 700 to 800.What you have right now.

Posted on Nov 28, 2013

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 435 Answers

Sounds like you need to take it in to a service dept and have the primary module reset. If I'm not mistaken, in that year and model, everything works off of a computer "brain", like a CPU in your computer. If this is the problem and not a fuel line issue, you will need the service tech to put your car on their equipment to fix this issue. It can't really be done in your garage with a wrench. Sorry.

Posted on Nov 28, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 6 Answers

SOURCE: my car starts and then dies

sounds like a security issue they installed a factory security system which will prevent the vehicle from running unless its reset go to passenger door lock turn key twice it worked for me after chasing other problems for a few hours

Posted on Jan 14, 2009

  • 1 Answer

SOURCE: 1995 Jeep Wrangler 2.5 4cyl spits and sputters while driving

have you considered checking alternator and battery? just a thought

Posted on Apr 01, 2009

  • 6982 Answers

SOURCE: wont hold idle will start with foot depressing gas pedal will run with foot on gas but stalls when foot removed

Check and clean Idle air control valve. Make sure its responding to signal as well. Also make sure ther are no vacuum hoses disconnected. This may not be a "cure" but it's a good place to start.

Posted on Apr 14, 2009

  • 1 Answer

SOURCE: 2003 jeep liberty starts but shuts down right

usually need throttle body and idle air control motor cleaned

Posted on May 04, 2009

duane_wong
  • 6826 Answers

SOURCE: my 2003 jeep wrangler 2.4 liter motor , spits and

what codes do you have on it?

Posted on Jul 16, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car dies when going over really bumpy roads


If the brake pedal goes hard right BEFORE the car dies, and not after, then you could have a problem INSIDE the brake power booster. try to verify this next time it dies at a stop, if you can safely pull the dead car off the road into a driveway (or try to make it stall in a bumpy parking lot) - then before you try to restart the car, open the hood, pull off the rubber hose where it's plugged into the brake power booster --> you SHOULD hear a big "Swoosh" of air being sucked into the booster because there's supposed to be a strong vacuum there even after the car stops running. if you get nothing there, your car is dying of an excessive vacuum leak through the brake booster.= bad booster.

Aug 10, 2012 | 1992 Buick Century

1 Answer

My 1998 dodge caravan won't stay running. starts up but shuts down instantantly or when i take my foot off the gas pedal,


ok i have a 1998 durango with the 5.2L 318 engine. had trouble with a bad cell in my battery. I went out bought an optima red top battery for it 800cca. put it in and had same trouble. No start without putting foot on gas. wouldn't stay running without holding foot on gas. CPU has to relearn it's programming once you unplug it for long periods of time. mine was without power for about 2-3 weeks till i got new battery. Start with this.. first check under air filter make sure a squirrel hasn't made a mess under your air filter and it's clogging the air intake. Then pull off the lid to your injector cover ( the screw down lid coming from the air box ( with air filter in it) to "carb") make sure all your cables move freely. put that all back together and close hood. Start truck with foot slightly on gas pedal to get started. keep it at about 1k to 1500 rpm for about 1-2 minutes. Rev motor to about 2500rpm and let it die out if it will. Get out lock doors with key fob if you have it. if not make sure to lock doors. ( trust me it worked for me) let sit for 5 minutes. come back out and unlock door and relock door 3 times with fob ( if you have it ) or key if you don't have a fob. Then unlock it with the key and enter vehicle. Start truck as before and keep it around 1k to 1500 rpm again for about 30 seconds rev it up and should keep running. Mine did. I think the iac was stuck from sitting and has now since loosened up.
Good luck hope ti works for you.

Jun 05, 2012 | 1998 Dodge Caravan

3 Answers

Car dies when stopping, then starts up


Throttle body or idle control valve, with both of these faults you can normally get away with cleaning them.

Feb 18, 2012 | 1997 Pontiac Grand Prix

1 Answer

Car starts after taking foot off gas car shuts down 2001 mit 3.0 v-6 spider


For this problem, i suggest you to go through this help links.Click the link below to go through the troubleshooting procedure :----Car Idles rough and quits when gas pedal is pressed less? http://technoanswers.blogspot.in/2012/01/1999-ford-f-150-idles-rough-and-quits.html-----------Car only starts when gas pedal is pressed? http://technoanswers.blogspot.com/2012/01/car-only-starts-when-gas-pedal-is.html
-----------Car won't start without hitting the gas pedal? http://schematicsdiagram.blogspot.com/2011/12/car-wont-start-without-hitting-gas.html
---------Car dies when gas pedal is pressed? http://schematicsdiagram.blogspot.com/2011/12/car-dies-when-gas-pedal-is-pressed.html
------------Pushing on the gas pedal, but the car slows down? Gas pedal to the floor and the car slows down? http://technoanswers.blogspot.in/2012/02/pushing-on-gas-pedal-but-car-slows-down.html
-----------This will help.Thanks.

Feb 15, 2012 | 2001 Mitsubishi Eclipse Spyder

1 Answer

I have a 93 Dodge Colt 1.5 liter engine. I've noticed in the last month or so after it starts that the idle seems to go high and take 15 or 20 seconds to get back down to normal. Two days ago I went to the...


Its probably your computer. Had the same thing happen to me about ten years back. About 500 dollars. better off finding one on ebay or at a junk yard.

Aug 09, 2010 | 1993 Dodge Colt

1 Answer

Roaring loud noise will come on while in drive with my 1999 couga


leaking seal on vacum booster where rod from brake pedal enters. will go away until it gets severe

Jan 19, 2009 | 1999 Mercury Cougar

1 Answer

Loosing power at cruising speed


Hi. I have two Dynasty LE cars, (a 91 and a 93). Both have the 3.3 litre. The 1991 had almost the same problem as yours except it would only do it once the engine warmed up, (similar to your freeway issue, given distance and time for the engine to warm up to operating temp.) I had it in about three shops before the dealer found an intermittent fault with the cam and crank sensors. I replaced them and now it runs just fine. I hope this helps.

Sep 08, 2008 | 1989 Dodge Dynasty

Not finding what you are looking for?
1990 Jeep Wagoneer Limited Logo

61 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Kevin Daniels

Level 3 Expert

1455 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...