Question about 1990 Buick Century

1 Answer

1990 BUICK CENTURY RAD.COOLING FAN RUNS ANYTIME KEY IS ON.

SWAP FAN RELAY STILLRUNS CHECK TEMP. SENSOR WITH SCANNER SHOWS NO PROBLEM UNHOOK SENSOR STILL RUNS. I KNOW THAT COMPUTER TURN ON FAN AROUND 200 PLUS DEGREES AND ANYTIME A/C OR DEFROST ARE ON IT WILL RUN.I DO NOT HAVE A GOOD WIRING DIAGRAM TO LOOK AT . ALL THE WIRING I CAN SEE LOOKS OK. ANY HELP WILL BE WELCOMED.THANKS.

Posted by on

  • yadayada
    yadayada May 11, 2010

    230 is the temp the fan goes on. u would not believe how many people can't accept this, but that is what it is set for.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 36 Answers

If you have changed out the relay, and disconnected the temp cooling sensor, make sure you have replaced the correct relay; I believe there is one bank of four relays located by the passenger side head lamp. If the fan is running continuously, then I would say the relay is stuck in the closed position, resulting in completing the electrical circuit, powering the fan. Have the new relay tested. You can find a wiring schematic in the Hanes manual for your make and model.

Posted on May 28, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Buick Century 3.1 cooling fans not working.


Check the wiring harness to the fan they sometimes put a fuseable link in the wire and it might of blown.

Mar 19, 2018 | Buick Cars & Trucks

1 Answer

Why won't Rad fan run if fan motor, fan relay, temp sender all okay?


check terminals on the ECM
the circuit is when the coolant temp sensor ( not the gauge sender) reaches a predetermined setting , power is supplied to the ECM which in turn activates the fan relay and switches on the fan
there are normally 2 fuses in the circuit
the gauge sender is normally a single wire unit and the sensor unit has 4 wires to it

Nov 05, 2017 | 1993 Dodge Spirit

2 Answers

1995 Buick Century 3.1 Cooling fans not running. I have replaced the cooling temp sensor and the ECM the fans and relays are all working i have jumped out relays and both fans run. Check the coil of the...


You have done well so far, but this is a hard problem. Have you checked the reference voltage (usually 5vdc) that is going to the temp sensor? It might be getting pulled down by one of the other sensors on that wire. A way to check is to get a baseline voltage on the coolant temp sensor black wire. Then unpulg the map sensor--does the voltage on the black wire increase? If yes, replace the map sensor. If not, next unplug the A/C pressure sensor. Same process. Finally, unplug the transmission temp sensor. If unplugging any of these sensors increases the voltage on the black wire by say a volt, replace the bad sensor and retest.

0996b43f80216888-j1axptdruxmkgupulmd503d3-5-0.gif

Aug 21, 2017 | 1995 Buick Century

1 Answer

Is there a cooling fan switch on a 96 buick century if so where is it located


The engine temp sensor sends a signal to the computer and the computer grounds the fan relay when it is needed.
I'm showing 6 relays on the firewall under the windshield.
The two on the right side are high and low radiator fan relays.

Sep 29, 2012 | 1996 Buick Century

1 Answer

Overheating


If the temp goes up at idle and is fine when your driving at highway speeds than the most likley problem is the cooling fans are not working.

the first thing you can do is check to make sure both of the cooling fan fuses are good. you can also check continuity of the cooling fans with an ohm meter.

The cooling fans are turned on by the low and high speed cooling fan relays. you can try swapping the relays.

If the fans still do not come on than you will need a scan tool to diagnose further since the PCM is what controls the fan relays.

I’m happy to assist further over the phone at https://www.6ya.com/expert/jeremy_d728a59f986299fa

Feb 23, 2012 | 1999 Buick Century

1 Answer

Why does the temp gadge go up when the car is sitting still????


If the temp goes up at idle and is fine when your driving at highway speeds than the most likley problem is the cooling fans are not working.

the first thing you can do is check to make sure both of the cooling fan fuses are good. you can also check continuity of the cooling fans with an ohm meter.

The cooling fans are turned on by the low and high speed cooling fan relays. you can try swapping the relays.

If the fans still do not come on than you will need a scan tool to diagnose further since the PCM is what controls the fan relays.

I’m happy to assist further over the phone at https://www.6ya.com/expert/jeremy_d728a59f986299fa

Feb 23, 2012 | 1999 Buick Century

2 Answers

Is there a sensor for the radiator fan? Fan is not working.


These models have a radiator fan relay that activates from the coolant temp sensor, a two wired plug with a brass body screwed in nearto the thermostat housing (follow upper rad hose to engine). Replacing both components together is the known repair if fan isn't siezed.

Sep 03, 2011 | 1990 Buick Century

2 Answers

I have a 2002 Buick Century. When I am idling, the cooling fan does not kick on when it is supposed to. When I turn the A/C or the defrost on, the fan will come on. Is this a sensor problem? Where is...


THE COOLING FAN DOES NOT COME ON UNTIL 220 DEGREES IT SHOULD COME ON WHEN THE A/C IS TURNED ON OR DEFROST ON IF YOU THINK THERE IS A PROBLEM HAVE A SCANNER PUT ON IT AND IT WILL SHOW THE TEMP THAT THE FAN COME ON

Oct 14, 2010 | 2002 Buick Century

1 Answer

1990 buick century 3.3 engine cooling fan wont come on.


The fan switch is under the alternator. The turn on temp is 238. Have you checked power at the relay? If you ground the wire at the the temp switch does the fan come on?

Jul 04, 2009 | 1990 Buick Century

1 Answer

2003 park Ave running warm. possible bad rad fan relays?


the simplest way to check a relay is to swap it with a relay from somthing that you know works (eg. starter, or horn) if that item still works after the swap then the relay is good.

May 21, 2009 | 2003 Buick Park Avenue

Not finding what you are looking for?
1990 Buick Century Logo

395 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

80608 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...