Question about Toyota Cars & Trucks

1 Answer

Engine not starting

Engine jut cuts off thn just cranking with spark and fuel pressure ok.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 9,324 Answers

Check the spark plug to see if it is wet with oil or gasoline. If all is well there then look to the computer.

Posted on Dec 24, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

ftw1952
  • 10319 Answers

SOURCE: 2001 honda civic ex,wont start, no injector pulse,

Injector pulses are sent from the engines computer. Have that checked out

Posted on Apr 07, 2010

drsinister69
  • 2317 Answers

SOURCE: engine cranks but wont start when hot,spark ok,

I would check the camshaft sensor.

Posted on May 08, 2010

  • 4793 Answers

SOURCE: Mitsubishi Lancer 2002 1.3Ltr Gasoline Engine -

try reseting the immobiliser.?

Posted on Jan 31, 2011

  • 2187 Answers

SOURCE: 2002 WG Jeep Grand Cherokee

The error P1130 and P1131 is for the fuel trim and lean fuel mixture respectively. This tells me that this may be an issue with the air fuel mixture or its reached its limits in compensating for the incorrect mixture. You could try to clean out the intake first using carb cleaner spray or tuner spray to clean out the intake and the MAF sensor which measures the air that comes in. Check also if there are leaks or gaps on the air duct found between the air filter and the intake manifold and the intake plenum. Leaks would cause the system to get an incorrect reading. If it were a faulty sensor you should get the error code for the sensor and you may have issues starting the engine up.

Check also the vacuum hoses which may be loose or cracked that needs replacing or refitting. This is also a common cause. I also do not rule out the possibility of the fuel sensors going or starting to go bad. The PCV may also need cleaning or replacing.

With all mentioned items go check first the leaks of the intake system and the vacuum lines as these are found to be common. Some leaks or cracks are minimal but is crucial to the sensors.

Posted on Jun 22, 2011

parkerjohn
  • 130 Answers

SOURCE: My son has a 2004

Change the crank position sensor

Posted on Sep 15, 2011

Testimonial: "Thanks for the possible solution. I'll give it a try."

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have overhauled engine for Isuzu bighorn 1998 petrol/gasoline engine. the 6VE1.timing belt is ok. Still it has a had start.


is this the Single head cam or twin version?
no photo of engine, so answers will be weak.

double posted. is this the single cam or twin cam engine?????? per side, the twin cam has 4 cams. 2 /bank.
i can not understand your questions, at all.
ok you overhauled the engine,
nor can i understand , still hard start.
does that mean it cranks slow and turn runs and drive perfectly ?
or cranks fast, but hard to start and runs perfectly?
or does that mean it cranks fast, starts, then misfires and runs crapppy-pappy?
hark, the devil really is in the details, no?

Generic answer.
all the wires and sensors , hoses not put back correctly.
oil full, coolant full, fresh gas in tank,
then you crank engine with no spark (I pull fuses)
and the crank it until oil pressure is good. yah, do that.

if really savvy, we check for top end oiling next. cranked only.


ok looks like oil pressure is good,(I don't want to wreck a new engine) (also check compression on a new engine, to see if we messed up., if not 150psi or more, you timed it wrong)



then we crank it, ok, it cranks and don't start
I check spark and it's timing using my timing light, it's wrong, i retime it, no and its ok. as is ..
ok sparks good, on all 6 cylinders. checked carefully and for static time.

so now start engine on test fuel,
if fails, see above for why.!
ok it runs for say 2-3 seconds and stalls. good.
We yell at the gas engine gods. O'BOY my engine seems to be OK ! progress....

next is fueling , ill stop now, as typing a book on fuel injection
is not easy here.
but fuel pressure is next. on all EFI engines. as is good fuel.
when did car last drive perfectly, 1 month ago,
10 years. what?
if long ago, the gas is bad. as are related parts all gunked up, like filters, and injectors.
and even the pump, or its sock packed in GUNK.
as you can see we have no history on the car, so.
really anything is possible. even vandalism.

btw we never just throw and engine in a car.
we check.:
1: compression, gee even sitting on a pallet.!
why install (6hr labor) a dead engine,?
2: then cranked oil pressure, spark/fuel off line.
same reasons.
3: then if all that is ok, I do check top end oiling now, if not any top end, the cams will not last very long. they will smoke and seize up in a flash.

this is how its done correctly, ask how.

Aug 20, 2016 | Isuzu Cars & Trucks

2 Answers

Turns over but does not start


First thing you can do do is spray a little carburetor cleaner in the throttle body if it start you a fuel problem if it doesn't start you have an ignition problem go to autozone buy a cheap noid light remove the injector harness install the noid light crank the engine if the noid light blinks your ok as far as computer also get and old spark plug check for spark while cranking if you have spark igintion system ok ck fuel pressure might have a clogg up fuel filter good luck

Oct 02, 2015 | 2002 Ford Explorer

1 Answer

Does 1999 isuzu rodeo have a no crank security sytem ?


gas engine? sure.
no crank security system.
my guess is you mean the car has and Immobilizer option on car?
most cut fuel.
all have a light, if the lamp is not there, you dont have it.
key on, the cluster lamps tell you if it has IMMOBLIZER ACTIVE.
meaning .
so if the lamp is not there, or is not flashing or glowing cranking
then that is not the ISSUE !
sure we look first...
then we.......
1: check for spark. got spark to all cylinders
yes, if not scan the pCM cranking, it will tell you what spark is gone, 90%
2: yes spark is good, now i check spark timing with 20 buck light.
its way off, the cam belt slipped, FACT.
yes timing is ok.
3: all engine , not blown up overheated , all perfect for 3seconds on test fuel (you do that with spray) does it? if not sounds bad, it is.
if it goes, verrrooooomm stall, its GOOD>
repeat over and over, until happy, see engine and spark is good.
4: ok test fuel tests PASS muster.....
so that leaves what, fueling.
a: too much is called flooding, use WOT cranking to clear floods.
wot means wide open throttle or as ,truckers call it pedal to dah metal..
this cuts all fueling to clear flooding on all EFI engines.

b: no fueling, the spark tips are dry.?
check pump pressure after scanning PCM.

the ECU cuts fuel for 3 reasons. (pure logic)
a: Tps stuck WOT.
b: lost spark (ignitor or tacho dead)
c: lost CMP or CkP sensors (cam, or crank)
the ECU reports a and b, and not c. as c is a FEATURE not an error.

Jun 16, 2015 | 1999 Isuzu Rodeo

1 Answer

Why the car cranks up and stay runing for 2 min then it will cut offwhat could that be


when it stops check for a good spark at the plugs if ok check fuel pressure and flow replace fuel filter if pressure ok.

Aug 15, 2014 | 1997 Pontiac Grand Am

1 Answer

1988 2.5E s10 no fuel


you mean,cranks ok, but will not start and no fuel , right>?
s10 no fuel. 1988 ( S10 blazer )
please do say , what that means.
1: car cranks and will not start. so must be out of fuel?
(over 50 causes, or better is 10 or less tests (ask)
2: same, and fuel pressure is 0 psi (spec.9-13). gauged.?
3: fuel dribble test?
4: sparks good so tired test fuel and it ran on test fuel ok? proving
loss of fueling>?
5: injector dead cranking, (eyeballs)

which was it?

1988 cars in the USA are BIG TIME TRANSITION year.
we went from CARBS to EFI.
2.5L (what is E)?
gear cam, roller HLA lifters.
your car, USA , is TBI engine,
TBI started on THIS car in 1985 (1/2 and 1/2)
Throttle body injection
an on all TBI engines, one can see it inject with eyes.
does it?
if not it can be the following things.
1: no fuel pressure, 9-13pis.
2: ECU is cutting fuel. Pressure good cranking.
2a: ECU is sending error for bad crank/cam sensors, and cuts fuel.
2b: ECU sees rpm or tacho line dead.
2c. ECU sees TPS sensor output as 4v or more cranking, this cuts all fuel.
3: if ECU is happy, it sends 12vcd to the pump, cranking.
all tests must be dont cranking or chase tail.

Jun 17, 2014 | 1986 Chevrolet S-10 Blazer

1 Answer

Where is the fuel pump cut off switch located on a 1997 geo prizm


why do you think it has this?
why not post symptoms
got zero fuel pressure cranking? or 30?
EFI runs large pressure or the injectors all FAIL.

we can work symptoms, not phantom , missing switches.
im not even going to look.

post the symptoms first. Example. 1.
does it crank y/n (yes)
does it start, no.
does it have spark on all cylinders, y/n
guess yes,
does it start and run on test fuel for 3 seconds?
yes,
ok , test fuel pressure next. (28psi is lowest on about all cars made)
which engine you have?
7AFE toy engine?

Apr 25, 2014 | 1997 Geo Prizm

1 Answer

I have a connector comming from the fuse relay center in the bunch of whires that is not connected and is a red wire which i know is a hot wire what do i do? connector is small and black comming out o


confusing, 1990 , CADDY a TOYOTA Escalade?
CHECK ALL FUSES in BOTH FUSE BOXES. first.

all cars have huge options, and one harness.
so vast numbers of connectors are just there. ignore them.
seems... seems in science is no good, we work in absolutes.
or better valid ranges. (as a pilot says, "in the envelope")
ill try to answer both cars, the relic toy and 2000 CAD


we fix cars by diagnosis.
the first is to tell the helper what is wrong.
it dont start. (right?
and you check both fuse boxes, for blown fuses, right?
do you have spark? y/n? on all spark plugs.? y/n
if you have spark does spray in test fuel start engine
even for 3 seconds>? a key test.
yes, then you have low fuel pressure.
no, bad engine. (or you lied about spark , lol)

now fuel pressure.
the ECU can cut fuel and pump if it sees spark go bad
this prevents crash and burn,.like as seen on TV.
connect a scan tool is there DTC 340,355 being thrown cranking 5 seconds. yes, bad crank/cam sensors. or RPM is 0 cranking
bad ckp. senor.

so, rule 2, the ECU, many not, (READ FSM) run pump
until it is cranking
so you check for 12vdc at the pump cranking,
ok i got 12v
i then check fuel pressure with a real gauge.
it see 0psi, bad pump. see 10 psi bad pump or stuck open fuel
40PSI normal there is a range, but ask.
pressure reg. see 65PSI, fuel pressure reg stuck closes or return line blocked.
no guessing ,simple tests tools $80 total.

so does test fuel run engine> do that.
ever do a tune up?
ever check spark plug tips for wet or dry , after a failed crankup?
dry, no fuel. add some.
wet ,flooding.. crank using super secret WOT.


ok a direct quote from the FSM TOY.
  1. Using a jumper wire, short terminals FP and +B of the check connector.<< this is the diagnostic port.
  2. Turn the ignition switch ON, but do NOT start the car.
  3. The fuel pressure should read 38-44 psi (265-304 kPa).
  4. If the pressure is too high, the pressure regulator is probably defective. If it is too low, check for the following:
    1. Fuel hoses and connections for leaks or restrictions.
    2. Defective fuel pump.
    3. Clogged fuel filter.
    4. Defective pressure regulator.
now the direct quote for CAD FSM.
what engine,there are many?
rule 1 , 2000
ever scan the ECU/PCM for error cranking or must we do this the hardway.
hard:
key off
pressure gauge on rule rail
not started engine.
60-66 psi is normal. (books shows scan too activate)

the FSM shows the leak down test too, at this port.
it also says using CAD scan tool command on the fuel pump.
says tool only allows 2 seconds run time,
but you can check it cranking or cranking then key
off see how fast 60psi drops.
there are many pump tests. and the leak down rate
and injector leak down test.
all this requires a fuel pressure gauge
and reading the tests on alldata.com or buy the full FSM from CAD.

Im sure the CAD only has pump power (12v) cranking and running
and running it drops about 10psi and rises at high altitude.
they wouldn't need

PUMP operation rules are complex.
this is all hard coded in the PCM brain this logic.
most cars are,
if sparks good, and not W.O.T cranking and cmp and CKP are
happen run pump and inject.
if not , cut fuel.
some cars cut the pump after 2 seconds running, its hard coded logic. if spark is bad.
many mech dont know this. but the only variace ive ever seen is
some cars do make fuel pressure. just key on, for 3 seconds.
mostly older cars.
my guess you posted in the Toyota section?

Dec 29, 2013 | 1990 Toyota Corolla

2 Answers

We have a Subaru Legacy GT, Twin Turbo 93, the car cut out and will not start, no fault codes, replaced spark plugs, fuel filter, checked the fuel pump, replaced air flow meter, engine temperature sensor,...


sounds like your timing may be off, or have a crank shaft postion sensor failing, when it cuts are you losing spark completely? do you have a fuel pressue gauge? whats the pressure? also you could try running it with the map sensor unplugged and see if the condition improves

Jul 31, 2011 | 1993 Subaru Legacy

1 Answer

Galant Special Edition 1994 Motor does not start


this maybe caused by no fuel or faulty fuel pump, ignition coil, wire and plug crank position sensor. first check for spark by removing on spark plug wire and put a spark plug in the spark plug wire boot, donot touch the plug only the boot have someone crank the car over. if you see spark, that part of the ignition is good. if not, check the coil resistance if should 40 to 80 ohm with a volt meter pf not replace. if ok, but no spark check the igniton control madule make sure the coil and module are receiving current. if not check the fuse that feels them. if it is ok, check distributor cap and rotor. if rotor and cap are fine, check for fuel at either the fuel filter, the fuel return line or removing some spark plug and see if they are wet. if there is no fuel check the fuel pump and the fuse and relay that control the pump. if there is fuel with high pressure but there is no spark, check the crank sensor for signal with a volt meter while cranking the vehicle

Jan 02, 2009 | 1993 Mitsubishi Galant

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...