Question about Cars & Trucks

Open Question

Location glow plug relay on peugeot 807

Glow plug are only on for approx 2seconds and car will not start

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

snownbird33
  • 120 Answers

SOURCE: Glow PLugs and Relays

Good Day
The glow plug relays are located on the right front shock tower. Remove the cover and you will see two relays If I remember I think they are round, but not sure.

Please let me know how you make out and if there is anything else that I might be able to help you with.

Cheers

Posted on Sep 17, 2008

  • 1 Answer

SOURCE: No glow plug light, car turns over but won't start, no CEL or codes

I don't have the solution but a possible help in diagnosing.  If you remove the water temperature sensor connector from the sensor, the glow plug light should stay on when you go to start the car.  Try leaving it on for 15 seconds and then start the car.  If it starts right away, it is your sensor.  If it doesn't, the good luck.  
The sensor is located on the right side of the engine near the top, at the back.  It is in the coolant fitting directly behind the hose from the rad, just left of the thermostat.  Be careful to disconnect the wires, and not remove the sensor, or you will loose a lot of coolant.  The sensor is held in by a separate plastic clip, and the harness just has a little built in clip on the side.  Hope you have small hands...

Posted on Jan 06, 2009

  • 119 Answers

SOURCE: volks wagen golf diesel tdi Nreg

Check the glow plug thermo sensor...found in the cylinder head.
Unlightly anything wrong with injector pump.
Good luck
John

Posted on Feb 27, 2009

  • 43 Answers

SOURCE: where is glow plug relay on a 2007 f350 6.0

I can solve this problem for you but I need the right information. They have your truck listed as a 2003 F-350. Then it is also listed as a 2007 and want to know where the glow plug relay is. I need the correct year and model with the proper engine displacement.

Posted on Apr 14, 2009

  • 1071 Answers

SOURCE: glow plug light on dash does not light up on my

light only comes on when it is cold enough for glow plugs to work they are not needed when air temps are 60 or better so this may be what the issue is if there ws an issue the check engine light would be on

Posted on Jul 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

After starting the engine, approx 1 minute later the glow plug indicator light comes back on and stays on.


check for a problem relay for the glo-plug, short in the relay control wires after the relay

Sep 24, 2015 | Cars & Trucks

1 Answer

MY 6.0 TURBO DIESEL IS HARD TO START


I drive a 2004 F-350 with a 6.0l. 5 glow plugs are out, have to start on ether when temp is below 40 deg F. CAUTION turn key on, wait for glow plug light to go out, spray approx 3 seconds, start. Should crank about 3-4 seconds then fire off. I work on heavy trucks by trade, mainly roadside service work.

Oct 22, 2013 | 2006 Ford F 350 Super Duty

2 Answers

Volvo v70 diesel glow plug ligh on and goes off after approx 3 secs engine turns and doesn't catch in very cold weather, -7c


Volvo V70TDI 1998 starts slowly at -2 glow plughs are working, still got with fumes after the car stated;
What to do??

Dec 17, 2010 | 1998 Volvo V70

1 Answer

I have a '99 vw beetle diesel that did not make any noise at all when I tried to start it this morning. The lights were working and the battery was replaced 2 months ago when a new alternator was...


will try to help. your problem most likely are your glow plugs, unless you're not waiting on the wait tostart light to go off before you attempt to start it. you can try cycling the key switch several cylcles before attempting to start it. that works most of the time. easy fix to just replace the glow plugs. they heat the cylinder up to start the car in any weather.please do not attempt to use a starting fluid as you can cause major engine damage!!! thank you for choosing fixya.com

Nov 12, 2010 | 1999 Volkswagen Beetle

1 Answer

The glows are not working ,the relay is not giving an order to the glows,mercedes bens E320 cdi 2005


WITHOUT ANY OTHER INFORMATION, I WOULD CHECK THE GLOW PLUGS RESISTANCE, THEY SHOULD ALL BE LOW, APPROX 2-3 OHMS. IF THEY ARE GOOD, THE GLOW PLUG RELAY WOULD BE MY NEXT GUESS. I HAVE REPLACED SEVERAL OF THOSE.

Jan 19, 2010 | 2005 Mercedes-Benz Mercedes Benz E320 Cdi

2 Answers

There doesn't seem to be power to the glow plugs when there should be


How did you determine there is no power getting to them? If the glow plug light comes on and then turns off immediately, that is the glow plug controller telling you the glows are burnt out.

Test the glow plugs by using a multimeter with an ohm tester. Take the engine cover off and pop the glow plug wires off the glow plugs. They should pop off like a spark plug wire. Find a suitable ground and place the positive lead on the glow plug. It should read approx 1.0 ohm resistance give or take 0.5 ohm. If you find that you have one or more plugs with either high resistance, no resistance, or a large variation between the 4 plugs, then you have likely diagnosed the problem and the plugs need to be replaced. If they are all the same or within .1 or .2 ohms, then the plugs are not the problem.

Beyond that, make sure you have done the obvious and check the fuses. The relay may need to be replaced as well. Good luck.

Dec 02, 2009 | 2003 Volkswagen Jetta TDI

1 Answer

Ford escort 55 van van starts after 3 or 4 atemps once warmed up starts 1st time?


You havent said which engine you have got so I presume it is the 1.8 diesel. Therefore, when you go to start it when it is cold, wait for the glow plug light to go off then wait approx another 15 seconds as the glow plugs continue to heat up after the light goes off before you try to start it.

Apr 22, 2009 | 1997 Ford Escort

1 Answer

Vauxhall vivaro wont start cold


Sounds like a faulty cold start assistor. On top of the engine you will find an aluminium housing with four things that look like glow plugs screwed into it. These 'glow plugs' are only available complete with the housing fron Vauxhall. Approx £70 +
Airbag light is probably a fault with the seatbelt pretensioner.
Check the wiring under the seats for damage or perhaps the plugs have pulled apart.

Oct 30, 2008 | 2002 Volkswagen Eurovan

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

247 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...