Question about 1999 Nissan Maxima

1 Answer

The speedo sensor was not plugged in all the way. The mechanic plugged it in and everything seemed fine. However, I noticed a milky oil like substance was leaking from my home when I got home. Could it be that a bolt was not tightened causing a leak in gear fluid? I took the car to Pep Boys and they said it needs a transmission which I pray is the wrong diagnosis.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Nissan Master
  • 808 Answers

Is this a standard transmission or automatic? If standard transmission if the entire speedometer gear assembly was left out then water could enter their. If automatic besides the gear then water can enter through the oil cooler on the bottom of the radiator.

Posted on Nov 25, 2013

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

ButtFuzz
  • 463 Answers

SOURCE: leaking transmission fluid

Does this vehicle have a transmission pan? If so, is there a gasket betwixt pan and motor? Bad gasket? Or is the leak out the side/back of the tranny where the seals are?

Posted on Mar 05, 2009

  • 8 Answers

SOURCE: Nissan Altima 2000 - Engine oil leaking problem.

replace the front oil seal. first i would clean the engine with purple power (degrease etc.) then look at the engine and make sure the leak is not coming from above like possibly the valve cover gasket or from the oil sending unit. try to tighten the bolts on the valve cover and even the oil pan. you never know, you may get lucky. i don't know where you are but front seals are cheap but the labor on the job is what costs you.

Posted on Jun 16, 2009

  • 1 Answer

SOURCE: PO420 DTC code on 02 Nissan 2.5 Altima

i found out the cat bein broken up and suckin into the fudgin pinstons....good luck everyone

Posted on Feb 04, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why is my traction and abs light on and making my car stale out in forward if I dont press on gas hard and make it rev up


How competent were the mechanics. If everything worked fine until the brakes were done, I would suspect that they either damaged a wiring harness for the wheel sensors or had them disconnected and did not reconnect them. Did the garage not notice this problem when the tested the car after doing the brakes? No quality mechanic would let a car go in this condition. Check the wiring on the rear of the car for the ABS sensor and the like.

Sep 11, 2016 | 2006 Ford Fusion SEL

1 Answer

My speedometer does not work all of the other gauges work fine I am trying to fine a wiring diagram for under hood by computer


General advice:
Speed sensor /speed sensor plug.
Tips:Most old car use a mechanical speedo cable link instead of a speed sensor (that could be loosed,broken).
Cheers,share if u figured it out.

Oct 27, 2013 | 1996 Chevrolet Camaro

1 Answer

Milky oil cap on merc c180 2005


You havw a serious problem with water getting into the oil.
Most likely it is leaking from the head gasket. You mentioned that the head gasket was replaced 6 months ago. Did the cylinder head get re-tighten after several hundred kms. If not this should have been done to avoid this problem.

Dec 04, 2012 | 2005 Mercedes-Benz C-Class

2 Answers

I have a 1984 ford f150, I starts a runs until I come to a stop then It just shuts off...Whats wrong? I also have low oil pressure, and my dip stick for my oil looks kinda milky.


The problem you have is a cracked block. This allows water to get into your oil, and that causes the milky appearance. As you might imagine, this is not a good thing. You can try the block seal, but, there are no guarantees. Good luck. Oh, and by the way, it has nothing to do with the dip stick, just the water and oil failing to mix.

May 03, 2017 | 1984 Ford F 150

1 Answer

I have 2 questions. First of all I just got a 2005 Chevy Impala and the speedometer works when it wants to. I noticed that when I turn the key in the ignition the speedometer goes down and eventually will...


As for the first problem it could be a speed sensor in the transmission. Do you have a check engine light on? You need to drive it with a scanner on it to check the speed sensor. If the sensor is reading fine but the speedo doesn't read right you likely need to replace the cluster. As for the second problem, this is a common one on the 4t65E trans. You need to replace the Transmission Pressure Control Solenoid.

May 22, 2011 | 2004 Chevrolet Impala

1 Answer

I have a 2002 jeep liberty with 145,000 miles. I change my oil a month ago and check the oil today and notice i was a half qt. low. I notice oil building up around the intake manifold (left side). I have...


THis could be bad gasket or just bad seals. I would recommend to have the engine washed on your local garage or if you can do it on your own the better. Once cleaned you should be able to identify the source of the oil. Usually bad gaskets would also cause you to burn oil and cause smoke.

Apr 04, 2011 | 2002 Jeep Liberty

1 Answer

Water in intake...not much


sounds like a head gasket is leaking, or worse, one of the water channels is cracked in the head.

a teardown is your best bet... sorry for the bad luck

Mar 21, 2009 | 2005 Dodge Ram 1500

1 Answer

No gear at all


take ur gear box of and chech wear ur speedo plug is and if ur car run before ur plug got lost then yh thats ur proplem

Mar 04, 2009 | 1991 Mazda 626

1 Answer

Overheating and anti-locking brake and parking brake lights on


thermostat my be stuck closed. check radiator for gunk and junk, check oil if it looks milky then its your head gasket. to reset the check engine light disconnect the neg battery terminal for 30 seconds

Nov 14, 2008 | 1991 Dodge Dakota

Not finding what you are looking for?
1999 Nissan Maxima Logo

61 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

713 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...