Question about 2003 Chevrolet S-10

1 Answer

A/c does not get cold what type freon - 2003 Chevrolet S-10

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 147 Answers

134a dont put any with stop leak or sealer in your system... if it does not get cold you need to find the leak if its empty. so a must for checking the pressure on high and low side with manual gauges.... and compare ambient room temp with performance to see what the system is doing... if you put sealer in it later on ,,, alot of shops wont hook there recycler recover machines to it(your car)

Posted on May 07, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

MY AC COMES ON BUT DOESNT BLOW. COULD IT BE A RELAY FUSE AND WHERE IS IT AT?


COULD BE MULTIPLE PROBLEMS...LOW FREON = NOT COLD..BAD COMPRESSOR =NOT COLD=LEAK IN 1 OR MORE HOSES OR EVAPORATER OR CONDENSER =LOW FREON =NOT COLD.SO WHAT IM GETTING AT IS LOTS OF POSSIBLITIES,IF IT HAS THE PROPER AMOUNT OF FREON IN IT YOU SHOULD BE ABLE TO SEE IF THE CLUTCH IS SPINNING ON THE COMPRESSOR.CHECK ALL THAT I WOULD SAY TO PUT SOME FREON IN IT BUT IF YOU PUT TOO MUCH YOU COULD DAMAGE THE SEALS AND =NOT COLD FOR GOOD.THANKS AND GOOD LUCK.

Aug 04, 2011 | GMC Jimmy Cars & Trucks

1 Answer

Have no power to a/c compressor for my 1993 turbo diesel non-power stroke f350. checked fuses they are okay. jumped hot wire and ground over from battery and the compressor kicks on.


You have either a bad pressure switch or your system is to low on freon. pressure switch is located near evaporator close to fire wall to check use jumper wire across the 2 terminals if compressor turns on add freon the chances are that the switch is ok. make sure to add the freon on the low side of system and use a gauge on the fill hose (the better fill kits have the gauge on the hose). If you get cold air out the vents and then after a bit it doesn't seem cold you have a leak in the system. Make sure to use the correct type of freon should have a sticker under the hood. I think it should be R-134A but make sure the sticker will tell you the correct type.
Thanks for using FixYa Hope this sheds so light on your problem

Jul 15, 2011 | 1993 Ford F350

1 Answer

How do you replace the compressor? Is there an online mannual? 2003


Physically changing the compressor is easy. Just two freon lines, a belt, one clutch wire, and a few bolts.
But first you need to capture the old freon, which needs a vacuum pump and tank.
It is technically illegal to just vent it, and it is dangerous because of the pressure and cold. (wear eye protection and gloves)
You also need to add the right amount of the right type of oil, depending on the type of freon (a 2003 should be R134a).
But instructions should come with the new compressor.
Then you need to add the correct amount of freon.
If you saved it, then you just put that back in.
Otherwise the instructions should tell you how much to add.

Jul 10, 2010 | Cars & Trucks

1 Answer

My 2004 jaguar x type a/c blows cool not cold about 80 degrees.freon is full ,clutch kicks in although I don't hear it cycle on and off, the large a/c line gets cold, condensor is clean of debris,cabin air...


I don't have a solution but my old 2004 X-type has that problem when the outdoor temp hits bast 85 degrees or so. Will be interested in any fixes... I've had the outdoor thermometer changed and freon refilled, etc. but having the same issue...

Jul 16, 2010 | 2004 Jaguar X-Type

1 Answer

2003 Tiburon air conditioner won't blow cold air


Most likely your problem is the same as mine, which means you have a crack in your air compressor therefore no matter how full you fill the freon it will always drain (or blow) right out. Solution - get a new air compressor. Try to find one in a chop shop junk yard type place if you can do it yourself.

Alternate problem - freon can lose its charge. You can take it to just about any auto store and get the freon charged up for about $70. If that doesn't fix the problem it is likely the compressor.

May 28, 2010 | 2003 Hyundai Tiburon

1 Answer

My air conditioner doesn't work the blower works fine but no cold air the freon came out when I got home, just kinda gushed out all at once


explain in more detail, but it sounds like some type of failure when you say your freon gushed out all at once, sounds like a hose failure or seal , major o ring seal..? can you clarify ?

Aug 05, 2009 | 2004 Oldsmobile Alero

1 Answer

AC Is not blowing cold air. What type of freon


Your cars use R134. Older cars have to be converted to R134

Jul 11, 2009 | 2002 Dodge Neon

1 Answer

1999 Dodge Ram AC blows cold at idle and up to 40 mph


Most likely the orifice tube/expansion valve needs to be replaced. Depending on the type of system, you will have one or the other but they both perform the same function. The expansion valve is typically located at the evaporator inlet. Orifice tubes can be located at the evaporator inlet, in-line between the condenser and the evaporator, or in the condenser outlet. You will have to discharge the system in order to replace. Not very hard to do.

Jun 08, 2009 | 1999 Dodge Ram

2 Answers

2000 buick lesabre 3800 has warm air blowing out two driver side vents in A/C mode, but the two passenger side vents are blowing cold. any suggestions?


I had same problem on 2000 Lesabre blowing cold on passenger and warm on driver. I fixed it by adding more freon even though it had 28 pounds of preasure. Now it works great!

Jul 30, 2008 | 2001 Buick LeSabre

Not finding what you are looking for?
2003 Chevrolet S-10 Logo

Related Topics:

118 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

77544 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...