Question about Cars & Trucks

2 Answers

I have a 1994 oldsmobile 88 royale-the spedometer quit working and the engine revs very high when you start the car and it does not idle down,which causes the tempature to get hot quickly. help

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 46 Answers

Does it idle down after it warms up?

Posted on Nov 22, 2013

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 31 Answers

The speedometer may need to be replaced, or the wire may have been loosened or corroded. You'd have to take the cluster from the dash and check (also can check for power & ground to the wires to see if the gauge itself is broken or if there is a power/ground issue). The idle probably just needs to be turned down. You'll have to located the 'screw' under the hood near the throttle arm/spring assembly. Turning it counterclockwise will turn the idle down.

Posted on Nov 22, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 11 Answers

SOURCE: High idle.

try clean idle speed control.

Posted on Jul 05, 2009

  • 2 Answers

SOURCE: 1994 oldsmobile 88 won't start

if key has a chip in it the lock cylinder is bad it has wires that sense that chip i've got a new one pluged it in at base of steering column with new key in it and used old key as normal

Posted on Aug 09, 2009

  • 242 Answers

SOURCE: 1992 Oldsmobile 88 Royale.... won't start, but all lights come on

Try turning the key to the on postion-not crank, just to he postion right before cranking. leave it in that postion for 15 min, Do this three and after the third time go ahead an try to start it. Hopefully this will reset your security for you.

Posted on Aug 29, 2009

bschilz
  • 2049 Answers

SOURCE: Serpentine belt diagram 94 olds 88 royale

Here's a link to the serptentine diagram for our '94 Olds 88 Royale...

http://www.gates.com/common/part_locator/view_diagram.cfm?id=S6005

Posted on Jan 10, 2010

tayjoejoe
  • 2184 Answers

SOURCE: 1994 oldsmobile 88 won't start

Yes, the key,ignition, or Theft Deterrent Module is not funtioning properly. You can start changing these out 1 by 1, or bypass the whole system for about the cost of a new key. This link explains and will help you.

http://vatspasslockpasskeysecurityhelp.yolasite.com/

Posted on Jun 18, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1994 Oldsmobile 88 Royale 3.8 L engine motor races


clean the small breath hole in the intake at the bottom.

Aug 16, 2012 | 1994 Oldsmobile Eighty Eight

2 Answers

The idle runs too high on my 1994 oldmobile 88 royal.


You might take a close look at all your vacuum hoses for a leak or crack. This problem will cause the RPM s to run high.

Feb 08, 2011 | 1994 Oldsmobile 88

1 Answer

Where is the ECM located on the '94 Olds 88 Royale?


For 1994 Oldsmobile 88 3.8L SFI OHV 6cyl the Engine Control Computer is located front seating area, passenger side, under dash, mounted above kick panel.

Hope helps (remember to rate this).

Nov 09, 2010 | 1994 Oldsmobile 88

1 Answer

No heat


start with flushing your heater hoses and heater core to make sure that there is not blocks

Feb 02, 2010 | 1994 Oldsmobile 88

2 Answers

Need firing order for a 1994 88 delta royal


1994 Oldsmobile Eighty-Eight Royale FWD 3.8 liter V-6

8ed4254.gif

Good luck (remember rated this help).

Nov 26, 2009 | 1994 Oldsmobile 88

1 Answer

Shuts off while driving but starts right back up also after restarting it chugs down like it has trash in the line and idles realruff for about 30 seconds but finally smooths out and goes on for a lttle...


We had this same problem. It turned out to be the computer. We had the computer replaced and it worked great for awhile but now there's something else wrong with it. Hope this helps and good luck.

Oct 22, 2009 | 1994 Oldsmobile 88

1 Answer

Ihave a 92 olds 88 royale. car idles high on start up and starts to over heat


could be a few things. i suggest starting with check for vacuum leaks, and check cooling fan operation. hope helps

Aug 01, 2009 | 1992 Oldsmobile 88

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...