Question about 2005 Chevrolet Corvette C6

1 Answer

Won't start Car will not start. everything works as it should. no clicking ,no nothing when I push start button. Battery is an Optima and has 14 volts.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Chevrolet Master
  • 1,098 Answers

Check whether the battery terminals need cleaning for better contact. If are clean,check for the starter motor fault especially the solenoid is seized. Need an electrician for it.

Posted on Nov 22, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 116 Answers

SOURCE: 2007 chevy cobalt ls won't

Ignition relay or fuse could be the problem. When you turn the key to start do you hear a fuel pump kicking on and or do you have spark when you hot wire the starter (I know it's hard to check while trying to start it)? You can email me back and I might be able to pinpoint it more.

Posted on Jun 06, 2011

tayjoejoe
  • 2185 Answers

SOURCE: I have a 98 S

Ya, when the car is running, you're using power from the alternator. So it will show 14 volts as long as its running. The fact that it won't hold the charge means the battery is shot and you probably need a new one

Posted on Sep 11, 2011

  • 17 Answers

SOURCE: 1997 chevroley cheyenne won't start without jumper cables hooked up, when the jumper cables aren't hooked up the battery isn't even getting 9 volts, when they are hooked up the battery gets close to 1

it is poosible it may have a duff battery and it is the cheapest to replace. if that is not the issue then it is most likely your alternator.

Posted on Dec 02, 2011

airjer995
  • 5332 Answers

SOURCE: Car won't start. New battery installed recently. Only clicks when trying to start.

one single click any time you turn the key usually indicates a bad solenoid on the starter. A new starter will typical get you going.

A series of rapid clicks when you try to start usually indicates a weak battery. There could also be a bad connection at the terminals on the battery or even a poor connection at the starter.

If you get a single click and everything goes dead for a couple of seconds than you definitely have a bad connection at the battery.

Let me know what you find or if you have any questions.

Posted on Dec 28, 2011

ZJLimited
  • 17970 Answers

SOURCE: 2008 impala won't start or shift out of park, key is difficult to remove from ignition.

Sound like a problem with the Neutral Ssafety Switch, this is located on top transmission (generally) and its possible that need some adjust.

Posted on Aug 13, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2010 corvette wont start.


And the antitheft is not activated ?

Nov 30, 2015 | 2010 Chevrolet Corvette

1 Answer

Car won't start, fan sound under hood.


Try turning everything off ,ignition radio, heater A/C or whatever . Open your hood and take off the negative battery terminal. Leave it off for a couple of minutes. Then reconnect it then try it.

Check all cables and fuses and make sure the battery is good. If that does not work, it may be the starter which needs to be replaced. Since it clicked once it means that current did go through but stopped at the starter.

Mar 14, 2014 | Hyundai Sonata Cars & Trucks

1 Answer

My car won't turn on it was working fine last


Just because you charged the battery it doesn't mean it is any good. Modern sealed batteries fail; just as you described, fine one moment and then nothing, they go open internally.

Jul 19, 2013 | Cars & Trucks

1 Answer

Car won't turn on; clicking sound


It does sound like a starter problem but the easiest way to rule that out is by trying to jump start the car with a push , if your starting motor has packed in it will still start with a jump start

Feb 24, 2013 | 2008 Hyundai Elantra

1 Answer

I changed my car battery, now my 2008 Nissan Altima key fob won't work


There is a special procedure involved in keying your fob to your car once the battery has been changed. You must lock and open the door with your key. Turn the ignition to "on"(not start) then push the fob's open and close button, then shut off ignition. This procedure is done everything the key battery is changed. Hope this can help you!
------------
Motorcycle Diagnostic Scanner

Oct 31, 2012 | Cars & Trucks

2 Answers

I have a 2004 pontiac sunfire with a few problems. First, when I turn the ignition to start the car all I get is a fast-paced clicking sound from the dash area and the engine doesnt even turn over. This...


as fo the idle, there is a IAC ( idle air control to maintain idle. you may have to remove this and clean the carbon out of it, and the intake as well. as for the clicking there are 3 solutions to fix it. battery if it is ok, the solinoid is bad on starter or the starter itself. but it does sound like a bad starter solinoid, because a bad battery will make the same clicking from solinoid. but make sure battery is ok first. when engine is off voltage at battery should be at least 12.6 or better. when running and alternator is ok, it should read about 14.2 to 14.7 if lower then 14 volts alt. is bad. have a very good day !! hope this helps!

Jul 09, 2011 | 2004 Pontiac Sunfire

3 Answers

Car won"t start..acts like the battery is dead .


possibly the alternator. or even a bad connection on one of the wires

Jul 19, 2008 | 2000 Kia Sephia

Not finding what you are looking for?
2005 Chevrolet Corvette C6 Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...