Question about Cars & Trucks

Open Question

I have a 1993 mercury topaz, when u turn the ignition on my car surges to 2500 and 3000 rpms, when idling its the same, when driving my brakes are hard to keep because its revving by its self, almost like its driving by its self, i dont even have to touch the gas, also when switching to reverse theres a huge thud noise followed by a jerk? Help me please lol ive tried everything!!!!

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I adjust the idle on a 93 mercury topaz?


I would clean the throttle body first and the idle air control motor(IAC). Clean where the plate sits and on the back of it/them. You have to remove the IAC to clean it. Brake clean and a toothbrush works fine. If it still is high. Diagnostics need done for the IAC. Most times it is the IAC.

Nov 01, 2016 | 1993 Mercury Topaz

1 Answer

Why would the car surge and act like to much gas is going to the injectors and then die


Well it could be a fuel mixture problem, or it could be an air problem.
If the check engine light is on, the O2 sensor may be telling the computer the mixture is too rich or too lean.
Or the idle air control valve may be faulty, or the throttle body may be gummed up.

Feb 18, 2013 | 1993 Mercury Topaz

1 Answer

My 93 mercury topaz idles high doing warm days, and idles low doing cold days,what could that be.


1) weak anti freeze 2) defective thermostate 3) out of range coolant temperature sending unit

Any of these or combination of these will give you the sympthoms you are experiencing

Mar 25, 2010 | 1993 Mercury Topaz

1 Answer

I have a 1998 Mercury Topaz that starts to miss under acceleration and can hardly make 100k per hour. Ignition system is ok. The problem seems to be in the fuel system. New fuel filter installed and...


Even tho the ignition seems ok, I'd check the ignition cables to the plugs. Sometimes these break down over time... it will idle and drive ok, but when you need power for a hill, or acceration, that's when the wires faults start to show up.
A quick test is to put the car in drive with your left foot on the brake FIRMLY while you press the accerator... if the miss and lack of power shows up, it's usually the ignition cables to the plugs.
k

Jun 30, 2009 | Mercury Topaz Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

13 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...