Question about Cars & Trucks

1 Answer

83 280zx cuts of after reaching normal temp.

Still having problem with my Z. It was running rough. I did a complete tune up. Ran good till it warmed up. I noticed the distributor was loose and worn. I replaced it with a new one including new ICM. I ALSO REPLACED THE COIL. I also replaced the ignition switch with one from wrecking yard. When I replaced the distributor I discoverd a broken wire tp the tempature sensor. I made the repair. I started the Z. Ajusted the timing. I let it run until it reached normal temp. Readjusted timing. A bit later the r.p.ms. came down a bit. It was running smooth. Then suddenly shut off. I felt the coil to see if it was warm also felt the ICM.THEY WERE BOTH COOL TO THE TOUCH. I tried to restart it but it wouldnt start. I shot some starter fluid into intake and it fired right up. Ran for 5 min. And shut off again. I havent tested the fuel pump relays or the cold start valve. Could it be as simple as changing the condenser on the coil? I downloaded the service manual but havent had time to vo throuth the process of testing each component. Any advise would be apppreciated. Thanks.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Cars & Trucks Master
  • 1,013 Answers

I take it with its age it has points and a condenser check points gap possible condenser change any way as its a cheap part does it have a vacume hose going to the dissy as when it warms up the vacume hose retards or fowards the timing has it got an auto choke this could be causing it to stall or cut out the spring on the inside could have snaped or come of the pin could be crap in the fuel filter or in the carb jets if it has a carb just a few things to have a look at and check hope these help cheers ivan

Posted on Nov 20, 2013

Testimonial: "This car has an electronic ignition no pointz to gap. Fuel injected, no carb go set. Coil is brand new, doesnt mean it cznt be bad. Ill tezt it."

  • Harvey Barnes
    Harvey Barnes Nov 20, 2013

    My Z is an 83 280 zx. its old but not that old. it has electronic ignition. no points to gap. besides its a brand new distributor and ignition module. new battery, new coil, new rotor, new wires, new cap, etc. I had the same problem beford replacing distributor and module and coil. however before the replacement the ignition module was hot to the touch. not the case now. module and coil are cool. engine gets warm and it shutz off as if I turned the key off.

  • ivan whisker
    ivan whisker Nov 20, 2013

    does it cut out as if the fuel isnt getting to it has it got an imobiliser of some sort just trying to think of somthing that would make it cut out normally ignition or fuel are all the injectors working thats if its a rail type injection or direct from pump my dad had and old audi 100 that did somthing similer it turned out to be a sticking needle in the fuel injection pump

×

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 4 Answers

SOURCE: Truck runs fine till reaches running temp then dies, no spark

Sounds like a bad ignition coil. Have it tested.

Posted on Dec 14, 2008

  • 432 Answers

SOURCE: 94 Bravada that stumbles and stalls.. won't start when warm..

Try checking the exhaust flow when someone else is pushing down on the gas petal.The farther the petal gos down,the more exhaust should be coming out. I replaced my catalitic convertor at 44000 miles, it was clogged. I had them install a high flow type.

Posted on Sep 03, 2009

  • 432 Answers

SOURCE: I have a 1991 Olds cutlass ciera 3.3 v6, starts up

Good Evening, you might want to check those injectors, I can not remember for certain but that setup was sequential and when one or two have a problem it would take out the rest. Ohm out the injectors and see what you have there.

Posted on Nov 03, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 camry runs rough while cold


Check the cold start injector in the air intake is working.

Mar 10, 2014 | 1999 Toyota Camry

1 Answer

Runs rough when cold


misfire cold.
ever tune it up. sparkplugs can fail when cold and rich conditions
are present(normal for cold)
ever seen the 60k service points lists it the glove box operating manual
id bet its due to not doing service.
am i right?
no engine size stated. so no details guessed.

Jan 11, 2014 | 1999 Toyota Camry

2 Answers

1998 ford escort zx2 car runs great till it reachs normal operating temp range then it misses like crazy. put in a new fuel pump that didnt help tried new coil pack that didnt help either its not over...


ignition module , that the coil packs sit on ,was the problem on my car. had the same symptoms .ran fine till it warmed up then it started missing like crazy

Nov 03, 2013 | 1998 Ford Escort

1 Answer

1997 jetta vw ,car cuts out an lost power


hi, does it run fine when its cold then play up when it gets warm or up to near normal running temp, if this is the case then the chances are the oxygen sensor needs replacing, if it runs rough from cold then it could be mass air flower sensor

May 18, 2012 | 1997 Volkswagen Jetta

1 Answer

Ram idles rough at start then fine after warms up


1. Injector cleaner.2. Does it have enough miles (75K-plus) to consider changing plugs?3. What's the air cleaner look like?4. Any codes showing?Here I am trying to give answers when I probably know less than you....Good luck.

Dec 16, 2011 | Dodge Ram 1500 Cars & Trucks

1 Answer

My 1987 Toyota Tercel will not run. It will start, but wont stay crunk unless im giving it gas. I check for vacuum leaks and no sucess.?


if you have a carburator then you have a blocked idle jet, simple job unscrew **** dirt out clean jet hole through, replace, (change or fit fuel filter to prevent it happening again. )
to tune is simple replace jet start motor and warm up . when at operating temp turn jet out and then in till motor runs rough then screw back out til motor smooth out , and runs sweet, if it cuts out when slowing car down (while driving) screw need to come out a slight bit more

Dec 20, 2009 | 1987 Toyota Tercel Liftback

2 Answers

Runs fine till warms up then losses power and dies


Does the fuel line still have 55 PSI when engine warmed up? Any other codes show up?

Aug 22, 2009 | 1998 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...