Question about Cars & Trucks

1 Answer

I have a 1996 Ford Falcon 4L GLi Auto. My car misses badly at pull away and with sudden acceleration. When cruising the car runs smoothly. I did replace the feul-, air- and oil filters, the coil pack, spark plugs & spark plug cords. Still no improvement. Any suggestions please?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 44,481 Answers

Run fault codes and fix the recorded fault sensor /servo

Posted on Nov 20, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 208 Answers

SOURCE: 2000 ford explorer 4.0 x-engine is stalling, missing and lose power while driving

I personally would check the fuel pressure. Then I would go back to the coil. I have seen brand new bad coils out of the box. The symptoms of a loss of power point to this component, especially if the car idles well, but loses power when accelerating. Please do not rate this reply - we all are left to grasp at straws since you have changed pretty much everything. Good Luck. Please post the final fix of the problem.

Posted on Oct 28, 2008

  • 8 Answers

SOURCE: coil pack keeps going bad,

Your problem sounds like an intermittent short in the power feed to the coil pack from the EEC module

Posted on Nov 03, 2008

autodr
  • 260 Answers

SOURCE: Car sputters when you accelerate

is the engine lite on? if a misfire shows, and the plugs are new, could be coil or wires. how does it idle? maybe air leak between mass air flow sensor and throttlebody.

Posted on Nov 15, 2008

phoenixinks
  • 89 Answers

SOURCE: engine cuts out on acceleration

could be the pump or injectors or both. while your at it check your fuel tank for rust dirt any thing.

good luck

Jason

Posted on Jan 17, 2009

  • 1348 Answers

SOURCE: 2002 ford ranger 3.0 is missing on 2 cyl plugs ok injectors ok new coilpack

do a compression test,as the intake manifold,like alot of fords is no good.

Posted on May 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1997 Ford falcon Gli EL auto sedan. I need to obtain new front L&R light assemblies.Can you help.


Just contact some vehicle dismantlers/wreckers in your area that deal in Ford parts.

Getting a set of those front lights in good shape should be fairly easy as there are many of these vehicles in wreckers yards now.

Jun 16, 2016 | Ford Cars & Trucks

2 Answers

Ford Falcon auto Gli - car loses power and misses when accelerating


It is being happened for bad fuel filter. You can check it out. I have bought Ford since 5 years.
Source : Mechanic Shop Tempe

Nov 28, 2012 | Cars & Trucks

1 Answer

1988 Toyota Camry 2.5 liter V-6. Engine starts fine, but after started it misses. The car misses terribly under a load, but will sometimes accelerate smoothly if you accelerate at a very slow pace. Will...


most misses are injector related either from dirty injectors , low fuel pressure ow injector wiring faults
use a quality injector cleaner for a tank or two
run the fault codes to check for other related sensor problems

May 23, 2017 | 1988 Toyota Camry

1 Answer

Digital spanner showing up on dash next to the oedomater


its just a service reminder its not an issue just preset scheduled service reminders. check your handbook to remove it. i think if you turn the ignition on then hold the demister button for 5 seconds it should remove it.

Apr 29, 2010 | 1996 Ford Econoline

1 Answer

I have a 2002 Ford F-150... it started accelerating as soon as i turn it on... it accelerates uncontrolably..


1) Check throttle cable/linkage for smooth operation. 2) The PCM may have failed. See dealer/mechanic. 3) Vacuum leak(s) at manifold or vac. lines.

(I had a fast idle and surging cruise all of a sudden. The diaphragm of the EGR valve started leaking.)

Sep 30, 2009 | 2002 Ford F150 Regular Cab

1 Answer

Idle ok,slow acceleration fine,accelerating quickly miss-fires


Sounds like you have a leaking cylinder head gasket

Jul 18, 2017 | 1992 Ford Escort 4 Door

4 Answers

Missing and stumbling during acceleration


4.2 ltr missing. 2000 truck, f150. Changed plugs, wires. Ran great for 2 weeks. Started again. Changed coils. Got worse. Changed fuel filter, did nothing. Added injector cleaner and fuel cleaner, nothing. Checked EGR, o.k. It is getting worse. Had new gas about the time it all started.

Feb 07, 2009 | 2000 Ford F150 Flareside SuperCab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

120 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...