Question about Dodge Avenger

Open Question

2010 avenger gas, speedometer, rpm, temp gauge not working

Gauges not working

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: gauges not working properly

Hello, Last year General Motors lost a lawsuit about the instrument panels in 2002 to 2005 trucks. The following website contains all the information about this lawsuit settlement.
http://www.speedometersettlement.com/
This impacts the entire gauge cluster in your vehicle.
I have the same year and model as yours and my speedo is never accurate and the tach always read 6000.
The issue is the metal bearings that the gauge meter movements use. The bearings are getting dry which impedes the meter movement.

Posted on Apr 03, 2009

mcgyver468
  • 710 Answers

SOURCE: started out with headlights out then the speedometer, odometer, gas gauge, oil, battery, rpm's are not working, fixed the headlight was a fuse but other stuff still won't work.

sounds like your missing a ground somewhere.

Posted on Apr 21, 2009

fknstart
  • 404 Answers

SOURCE: speedometer, rpm gauges not working

sounds like a fuse

Posted on Jun 13, 2009

  • 1 Answer

SOURCE: my check gauges light came on and my gas gauge,

Mine has done this a few times after having disconnected the battery for service. Disconnecting and reconnecting the battery a second time brought them back. A mechanic friend told me it hase something to do with the ECM relearning after having been disconnected. Hope this helps.

Posted on Jun 23, 2009

  • 1 Answer

SOURCE: speedometer, gas gauge, odometer, rpm gauge not working

My gas guage, speed odometer and tempiture does not work
The speed odometre is reading 9999999 what should i do

Posted on Oct 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Which fuse do I replace if my temp control, speedometer and rpm gauge isn't working On a 2010 dodge averenger rt ?


Most likely not a fuse. The instrument cluster is controlled by the body control module as well as the temp control system. Possible communication issue that needs to be reset or repaired. I agree with Johnny.... have the dealer take a look

Apr 26, 2015 | 2010 Dodge Avenger RT

1 Answer

Fule gauge speedometer and rpm gauges stopped


Go to the fuse box and change the fuse for "Gauges". I think this might solve the problem.

Feb 23, 2010 | 2004 Chevrolet Monte Carlo

3 Answers

Speedometer, gas gauge, odometer, rpm gauge not working


My gas guage, speed odometer and tempiture does not work
The speed odometre is reading 9999999 what should i do

Jul 29, 2009 | 1998 Nissan Frontier

2 Answers

Gauges misreading bigtime


instrument cluster and buy and extra per gm quality

Dec 24, 2008 | 2003 Chevrolet Cavalier

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...