Question about 2009 Dodge Avenger

1 Answer

My 2009 Dodge Avenger has 64,000 miles on it. The check engine light came on last Tuesday. On Wednesday it started running rough and wouldn't go over 40 mph. On Thursday I took it in to have an oil change and asked them about it. They thought it was the spark plugs needing to be replaced. The very next day the lightening bolt looking light came on and then about 5 minutes later it died in a busy intersection. I had to have it towed. I changed spark plugs yesterday and it did no good. I read somewhere that this may be the throttle. and that it may need to be cleaned or replaced. Any ideas on what it can be? How do I clean it if it is the throttle?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Dodge Master
  • 40,672 Answers

When the engine light came on the correct procedure to follow is to have the fault codes read to find out what sensors failed . I would have it done now before you waste more money chasing what fasle ideas.Next find yourself a reputable mechanic as changing the plugs was a waste as it fixed nothing.

Posted on Oct 23, 2013

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2 Answers

SOURCE: I have a 1998 Dodge Avenger 6cyl Coupe, 143,000

Mine did the same thing, try one of the fuel injectors. You'll have to take off the manifold to get to them though.

Posted on Jan 28, 2010

bogdanodwazn
  • 5617 Answers

SOURCE: 2000 Dodge stratus running rough. Changed plugs. Ran good for about 5 miles. Then car startrd running rough againwith check engine light flashing on and off. What is the problem?

Change coils,fuel filter and check the code.

Posted on Mar 16, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My lighting bolt light is on and my car is running rough and I'm not able to go over 10-15 miles.. I have a 2008 dodge avenger 2.4L engine.


it is limp mode
you will have to run the fault codes to determine the fault
the sign indicates electrical problems so check alternator , drive n belt and have a load test done on the battery

Dec 28, 2015 | Dodge Cars & Trucks

1 Answer

Rough idle


What about the coil packs? Do you have a check engine light on? If so take it to an auto parts store and see if they will scan your vehicle for the codes.

Oct 19, 2013 | 2007 Dodge Caliber SXT Sport Hatchback

1 Answer

Running too rich


Wouldn't you take it back to the place that
apparently did whatever they felt like & made
things worse, than when you went there,instead
of actually diagnosing the reason you were there?

Jul 08, 2012 | 2000 Dodge Avenger

1 Answer

Last year my 2003 neon stopped running and we had the timing chain replaced WE got 40 miles and the car stopped then wouldn't even turn over we changed a fuse and got it to run another 70 miles to limp...


I would say yes, if it wouldn't let the car run, then yes the wire may be frayed now, repair the wires first and eliminate that problem . then have the codes read,

Jul 06, 2011 | 2003 Dodge Neon

1 Answer

I have a 2008 Dodge Avenger and the check engine light is blinking, also the car has a rough ride when I go from stop to acceleration.. What could this be


sounds like your have a misfire in one of your cylinders...a flashing check engine light with engine running rough. Check your sparkplugs and wires. you should have the code scanned.

Jan 06, 2010 | 2008 Dodge Avenger

1 Answer

1996 Dodge Avenger runs rough


Could be a defective engine coolant temperature sensor -- if it's sending erroneous signals/data to the engine control module, it can cause the symptom you describe (of course there are numerous other possible causes for the symptom you describe. Good Luck

Jun 30, 2009 | 1996 Dodge Avenger

Not finding what you are looking for?
2009 Dodge Avenger Logo

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...