Question about Cars & Trucks

1 Answer

Hi there please help, my mother has a 2003 Nissan primera (92,000 kms) and has stopped using the car recently because the check engine light has come on, also in the past month I have noticed that the bottom radiator hose is considerably a lot colder than the top hose after a big drive?? me thinking of it being a blocked thermo... anyway mum has taken the car to a auto mechanic for a diagnosis check to be done the the cars computer, the mechanic has called mum about half an hour later saying that he couldn't find what was wrong in the test but identified that the car needs a service, she agreed to that. he called again that same afternoon, and said that the front break pads are worn and need replacing aswell as the rotors (claming that they were metal on metal ( there has been no break issues prior.??? you can probly c whats happing so far............ anyway he called back after that saying that breaks were done and can pick car up the next morning. the following morning he called saying that the car needed a w.o.f and mum had agreed to that, after all this mum has gone and picked the car up, when she started the car mum noticed a difference in the cars start up, it didn't fire up properly with the ease it normally does, mum drove roughly 4 kms and parked up, 20 mins later mum has tried to start car to leave and it hasn't started. the engine was turning and trying to start but it wasn't fireing (no spark or ignition of the cylinders I guess???) she rung mechanic and he asked if mum if she was with AA..... her saying no he drove to mum to asses, (funny thing was he turned up with the computer code reader and two second hand sensors) he ran test and then tells mum that the sensor needs replacing and tried the first of the 2 sensors he brought and the 1st didn't work, he put the second one In causing the car to start, he has told mum that it wont last being second hand.. 3 hours later mum went off to work and the car started for her first time, after work car started, mum has stopped and turnd car off to get petrol, upon starting the car it wouldn't start again, (engine just turning over without ignition) mum was there for 2 hours and without help from a tow truck mum has tried starting it (after2.5 hours) and it has started up..... she drove the car home and now I have traveld all the way here to sort this out.. PLEASE HELP!! should this auto mechanic have knowen of the problem right from the start after running the obd computer code check?? as he is now saying that it could be the cam chain.. im nota happy with his level of professionalism and poor workman ship with fitting second hand sensors to try fix, my question being... has this mechanic knowingly taking my mum for a trip down bills line? would he have knowen from the start if the cam chain was stretching? is there any approach I can take when I go down to his workshop soon

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 60 Answers

Take it somewhere else.

Posted on Oct 22, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

dddsouve
  • 64 Answers

SOURCE: Check Engine light

It sound like you are having a electrical problem.You need to check your electrical/ignition system,not all electrical problem the diagnostic machine can read.

Posted on Aug 22, 2008

  • 1 Answer

SOURCE: Misfire

One question, have you replaced the ECTS (Electronic Cooling Temperature Sensor)? These cause no end of different seemingly unrelated problems on Saturns. Peice is about ten bucks and is an easy install. Just search on youtube for a how-to video. Even if that's not the problem it is reccommended to replace this peice just the same as they ALL end up going bad at some point.

If that's not a fix, start pulling plugs. Check to see if they're correctly gapped and if they have any damage/corrosion. If you're running Platinum plugs, immediatly change to a copper plug as Platinums have no place in these motors. Most people have the best luck with NGK copper.

Check to make sure that your plug wires haven't been crossed. This sounds like a plug or wire issue most likely so it has to be in that family, if the plugs are good, wires good and not crossed, sensors are fine, then time to replace your coil packs. If you've replaced everything up to the coil packs then that is most likely the cause of your dillema.


Posted on Oct 25, 2008

Mr BrokRench
  • 1623 Answers

SOURCE: 1999 Cadillac Catera - 103,000 miles - cranks but no fire

Hello carol...from the symptons you describe more than likely it's the CPS (crankshaft position sensor.)
The CPS is a common problem on Cateras with these symptoms.
The sensor is a magnetic impulse type that sends a signal to the computer, the computer then triggers the fire signal. When the CPS gets weak, dirty or has low voltage the intermitten no starts occur. It will finally result in a no start at all...Please be aware that a lot of caddy dealers will and have overcharged customers for this common problem by ill advise and replaceing uneeded componets.
Good luck...i hope this helps and will fixya up.

Posted on May 22, 2009

TheComforter
  • 18 Answers

SOURCE: I have a 2004 NISSAN SENTRA SE R SPEC V (Nismo), my car sputters

You have 2 Problems, First problem batteries dying you have to make sure connections secure and alternator is charging your batteries (go to an Autozone or Discount advanced they will tell you). The Sputtering is either a bad SPARK PLUG or a damaged Cable going to the spark plug..Change them every 2 years.

Posted on Jun 16, 2009

  • 1071 Answers

SOURCE: car just shut down on highway. Mech says I need a new crank senso

no you just need to remove the timing belts and crank gear all can be done in car i am a kia master certified technician and have replaced a few of these on both v6 and 4 cyl

Posted on Aug 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine nissan primera


You have a MIL Lamp on ,so you have codes

Get the codes & diagnose them

Why would a shop tell you what to do & not look at
data & road test?

Their giving away work & failed to diagnose or test
for the problem,whatever it is!

May 03, 2014 | 2003 Nissan Primera

1 Answer

Engine nissan primera


You need to get it scanned. Auto Zone does it for free.

Apr 04, 2014 | 2003 Nissan Primera

1 Answer

Nissan primera 1996 immobiliser work, not locking door


Check and replace the battery in the key

Apr 28, 2013 | Cars & Trucks

1 Answer

How to change fuel filter on 2003 nissan primera


2003 Nissan Primera, the P12 engine runs on chain NOT belt!!! You don't need to change the chain unless in very very unlikely case the chain snaps.

Mar 15, 2013 | 2003 Nissan Primera

1 Answer

Engine check light went on the mechanic wont find problem primera 2003


the check engine light is simply the cpu telling you that it has detected a fault in on of the systems it monitors. There should be a fault code showing that will point to the fault

Jan 17, 2013 | 2003 Nissan Primera

1 Answer

The cvt light comes on in my nissan primera 2002...what does this mean?


would help if i knew what you meant by CVT light ,iam only a thick cockney from the east end of london ,do you mean the engine light ?

Sep 24, 2012 | 2003 Nissan Primera

1 Answer

Nissan Primera petrol P12 - malfunction warning light (picture of engine)showing on dash, had it checked by auto sparky no fault found.


tats the engine management light mate usally comes on when u have low oil or antthing to do with the engine bring it to nissan dealer if its not low oil they will hook it up to a machine and bingo they have your problem.

Feb 14, 2010 | 2003 Nissan Altima

2 Answers

Nissan primera gearbox


how much is the price for nissan primera 2003 gear box

Oct 06, 2008 | 2004 Nissan Armada

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

117 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...