Question about 2000 GMC Jimmy

1 Answer

Ok so im trying to help my Boyfriend out, he works a lot and I know a lot about vehicles being a woman :) He just put a new tranny in, it seems to struggle to get up and go but does fine in reverse he knows the tranny is good, theres no exaust on it at all cause the exuast wouldn't fit back on so hes gotta buy exuast for it but is that making it not get up and go very quickly?? another question is speedo isn't working?? checked fuses only one blown was cigarette liter.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Speed sensor is probably dead or not hooked up or bad wiring.

Posted on Oct 22, 2013

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 438 Answers

SOURCE: speedo wont go past 55 truck runs fine

Hi
The transmission and speedo COULD be the VSS (Vehicle Speed Sensor) and or related wires. The Tach is a seperate circuit that gets signal from Distributor and power is fed through the "Gauges" fuse. The only way I see them being a related concern is either The ground (G200) and is located Behind the left side of the IP, below the fuse block, on the tie bar. the other way would be the IP cluster itself.
I think you MAY have 2 issues. I would get the VSS checked and make sure your getting a signal to the VSS buffer (located next to the PCM, around the glove box area). Make sure the buffer is sending the signal out. A Scan tool SHOULD be able to assist you in this. If there is NO VSS signal the transmission will not shift properly, if at all.
Also your speedo will drop off with no VSS.
As stated, this is just advise from experience and published material.
If in doubt, please take it to a Repair shop in your area your familiar with.
regards ranjit

Posted on Oct 14, 2009

  • 1 Answer

SOURCE: I have a 2008 GMC 2500. My cigarette lighter (not

Check fuse 55 in the eng. comp. and check the power fuse "alt pwr" 20A in the driver's side fuse panel on side of dash.
I melted my right side power plug with a portable compressor and blew the fuse in the dash panel. I need to get a new power plug now.

Posted on Nov 15, 2009

  • 212 Answers

SOURCE: Needing to know why my Yukon's gauges stopped working.

You need to replace cluster, 99-02 Silverado GMC all will work even if it has a trans temp truck is pre wired for it. I put a 02 Denali cluster in my 01 silverado no problems. GM can reprogram hours and odometer if you want.

Posted on Mar 10, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When i put my 98 old's Cutlass in reverse it


change your transmission filter and fluid if its a automatic tranny ok dude ?if it is automatic transmission then that's your problem I know if your vehicle does not slip in any forward gears then go to the auto parts store and ask them for the tranny filter kit replacement and how many quarts of tranny fluid you need to put into it ok make sure you tighten the bolts in a sequence and no more then three fingers on a rachet and socket tight ok all evened torked and then add your fluid into the tranny dipstick tube using a tranny funnel ok

have a great day!

your helpful friend Robert W. Caston

Oct 04, 2014 | 1998 Oldsmobile Cutlass

1 Answer

Car wont start makes clicking sound


Make sure the contacts at the battery posts are tight.

Nov 24, 2013 | Pontiac Grand Prix Cars & Trucks

1 Answer

I have a 1996 gmc serria 1500 4x4 v6 vortec manual I can't seem to find the oil plug for the trannie it seems to me it's part of the transfercase help


Most vehicles do not have an oil drain plug for the tranny...you have to drop the pan to change the oil. Make sure you install a new gasket when you put it back on.

Jul 17, 2013 | Cars & Trucks

1 Answer

Turn Signal ISsues


replace multi function switch put other relay back in

Mar 26, 2012 | 1995 Ford Windstar

2 Answers

Im looking at a jeep 2002 with 4.7l motor. was there any problems with that year over all?grand cherokee sport.135000 miles.im a women with no knowlegde of buying a vehicle by myself. thank you jody


The 4.7l is an overhead cam V-8 motor. It is plagued with problems involving sludge build up, poor oil circulation, and engine failure due to lack of lubrication. Personally, I would avoid any vehicle with this engine.

Dec 19, 2010 | 2001 Jeep Grand Cherokee

1 Answer

Its a car im looking at for the winter, its better than what i have, its a 95 mercury sable, it runs ok, its just he tranny. when you put in gear it takes a while to kick in. my boyfriend is wondering if a...


Do you mean an OBDII? How about just having the oil and filter changed. It will also give you an idea what condition the trans is in by what is found in the pan. zzzzzzzzzzzzzzthere should be some sedimen, so if you get the
'gotta overhaul" pitch. Tell them you see how an oil and filter services works first. Good Luck.I don't trust transmission shops either.

Sep 28, 2009 | 1995 Mercury Sable

1 Answer

Transmission problem


have the same problem with 1999 mazda pickup try flushing the tranny and put in a new filter replace one quart of tranny fluid with some lucas trans fix and see if this helps it any, was told the tranny will need to be rebuilt.

Aug 28, 2009 | 1995 Jeep Grand Cherokee

2 Answers

1994 JGC tranny problems


The only thing that can make the noise is the transmission front pump, if the trans works ok try changing the fluid and filter, it may help or reduce the noise.

Aug 20, 2008 | 1994 Jeep Grand Cherokee

1 Answer

Help please


Try checking the crank sensor, (for sludge, and wiring connection) and having someone check the timing. It may have jumped a tooth. (so the engine isnt firing the sparkplugs at the right time) Also try drilling a 1/4" to 1/2" hole in the exhaust, forward of the catalytic converter, then try to start it. If it starts with the hole drilled, then that means that the catalytic converter is clogged, and needs to be replaced. If there is no difference, then the small hole can be plugged with a short bolt, or welded shut.

Jul 01, 2008 | 1992 Chevrolet Corsica

Not finding what you are looking for?
2000 GMC Jimmy Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...