Question about 1995 Isuzu Trooper

1 Answer

Bought this car about a week ago and it's run great up until having to takeout along a long dirt road, I cleaned the air filters and the sensors but its still struggling up hill with no load. It start jumping revs, loosing power and has started doing it on flats too. If I switch off the car and then back on again she runs fine for another hour or two.....we have tried everything....please help :(

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 401 Answers

Where did you buy it from?

Posted on Oct 21, 2013

Testimonial: "Private sale, looked over the car she was fine but I've run a lot of ks up on her in the past week with a trailer because I'm in the process of moving 5 hours away"

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 345 Answers

SOURCE: I have a vw passat 1999 1.8 T wont idle when started

i suspect the throttle body has lost its basic settings for some reason,ive only known of that happening a few times tho,but that is the symptoms of a throotle unit,plug in a scanner check the codes and reset the throttle body in basic settings

Posted on Feb 19, 2009

  • 5 Answers

SOURCE: up hill i have no power goes from 65 to like 25 in less then 10

adjust the valves .006 intake, .010 exhaust.

Posted on Apr 18, 2009

  • 1 Answer

SOURCE: idle is erratic

I had the same trouble 2 to 3000 rpms. there is a power steering stwich on the bottom of steering pump unplug this and see if your rpms come down. Mine did,you can get a new stwich from rockauto.com for about 60.00. It took me four months and 400.00 to find this out

Posted on May 02, 2009

  • 1 Answer

SOURCE: 2000 Isuzu Rodeo Stalls without warning or other "symptoms"

it could be your ecu...that what is wrong with mine...

Posted on Jun 22, 2009

buzz100
  • 4 Answers

SOURCE: 1990 Holden rodeo, Isuzu ute wont start when cold,

its coss the motor is frozen , so put anti freeze in the radiator

Posted on Jul 31, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starts fine first thing when cold. After warming up, cranks many time, coughs and idles rough.


Clean the throttle body, IAC, and replace the air filter if needed.

Nov 28, 2015 | Cars & Trucks

4 Answers

2002 Cavalier starts then dies. Started about 1 week ago. Let sit overwrite started fine next afternoon. Ran great for several hrs. Started dying again. Replaced fuel filter, Ran great for a day. Now it...


Had a 89 cavalier did that start then die it map sensor. Also check ground wires if the become too corroded they won't start sometimes just run weird

Jan 21, 2015 | 2002 Chevrolet Cavalier

1 Answer

Hi i have a 2006 dodge diesel that we figure got bad fuel and stopped running.wouldnt start took it in go a new lift pump, fuel filter, lines cleaned and tank cleaned out and its still not running great....


Diesels need to be clean and typically after 10,000 miles removing the fuel filter produces very little in the way of dirt and grit.

You had the tank and lines cleaned out and a new pump and presumably a new filter and still you find dirt and grit in the filter after a short time. ..
Either the tank, etc. wasn't cleaned out or more dirt has entered the tank since, either from more dirty fuel, from dirt ingress into the tank while the car is in use or the third possibility is something is wearing rapidly and the dirt is appearing in the tank to be recirculated after being sent along the fuel return line. If this is what is happening it throws suspicion onto the high pressure pump...

If the high pressure pump is failing it is surprising one or more of the injectors hasn't failed.

If you got dirty fuel the filter should have trapped everything that was likely to damage the injection system until performance reduced and eventually the engine stopped due to fuel starvation. Replacing the fuel filter with a suitable amount of care should then restore performance to the previous level.

Fuel filters are great for trapping dirt but not so good for other liquid contaminants. Water fortunately tends to remain at the bottom of the tank and the bottom of the filter cavity but other things might pass through the filter - acids, salt solution, solvents.
A couple of years ago there was a case of a few petrol filling stations selling fuel contaminated with seawater and shortly afterwards a lot of injectors needed replacing...

I think if my car had the problem your car has I would temporarily fit an inline filter to the fuel return line and drive it for a time. Two things should happen if the dirt is self-generated. The new inline fiter when cut open should show the dirt and grit you usually discover in the main filter and secondly, there should be a reduction in the amount of dirt and grit you find in the main filter, however any dirt at all in the inline fiter means my best advice is to take the car to a good diesel specialist for proper diagnosis and a guaranteed repair.

If dirt is found in the fuel return line there can be no half measures - the business end of the injection system needs surgical-level cleanliness.

Good luck!

May 12, 2017 | Dodge Ram 1500 Cars & Trucks

1 Answer

Running rough-1987 Ford Ranger 2.3 L 4 cyl. Had been running very smoothly until 2 weeks ago when it began backfiring and running rough, especially at low speeds, without my having made any adjustmen


If your car has a mas air flow sensor (usualy located right aroung air filter or in air passage after the air filter) check and clean the sensor. This looks like a small spring on the end of 2 wires. BE CAREFUL not to damage the sensor. I have seen where the sensor gets dirty over time and this can cause a rough idle.

Jul 11, 2012 | Cars & Trucks

1 Answer

Truck surges


if this has the 2.9 six engine yep I've seen this before
on the front of engine right behind the pipe that carries air from filter is the throttle blade on the left side of it is a black sensor with two phillips screws on it This is the throttle posisition sensor ford has a service bullitin on this It seems fine dirt in air follows the throttle shaft and gets caught inside this sensor
solution replace sensor and use throttle/carb cleaner to clean shaft from inside you'll see black dusty powder on it
Runs great for 15 minutes because ecm runs open loop(epa stuff) till then when it tries to go closed loop the sensor's input is not there so it goes crazy
any one with two hands and a screw driver can fix this

Jun 29, 2012 | 2004 Ford Ranger

1 Answer

Fuel sensors or other causes?


Please kindly run a scan on the car to be sure of the exact problem.

Apr 13, 2012 | 2003 Saturn VUE

2 Answers

1994 pontiac grand prix, starts up and runs fine until it warms up, about 4-5 min, then dies and will not start until cool, has new plugs and new fuel filter


the mass air flow sensor will cause this. you can remove it and spray it with electrical cleaner or maf sensor spray. you can buy at any auto parts store. follow directions on can for maf sensor spray. this sensor is very sensitive to dirt and debris. and also make sure air filter is clean and hose from filter is free from dirt.

Oct 18, 2010 | 1994 Pontiac Grand Prix

1 Answer

My 2004 PT Cruiser 4 cylinder has 117K on it. When I come to a complete stop and wheels stop turning the car's rpm's dip so low that the car sounds like its about to clonk out. About 3 out of 5 times the...


You said you just had the spark plugs replaced, could be that a spark plug wire was connected in the wrong spot, I would check that first, also does the car run smoothly going down the road? clogged fuel filter perhaps. Check engine light on? could alse be a sensor. This newer vehicles basically use a computer to control every aspect of the engine as far as keeping it running at top performance and the least amount of emmissions as possible.

Sep 03, 2010 | 2004 Chrysler PT Cruiser

1 Answer

Dust inside engine and clogging sensor - 2010 Equinox


dust what kind of sensor is this, never heard of such a problem, there no sensor that should hit dust and oil, maybe your talking about a mass air flow sensor, if so that a bad call on the shop to tell you that,maf sensor does get dirty, but they must of put on a defective one, it would take at least a year or two to recollect dirt, the air is filtered with air filter. they should just tell the truth, they got a bad part,goodluck.why scare people with lies, if it the mass air flow sensor.

Oct 27, 2009 | Chevrolet Equinox Cars & Trucks

Not finding what you are looking for?
1995 Isuzu Trooper Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14384 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...