Question about 2003 Oldsmobile Alero

1 Answer

2003 Olds. Alero, runs but won't go over 10 mph. Problem started all at once, not gradually

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 73 Answers

Any check engine lights, or CEL flashing? This can be cause by a clogged catalytic converter (exhaust) or a bad torque converter (transmission) both of theses will code but not always

Posted on Oct 20, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 3 Answers

SOURCE: 2003 olds alero engine sputtering, running jerky, poor accelerati

car may need some spark plugs wirs

Posted on Feb 16, 2009

  • 1 Answer

SOURCE: 2003 OLDS ALERO WONT START

Check to make sure the Security light in dash on right hand corner is not on. If it is on , your passlock is enabled. to dissable it turn your key on but not start it and wait for apx 10-15 minutes. this should re-set it.

Posted on Apr 15, 2009

bryan213
  • 8 Answers

SOURCE: 2003 olds alero igntion/starting problem

i own a 03 alero ... aleros have history of igniton switches going bad... replace it or take it to dealer then ull be charged arm and leg...

Posted on Jun 01, 2009

  • 14036 Answers

SOURCE: 2000 olds alero will start but wont stay running.

IT COULD BE STOPPED UP FUEL FILTER OR A FAULTY FUEL PUMP.

Posted on Sep 14, 2009

  • 6 Answers

SOURCE: 2003 Olds Alero heat will only work on High

It is the blower motor resistor

Posted on Feb 28, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

03 olds alero wont start but lights on


Could be the key switch or the neutral safety switch. Will it crank in neutral instead of park ?

Jul 11, 2013 | 2003 Oldsmobile Alero

1 Answer

2002 olds alero was running then would not start back up.New fuel filter and the fuel pump is fine,but it turns over,won't start


Have you reset the fuel pump switch...bled the lines? Try starting fluid for a few times then look at these issues.

Dec 30, 2012 | 2002 Oldsmobile Alero

2 Answers

Security light is flashing. car will not start on my 2003 oldsmobile alero


I OWN a 2001 Olds Alero and the same thing happens to mine.. It's an easy fix..
1. Turn the Key to ACC (keep it in this mode for the entire 10 minutes).
2. The security light on the Dashboard will flash for exactly 10 minutes..
3. Once the 10 mins are over, the security light will stay solid..
Wait for the red light to disappear off the dashboard...
YOU ARE NOW READY TO TURN YOUR CAR OFF AND RESTART YOU CAR....

SIMPLE FIX..
I DO THIS ALL THE TIME TO MINE..

Nov 06, 2012 | 2003 Oldsmobile Alero

1 Answer

Just changed plugs and wires on a 01 Olds Alero 6 cyl now it won't start


  • Fir port of business is check your firing order. See diagram below.


11_27_2011_12_35_54_am.gif
  • Hope this helps.

Nov 27, 2011 | 2001 Oldsmobile Alero

1 Answer

Shifting/RPM problems


check tranny fluid. if tranny fluid checks good then buy a bottle of "lucas transmission additive". this is the best on market. you can buy at atuozone, oreillys or napa. the transmission fluid can only be checked while engine is warm and running in park. another stupid question. when you back up does the car make a funny squeaking nosie? if so then your u-joints are the culprit.

Feb 02, 2010 | 2003 Oldsmobile Alero

1 Answer

Shutting down


Try replacing the air filter.

Dec 21, 2009 | 2003 Oldsmobile Alero

1 Answer

2003 olds alero igntion/starting problem


i own a 03 alero ... aleros have history of igniton switches going bad... replace it or take it to dealer then ull be charged arm and leg...

Jun 01, 2009 | 2003 Oldsmobile Alero

1 Answer

2003 OLDS ALERO DIES


It's probably the main engine computer. Same thing happened to my Cadillac. Dealer replaced computer module and problem stopped.

Dec 12, 2008 | 2003 Oldsmobile Alero

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

169 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...