Question about 2010 Chrysler Town and Country

1 Answer

Cleaned the inside of my van, now radio won't turn on. Fuses to radio are good. On the corner passenger floor board there are a group of wires. Could there be a loss connection there or some other solution?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Chrysler Expert
  • 473 Answers

Check to see if any othe them came apart

Posted on Dec 02, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Need help with a 1998 ford e150 cargo van. Its the base model. No power locks or anything fancy. I have no power to the radio at all. All fuses seem to be okay. Im having an issue finding a fuse diagram....


There is no Relay. But I believe that the Radio chassis has to have good ground. That can be easily checked with a test light connected to a Positive(+) Source.

Nov 09, 2014 | Cars & Trucks

1 Answer

Radio on but no volume 2000 monte carlo ss


I JUST HAD MY FACTORY RADIO SOUND FIXED IT WAS THE WIRES FROM THE FACTORY AMP IN THE TRUNK TO THE STEREO. WIRES RAN ALONG THE PASSENGER SIDE FLOOR BOARD. WIRES CORRODED BECAUSE OF A MOON ROOF WATER LEAK THAT CAUSED WATER TO SETTLE ON THE PASSENGER FRONT FLOOR. REPLACED WIRES I PAID 100.00 TO HAVE STEREO PUT BACK IN AND WIRE CHANGED, ON STAR EVEN WORKS AGAIN I HOPE THAT HELPED. NOW FOR MY LEAK ERRR

Mar 15, 2013 | 2000 Chevrolet Monte Carlo

1 Answer

I have a 2001 Chevy Express 3500 passenger van. Where is the best location to tie into the wiring harness for traile lights?


Hi, the harness is inside these vans, if you lower the trim panel, at the back of the headliner, you will see the rear light harness. You can pick up the wires here, and then run them down through the floor, to your plug. Good luck...Coop

Dec 24, 2010 | Chevrolet Express Cars & Trucks

1 Answer

My son pulled out and then snapped back the rear passenger side seatbelt on my '99 Merc. Villager Van, and it ended up locked into place near the floor inside the mechanism used to adjust the rear bench...


is the belt wrapped around the lever to adjust the seat?
Try sliding the seat to get some slack.
He may have it in ALR mode. That is when you pull it allthe way out, and then it ratchets it's way back in until it is all the way in. Then it reverts back to pulling out and going in w/o ratcheting.
This is to lock a child seat in.
So, you need to get it in all the way somehow.

go here for more help.

Gerry

http://groups.yahoo.com/group/villagerquest/

Apr 05, 2010 | 1999 Mercury Villager

1 Answer

FORD WINDSTAR 97 WON'T START - SUSPECT FUEL PUMP; APPEARS TO START WITH ETHER STARTING FLUID; NOT SURE HOW TO TROUBLE SHOOT


have someone listen to your gas tank while turning the key from off to run. if theres no sound, goto the rear passenger side fender cover and remove (inside the van) theres a little red button down in the rear corner. check to make sure its pushed in (inersia switch for fuel cutoff). also check fuses. if you hear the pump check, the fuel filter.

Apr 01, 2010 | 1997 Ford Windstar

1 Answer

My radio quit working. turns on and looks like it is but no sound. cleaned the wires on the harness going to the amp by the rear back door. but still nothing. some previous owner has done this before and...


Soaked floor on passenger side probably is a bad seal on cabin air filter. Replace filter, and silicon glue any rubber gaskets that are loose. Cheap and easy fix.

Feb 11, 2010 | 2002 Chevrolet Impala

1 Answer

No spark at all!


you need to check the fuses again under the hood and under the dash if all are good look for a bad fuse link if you melted wires you had to blow fuses or fuse link

Dec 22, 2008 | 1998 Ford Ranger SuperCab

2 Answers

Where is the radio fuse located on 2003 chrysler T&C


According to the Haynes repair manual: "There is no fuse and relay box inside the passenger compartment.  However, there are a number of fuses, relays and circuit breakers in various locations under the dash.  The heated mirror circuits and the circuit for the lower instrument panel power outlet (in the floor console) are fused with self-resetting fuses that are only serviceable by an authorized dealer."  However, in the fusebox under the hood (a.k.a Integrated Power Module) there is a fuse RDO/IP IGN which is the fuse for the radio.  Check this fuse.  Both the radio and the Cigar Lighter are fused through the IPM.

Nov 24, 2008 | 2003 Chrysler Town & Country

Not finding what you are looking for?
2010 Chrysler Town and Country Logo

Related Topics:

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...