Question about Cars & Trucks

1 Answer

I have an '05 with the V6. Whenever i drive it in the rain or wash it,(not the engine, because of the missing fuse panel cover) the engine will start but wont run right, the traction control light comes on and the accelerator pedal is non responsive. It usually starts running fine again after it dries off. But, this time its been a week, still runs horrible, and there is a clicking sound coming from the relay labeled "powertrain" Can somebody please give me some insight on what could be wrong?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 74 Answers

Probably corrosion on terminals now. check and clean

Posted on Oct 17, 2013

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 4 Answers

SOURCE: when it rains, my 2004 dodge durango hesitates and

I had the same problem. Same year, too. 2004 4.7L Durango. Took it to a Dodge Dealer in Oak Lawn, IL. Problem was when it rained out water got into the engine from the hood by the windshield wipers. The spark plugs got all wet causing the engine to hesitate and shake. I had to have a water dam installed and never had anymore problems. Hope this helps you out.

Posted on Jun 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Only front wipers not working on 2005 expedition


check the linkages at your wiper motor. check the wires for power to the motor.

Dec 28, 2013 | 2005 Ford Expedition

1 Answer

2000 cavalier. dead battery. poss short.


Jumping a dead battery is a dangerous practice
You have to fully charge a dead battery before
putting it back in service
Have the battery tested
Get a fuse cover from a salvage yard

Jul 26, 2013 | 2000 Chevrolet Cavalier

2 Answers

When it is raining the engine idel is rough. 5.4 L Hemi engine. Only occurs during a heavy rain or in the car wash.


If you lift your hood, check the wires that are for your windshield wiper fluid, I had the same problem and because the wires were being pressed against the molding water was able to drop down onto the engine. When ever it rains really hard felt like the truck was going to cut off. But when the sun was out my baby would pur like a kitten.

Feb 08, 2010 | 2004 Dodge Durango

1 Answer

I have a 1996 Oldsmobile Aurora and when it rains my engine sputters then shuts off. it never started back up until I got the fuel pump replaced which I have done twice. But as soon as it rains again the...


Sounds like your under car plastic panels are missing I would go to your local junk yard and get those covers and put them back under there. I had a hyundai that I took the covers off and when I drove in the rain it would get up in the distributor cap and kill the engine. Also dont drive through flooded areas

Aug 01, 2009 | 1996 Oldsmobile Aurora

1 Answer

Engine cant start whenever it is raining


check on the passanger side of the car to see if the floor is getting wet as well because it sounds as if your computer is getting wet behind the glove box while at home on a nice day wash the car and check it all over for leaks because the computer or something is getting wet in the car it may be a bad seal around the windshield

Apr 26, 2009 | 2000 Mercedes-Benz C-Class

1 Answer

05/55 s60 d5 185. whirring from under bonnet


Hi, this noise is usualy caused by dry belts afther engine been washed or driving in the rain , you can buy a belt dressing spray at many auto parts ,spray all belts lightly ,repeat if nessesary until noise is gone....C1

Jan 04, 2009 | 2005 Volvo S60

1 Answer

1990 Dodge Dakota 3.9l V6 won't start


look in the engine compartment near the battery... should see a long flat plastic piece with tabs on each end... remove that cover... lots of relays there and fuses too.

Robert

Dec 19, 2008 | 1990 Dodge Dakota

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...