Question about 2003 Chevrolet Silverado 2500HD

1 Answer

Just had all 4 O2 Sensors replaced along with the Throttle Body, in my 03 Chevy 2500HD, have had my truck back 1 day, and the check engine light came back on and gave me codes PO140 and PO 160. What do I do now?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 107 Answers

O2 sensor circuit. No activity detected. Bank 2 sensor 2. Take it back to the garage. They did something wrong.

Posted on Oct 17, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 14 Answers

SOURCE: Check Engine Light - O2 Sensor - bank 1 running lean

you should have three oxygen sensors on your car, one for each bank of three cylinders; should be towards the Y pipe on each exhaust manifold. Additionally you should have one on the exhaust pipe before the cadilitic converter.

Posted on Nov 20, 2008

  • 3 Answers

SOURCE: stalling, 'reduced power' light, and OBD code P1125 Manufacturer control air metering...

These trucks have a drive by wire system,we seen a` lot with a broken ground wire on the rear of the drverside cyl head,this is hard to see just feel and give the wire a tug .If the wire is loose or broken the reduced engine power light will come on.

Posted on Feb 15, 2009

STEVIE_N_24
  • 147 Answers

SOURCE: CHECK ENGINE LIGHT ON , WITH CODE SYSTEM TOO LEAN

Possible failed bank 1 sensor 1 oxygen sensor..

Posted on Mar 29, 2009

  • 708 Answers

SOURCE: 2oo0 chevy blazer cel and code p0171 and p0174

Depending on the engine it will have between 4 and 2.

If you had a straight 4 or 6 engine then there would be only 2, one on the exhaust manifold or exhaust pipe and then one just after the catalytic converter.

If you have a "V" engine (V8, V6) then you have an oxygen sensor on each exhaust manifold and will have a catalytic converter for each bank of the V. There will also be an oxygen sensor downstream of each converter as well. In this case there would be 4 oxygen sensors.

Posted on Oct 05, 2009

  • 38 Answers

SOURCE: I have a 1999 chevy blazer with a 4.3l I took the

sounds like you know what you are doing, sometimes the codes have to be removed after repair, i'm not sure whether or not your vehicle requires this. If it is just a light bothering you try and clear the code and see if it comes back. Some Advance Auto or O'reilly has a tool to do this free of charge

Posted on Oct 13, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

03 Chevy 2500HD 6.0 Gas I have no power to the 10A fuse for the crank with the key on or off truck does start. A P0342 code keep coming up


code p0342 refers to cam shaft position (CMP) sensor A bank 1 --low input===causes--wiring short to ground---CMP sensor---ECM
Check for wiring shorting out on the engine /body, replace the cam sensor on bank 1

Jan 31, 2015 | Cars & Trucks

1 Answer

I have 03 ford e-150 with 4.2 engine. i have gotten codes 1131 & 1151 consistently. i live in upstate NY where its cold. i have replaced both ox sensors (upstream)... have cleaned mas with spray...


has your check engine light come on and stayed on after changing o2 sensors. I had a bad tempature sensor on my 2006 silverado and i replaced all four 02 sensors they were showing as bad and then i got a code that said catalyst system inefficient bank 1 and i replaced that catalytic converter and cleared my engine code and was able to go through emissions. but you might have to clean your throttle body check your plugs and wires . if you have a distributor check the cap and rotor button. you also have an egr valve that can get cloged up or go bad and a pcv valve it can be a host of things . if your mass air flow sensor is bad it could cause it to run funny . if your tempature sensor is bad it will not tell the engine it is warm and it will run rich and that will eventually cause your plugs to foul and your catalytic converter to get backed up and your o2 sensors to get carbon build up on them . my catalytic converter looked like it was starting to melt out the honey comb inside . hope this helps

Apr 15, 2011 | Ford E-150 Cars & Trucks

1 Answer

I have a 2002 chevy impala, I bought the car in december 2008 since i bought it Ive had to change the same o2 sensor about 5 times, the last time i had it changed the engine light came back on 4 days later...


Couple of notes - poor grade of fuel or additives can be coating O2 sensors. Next, when changing sensors are you disconnecting battery? If not a power surge can damage sensor and lastly check wiring harness and make sure wires are all clean and not scared along the way - could be shorting out.

Jan 30, 2011 | 2002 Chevrolet Impala

1 Answer

'05 PT Cruiser O2 sensor problems.


I had a similar problem with my car. It turned out the O2 sensors were fine and the issue was a leak in the throttle body causing the engine to run lean. If you have an ODB2 scanner you can look at fuel trims, etc and will be able to tell.

Mar 28, 2010 | 2005 Chrysler PT Cruiser

2 Answers

I got code p2176 I changed out the tps still got same problem did not have this problem with other engine just changed engine out now cant seem to get this code off causing the car to rough idle and low...


P2176=Throttle Actuator Control System - Idle Position Not Learned
Did you use all you old sensors,or is some of them from the new engine,I would swap out the IAC sensor or check for wires not hooked up.
If it can't relearn to idle the Idle air control might be different then your old one,but its not registering with the computer

Dec 17, 2009 | 2006 Chevrolet Impala

2 Answers

Check Engine Light - O2 Sensor - bank 1 running lean


you should have three oxygen sensors on your car, one for each bank of three cylinders; should be towards the Y pipe on each exhaust manifold. Additionally you should have one on the exhaust pipe before the cadilitic converter.

Nov 20, 2008 | 2002 Chevrolet Monte Carlo

3 Answers

My car is having difficulty idling, this morning it died on my way to work but started right back up. The check engine light has been on for about 3 weeks. I took it to a garage to have it ran on the...


I have the same problem, I replace the O2 sensors and nothing??????? I have no idea what to do to take care of the problem. I have just ordered a new and improved throttle body. according to the Mazda6 forum, the throttle body on the 03 model was junk. I'll keep you posted.

On a side note, I was transferred to Richmond, VA for Columbus, OH about an 8 hour drive. I have driven back and forth about 4 times with the check engine light on and have had no problems. my email is jburnitz1099@yahoo.com if you find a solution please let me know and I will do the same.

Jul 23, 2008 | 2003 Mazda Mazda6

Not finding what you are looking for?
Cars & Trucks Logo

151 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...