Question about 1999 Toyota RAV4

2 Answers

My rav 4 runs great but when I am going a steady speed ( doesnt matter what the speed) about every 10-12 seconds I hear a chirp or a tweet. Also when I start the car after it sits for a few hours ther eis a terribly LOUD screech for about 30 seconds...then it suddenly stops and is fine. My uneducated guess would be some sort of a belt? problem? thoughts?

Posted by on

  • Emmanuel Swamy
    Emmanuel Swamy Oct 16, 2013

    sounds like a serpentine belt

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 35 Answers

Well if you look under your hood if your belts are slipping there will be evidence it will look like black dust on and inside your alternator, power steering, and or a/c compressor if you still have it. also on the hood itself underneath you might see this dust. it may need replaced or just tightened. while the car is off if you garb the belt and its not tight it will squeel.

Posted on Oct 16, 2013

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 38 Answers

Could be a worn serpintene or possibly the timing belt is wearing out and slipping

Posted on Oct 16, 2013

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 65 Answers

SOURCE: toyota rav 4

I can get you a diagram on monday but it goes from the alternator to the power steering pump then around the tensioner pulley then around the crank pulley then to the a/c compressor then pull on the tensioner to give you some slack and slip it on the waterpump.I hope that helps.Let me know if you still need the diagram

Posted on Nov 30, 2008

  • 1 Answer

SOURCE: 1996 Toyota Tacoma wont start when the engine is hot and sits a few minutes

I Hope You All Appreciate This FAST and EASY Inexpensive Repair That Even The Toyota Dealers Dont Seem To Know How To Fix !!! The Problem Is The Air filter temp sensor. Look On The Left Side Of the Air Filter Housing and Disconnect The Plug Thats Attached To The Spark Plug Like Plastic Sensor Mounted on The Side Of the Air Filter Housing, Now Go Start Your Truck !!! Your Truck Will Start And RUN Fine Now ! Replace The Sensor Approx $59 at Autozone... This Should Fix 90% Of Your Problems If your In the other 10% and it does not Fix it , Email Me and Ill See If I Can Help ! People Have Spent Hundreds and into The Thousand Dollar Area Trying to Resolve This Intermittant Problem At Inept Shops with Illiterate Mechanics ! If Your Happy With This Fix, BE Generouse ! I Do Accept Donations at Paypal Send to donsgirl89@yahoo.com Thank You JOE Mechaniac

Posted on May 18, 2009

  • 242 Answers

SOURCE: On a 94 Toyota Rav 4. A warning light is on. It

its rear accel oil low light ,top up very soon as can do damage.there a nut on accel to drain and refil

Posted on Dec 29, 2009

  • 4 Answers

SOURCE: 1996 Toyota Tacoma wont start when the engine is hot and sits a few minutes

Found this solution and it worked for me on my 1996 Toyota Tacoma and fixed the problem you described...!!! Here it is --------"I Hope You All Appreciate This FAST and EASY Inexpensive Repair That Even The Toyota Dealers Dont Seem To Know How To Fix !!! The Problem Is The Air filter temp sensor. Look On The Left Side Of the Air Filter Housing and Disconnect The Plug Thats Attached To The Spark Plug Like Plastic Sensor Mounted on The Side Of the Air Filter Housing, Now Go Start Your Truck !!! Your Truck Will Start And RUN Fine Now ! Replace The Sensor Approx $59 at Autozone... This Should Fix 90% Of Your Problems If your In the other 10% and it does not Fix it , Email Me and Ill See If I Can Help ! People Have Spent Hundreds and into The Thousand Dollar Area Trying to Resolve This Intermittant Problem At Inept Shops with Illiterate Mechanics ! If Your Happy With This Fix, BE Generouse ! I Do Accept Donations at Paypal Send to donsgirl89@yahoo.com Thank You JOE Mechaniac"
The answer (above) came from this link and was posted by joe the mechanic on this thread
http://www.fixya.com/cars/t890232-1996_toyota_tacoma_wont_start_when

Posted on Jul 20, 2010

  • 2 Answers

SOURCE: car doesn't have any power

This happened to me and yes it was caused by a timing belt i replaced it and guess what? My car took forever to pick up speed but once i hit 30mi than it was fine. So i found that one valve was bended so i had to rebuild the heads now its fine one way to find out if you have a faulty valve is by unpluging one of the spark plugs wires you are probably running on 3 cylinders thats why it has no power until it reaches some speed then its fine but when you stop and try to go again it does the same thing i recomed 4 you to go check the heads i bet thats what is wrong with your car. Youll end up paying arround 500 bucks! ! Parts and labor but its a. 1990 celica worth it? Yes its the best car i have ever owned!! And if it happens again i will fix it i love my celica! !

Posted on Sep 20, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My hard wired smoke alarm has had a new 9 volt battery installed and even a second new one installed and is still chirping 4 times every 30 seconds.


On many of the newer smoke alarm installations, all of the units are wired together so that if one goes off, it triggers all of the others so that no matter where you are you will definitely hear the maddening noise of the alarms! And if one of the other units has a bad or weak battery not only will it chirp but so will the others.

Only way around this is to cut any and all wires going to each smoke detector. They will still work because each has its own battery but there will be no more triggering of other units.

Oct 27, 2016 | Cars & Trucks

1 Answer

2003 Rav 4 periodically stalls at low idle, intersections


Start with the throttle body. I use brake clean and a toothbrush. Clean the plate and were it sits. Wouldn't hurt to spray down the MAF sensor, if it has one. Once you do it, it will take a few seconds to start. Once started, rev it up and spray inside the throttle. Keep it running. Most times this is a $4 fix.

Aug 20, 2016 | Cars & Trucks

1 Answer

One tire not showing pressure replaced tire sensor still not


After TPMS sensor replacement or tire rotation, reprogramming is required. 1. key on engine off, parking brake on. 2. turn park lights on and off 4 times you will hear a horn chirp twice, you are in program mode. Start at L/F tire release air for 10 seconds, wait 15 seconds until horn chirp, after chirp go to R/F tire do the same until horn chirp then R/R let air out til the chirp then L/R do the same after the L/R chirp, turn key off and you are done, note you have only 5 min. to complete. If you do not hear horn chirp at each tire, you will have to start from beginning. When complete, remember to add air to each tire, 35 psi is recommended.

Jan 27, 2014 | 2005 Chevrolet Tahoe

1 Answer

What does service tire monitor mean on a 2005 chevy tahoe means


It means you have a malfunction in the TPMS system. First you can try to do a reset as follows: 1. key on, engine off, parking brake on. 2. turn park lights on and off 4 times you will hear a horn chirp twice, you are in program mode. Start at L/F tire release air for 10 seconds, wait 15 seconds until horn chirp, after chirp go to R/F tire do the same until horn chirp then R/R let air out til the chirp then L/R do the same after the L/R chirp, turn key off and you are done, note you have only 5 min. to complete. If you do not hear horn chirp at each tire, you will have to start from beginning. When complete, remember to add air to each tire, 35 psi is recommended.
If that does not work you probably have a bad TPMS sensor, which will have to be replaced. Some auto parts stores will test your sensors for free, so check around.

Apr 01, 2013 | 2005 Chevrolet Tahoe

2 Answers

Service tire monitor light is on


is it just a dummy light on the dash or is it more specific like L.F tire low,ect? if its a dummy light then you need to go to a garage with a tire pressure monitor service to to check to see if the batteries in the monitors are still good or if you are just dealing with a leaking tire. If you Tahoe uses wheel speed sensors to monitor tires and pressure you may have a faulty wheel speed sensor or a heads up that your wheel bearing is wearing and the gap between the tone ring and sensor have increase or decreased good luck

Apr 07, 2010 | 2005 Chevrolet Tahoe

2 Answers

Rotated tires now sensors do not read correctly


If you are talking about your low tire pressure sensors, theres a button in the glove compartment. Press it for 5 seconds to reset the sensors.

Feb 04, 2010 | 2005 Chevrolet Tahoe

2 Answers

Dodge 318 2500 ram wagon stumbles on medium acceleration .


Have to plugs and wires been replaced according to the manual every 30/60K? Check for play in the distributor. Look in the throttle body with a light for oil on the intake floor, this would be a bad lower intake gasket. Make sure to use the factory recommended spark plugs, it only likes Champions.

Jun 01, 2009 | 2002 Dodge Ram Maxi

1 Answer

My 2003 rav 4 vibrates on rear end while driving ,i hav a 2litre turbo diesel as i move up the gears it vibrates all through the car when u get to a steady speed it stops vibrateing ,even when u let the...


I would suggest having your universal joints checked out , sounds like a bad joint or bearing somewhere in the rear end, if you can get your speed up to about 50, put your rav in neutral and let it coast if it stops vibrating, it most likely is your problem

Mar 24, 2009 | 2003 Toyota RAV4

1 Answer

Envoy 2004 idle speed


Hi
your problem seems very easy :) hope this one work with your envoy. Just buy AC DELCO carburetor tune-up conditioner.

How you use it: engine running , AC off please

1. detached the big black airflow hose which is attached in the mannifold of the engine block.

2. ask your friend to step on the gas pedal and set the rpm steady in 2000 rpm only.

3. then spray vigorously in 8 seconds the inside circle opening of mannifold while your friend steady step on gas pedal with steady 2000 RPM only.

4. after you spray, let your freind continue on gas pedal with 2000 rpm for 15 more seconds.

5. attached back the airflow big black hose to the manifold and you are ready to roll with your AC on.

if this one doesnt work, please scan your envoy by scanner called TECH II. and find out.

Jul 09, 2008 | 2004 GMC Envoy

Not finding what you are looking for?
1999 Toyota RAV4 Logo

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8265 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...