Question about 2001 Hyundai XG300

1 Answer

Drops of water come out of my 2004 houndi elantra wiper washer moter i hear the moter i cleaned out hose but no pressure

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

  • Expert
  • 225 Answers

Remove the hoses directly from the pump and try your washer. If you don't get a positive flow then either the pump is bad, obstructed flow to the pump or you have a low level in the reservoir

Posted on Oct 16, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 olds alero clog sprayer heads how to get them off


2004 Oldsmobile Alero Replace windshield wiper motor ...

www.fixya.com > ... > Oldsmobile > Alero > 2004 Oldsmobile Alero
Get solutions for 2004 Oldsmobile Alero replace windshield wiper motor ... The problem is often just a clog in the sprayer heads. ... ...windshield wiper fluid, I hear the pump's motor running but no fluid is ejected. remove the hose from the wiper .

Oct 16, 2015 | 2004 Oldsmobile Alero

4 Answers

My 2004 Ford Expedition will not spray windshield wiper when the button is pushed. The wipers do turn on, but no spray. Would this be caused by a fuse (the wipers do turn on) or is the motor bad?


Can you hear the washer pump running when you operate the washer switch? The washer pump is in the bottom (side) of the washer fluid reservoir. You should hear it running. If not, you can disconnect the wire connector at the pump and use a test light to check to see if there is power and ground at the connector when you operate the switch. If there is power and ground, replace the washer pump motor. If there is no power or ground, you most likely have a bad washer control switch. (You have to replace the entire Multifunction Switch)

If you can hear the pump running, check for washer fluid pouring on the ground. If this is the case, you have a broken hose between the washer pump and the jets that spray on your windshield.

Also note that there is no way possible that your problem could be CAUSED by a fuse!
For more information on this subject, please review this article: Where's The Fuse?

May 17, 2011 | 2004 Ford Expedition

2 Answers

My front windshield wiper pump does not pump washer fluid but the wipers work fine , the back wiper and pump works


First make sure you have water in washer reservoir, with ignition on reds (not started) then get someone to operate washer while bonnet is closed otherwise the wipers (may come on) may damage your bonnet (would also be a good idea to throw some water on your screen before commencing), listen for a buzzing noise, if you can hear that noise than your washer motor is ok, if not - if fitted with fuse check it and if fuse is ok than your motor needs attention. If motor is ok than while someone is operating the washer motor look under the car to see if there is any water leaking, if there is water leaking than the hose going from your washer bottle to your washer nozzles has come off somewhere, visually check this hose, usually small diameter and clear in colour, reconnect or replace it. If there is no water leak and you have full water and motor is working, than your nozzle, usually located on the bonnet or wiper arms are blocked, this mainly happens after polishing the vehicle. There are 2 main ways of cleaning these nozzles, easiest way is to get a fine pin and poke it several times, this will clean it 85% of the time, if it does not work than you need to find the hose that connects to it and pull apart at a join, closer to the nozzle the better, and give it short burst of compressed air, have to be careful not to pop the hose out at the nozzle as some of them are located in really awkard points, hope this helps.

Apr 12, 2011 | 2004 Toyota Matrix

1 Answer

Good fues and new washer pump. still not pumping fluid. Not frozen either. Wipers and controls seem to still work at trun signal arm??


The little pipes that spray the windshield washer fluid clog very easily. Use either a very thin piece of wire or a very small drill bit (a welder's "tip cleaner" works perfect!) to clean out the sprayers. Use only 100% bottled washer fluid and not tap water since the minerals will clog up the sprayers.

Make sure the rubber hoses between the pump and the sprayers did not pop off or split. If your fluid level goes down but you get no spray it is going somewhere it is not supposed to.

When you activate your windshield washers, you should be able to hear that little pump run- it makes a very distinctive sound. If you do not hear it, there is a wiring problem.

Feb 10, 2011 | 2004 Ford Expedition

1 Answer

I have a 2001 Hyundai Elantra GLS four door car and about a month ago the windshield wiper fluid has stopped working. When I pull the wiper ledger in the car to clean the windows, no fluid is coming into...


With the hood up, try to clean your windows. If you hear the washer motor running, you have clogged jets that need to be cleaned. You can use a small, sharp object to try to clean out the jets. If you can access the hoses that go to the jets, you can disconnect them and see if you can blow through them to clear the line or use compressed air.

If the washer pump is not working, I would disconnect the wires going to the pump. Test them using a voltmeter to see if you are getting power to the pump. If you are, it may be time for a new pump. If not check the fuse. If the fuse is good its in the control mechanism. Hope this helps. Good luck!

Mar 11, 2010 | Hyundai Motor 2003 Elantra

1 Answer

Winshield Washer Fluid extremely low pressure


The washer pump is located in the right front fender, mounted infront of the wheel. Remove the front portion of the wheel well splash cover to gain excess. This pump does the work for the front and rear washers. Verify that the pump is working and then check for a pinched hose.
However, if you hear the pump working,as you say, open the hood and take the hoses off the squirter nozzles to see if there is good flow of fluid. If there is, then your nozzles are plugged. You may be able to clean them out with some air pressure. Careful working with the nozzles, as they are plastic and break easy.

Steve

Jan 11, 2010 | 2004 Hyundai Santa Fe

3 Answers

Heater only works when it's on the highest setting (I believe it's the blower setting). Can't get the windshield wiper sprayer to work. Reservoir is completely full!


Heater: make sure temperature slider is all the way to the red /hot zone. This is a different slider than the one for blower speed. Blower setting will not change the temperature. Sprayer: 1) make sure rubber hose from tank to sprayer is purged (full of water). If unpurged, water wont reach sprayer. 2) make sure that hose did not detach. 3) Can you hear the water pump running when activating the sprayer? maybe cable became unhooked or pump is shot.

Dec 08, 2009 | 2001 Dodge Stratus

2 Answers

Wipers on 2000 elantra won't work.


yes you can simple problem to fix there are rodes that connect the two wipers together with a rocker arm it has com loose from the moter there are screws under the hood holding a panel closet to your winshild and there are screws in the panel out side the hood you will need to remove the windshild wipers to remove this panel once it is off you will see what i'm telling you

Dec 05, 2008 | 2000 Hyundai Elantra

Not finding what you are looking for?
2001 Hyundai XG300 Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...