Question about 1989 Chevrolet C2500

Open Question

Injector pulse problem on 89 C2500 350 TBI - 1989 Chevrolet C2500

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 89 s10 2.5 has fuel and fire injector has power but no pulse

injector pulse is just controlled by the ecm or computer as some would say,u said u replaced wires? did u have a fire or melt wires? ecm is known to go bad on these,had a few of these trucks back in the day.

Posted on Feb 16, 2009

Ad
  • 17 Answers

SOURCE: i have no fuel injector pulse. the truck is a 92

replace the module in the distributor

Posted on Apr 09, 2009

Molson02536
  • 3854 Answers

SOURCE: 1993 s10 2.8 tbi the fuel pump fails to pressurize

There needs to be 60 PSI of fuel pressure in the system to have the fuel injectors to work. There is also a fuel pump relay on the fire wall just left to the brake booster, There is two relays there, i just can not remember which relay is which but try switching the relays with one another. Also check the fuses to the fuel pump and ECM, and the fuel pressure from the shredder valve. Good luck and keep me posted, not a bad Idea to also replace the fuel filter, and that is located at the inside frame rail under the drivers side.

Posted on Jun 03, 2009

  • 1071 Answers

SOURCE: i have a 1988 s-10 with a 2.5l is getting no pulse

short to groun in a wire or the injector

Posted on Jul 21, 2009

  • 79 Answers

SOURCE: No power to injectors 350 tbi

Check the crank sensor for failure. It is relatively easy to change and it is what tells the computer that the engine is turning over. If there isd no crank signal the computer wont fire the injectors.

Posted on Aug 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1993 Geo tracker fuel injector is not working right. i have to pour fuel into it. any suggestions on what i should do?


Important to know if it's not working at all, or if it is working some, just not enough? If not at all, then you need to check the injector wiring circuit, it's pretty simple really, just a hot wire with key on, and a ground wire that goes into the engine computer. Test with a voltmeter, best practice.

You should probably first check fuel pressure. The injector won't work unless the fuel pressure inside it is at the specified pressure. If the fuel pressure is too low, you have a bad fuel pump or a clogged fuel filter. If the fuel pressure is correct, you could have a clogged injector. The best way to clean that is with the injector off the engine.

Dec 09, 2015 | Geo Cars & Trucks

1 Answer

89 dodge d150 318 tbi turn key to on position gas pours out of injection and fills throttle body in seconds I'm wondering is this absolute proof of complete failure of fuel pressure regulator failure?


89 dodge TBI system - that is NOT proof of the Pressure Regulator failing.
The fuel system will pulse on when the key is turned on to charge the fuel rail for starting. The injector should not leak - probable injector failure (stuck open) - try disconnecting the wiring to the injector (to rule out computer controls) and see if it still leaks with just Key-On. If it still does you can also tap the throttle body case where the injector is - if it stops - definitely the injector (don't damage the throttle body - lightly tap )
You may want to retrieve fault codes before you try disconnecting things and creating new faults. If you don't have a code reader - try Key On - Off - On - Off - On (without cranking) and count the flashes of the engine lite - all two digit codes - usually starts with code 12 (battery disconnected recently) and ending with 55 (end of tests)

Feb 05, 2015 | Dodge Cars & Trucks

1 Answer

89 camaro 5.0 tbi injector pulse intermitant


What have you checked? I would start with a noid light to see when the two injectors wiring is pulsing. if intermittent then i would check the pickup coil located inside the distributor. It controls timing for the injectors and for the timing advance.

Oct 18, 2014 | 1989 Chevrolet Camaro

1 Answer

No injector pulse on 89 olds 3.8


ECM? Check grounds also. The ECM uses the ground circuit to fire the injectors. Bad injector ground, no fuel.

Aug 15, 2014 | 1989 Oldsmobile Delta 88

1 Answer

Injector not fireing


you have a TBI 8valve engine. just like my 91
the injector , not firing, so by guy method.
1: it dont click? (sonic ,stethoscope)
2: the noid dont flash. (use a noid lamp and win)
3: it dont squirte, watching it with eyes, cranking,

if the noid fails, that means ECU is bad or one of 3 inputs to ECU are dead.
if noid works, that means, the injector is cogged, it has 10 micron screens that are easy to clean. or there is no 35 PSI fuel pressure.

here is the page just for that.
  1. THE ECU IS PROGRAMMED to cut fuel if there is no spark preventing TV like crashes and burns. (and other fire reasons)
  2. the tests are all easy. no order but #1 is #1
  3. fuel pressure at spec.
  4. injector coil reads 1.0 OHMS.
  5. injector clean. (there is only one, so all hope is just here)
  6. noid lamp fails , so is CMP dead? or TPS TP pin stuck high or , ecu throwing code 41./42s errors, BINGO!

http://www.fixkick.com/INJECTORS/injectors.html

or no starts

http://www.fixkick.com/INJECTORS/injectors.html

May 06, 2014 | 1992 Geo Tracker

2 Answers

89 GMC K2500 5.7L TBI not spraying fuel


have you checked the coolant temp sensor? it controls air-fuel mixture.

Jul 16, 2009 | 1989 GMC K2500

1 Answer

No injector pulse width if system voltage over 12.5 volts


Hi, it sounds to me that you are losing contact at the ignigtion switch..C1...

Dec 02, 2008 | 1994 Oldsmobile 88

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...