Question about 2005 Saab 9-3 1.9

2 Answers

Hi after full service i cant get any speed from my car when i put my foot down the reave go very high but can't get any speed

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 444 Answers

If you had your transmission serviced along with everything else then my guess is they didnt properly fill the transmission or didnt seat the filter correctly. at any rate damage has already occurred and your only a few miles of driving away from complete transmission failure. i would take the vehicle to another shop and have them diagnose it. if that is the issue youll need to make arrangements with the shop that did the initial service or contact an attorney. even if they fill the transmission up to the proper level and it seems to work ok unreversable damage has already occurred and the lifespan of your transmission has been seriously reduced

Posted on Oct 15, 2013

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 77 Answers

Can be the clutch, adjust the clutch

Posted on Oct 15, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Audi a4 1.9 tdi


Simple fix come by.

Feb 26, 2014 | Audi Cars & Trucks

1 Answer

Can the Rpm on the singer speed be slowed down?


if you are talking sewing machine the machine speed is controlled by the foot control. Light pressure slow speed through to full pressure is max speed. If it runs flat out regardless of the foot control position then the fault will be there or the resistance part near the motor.. Have a sewing machine mechanic look at it.

Jun 26, 2013 | Cars & Trucks

1 Answer

Faults


Try to replace your fuel pump relay. If that doesn\'t work, replace the spark plugs. If that doesn\'t work, replace your high tension leads with boogie cords.

May 27, 2013 | 2001 Nissan Almera Tino

1 Answer

Sputtering at high speed


i think only the link given visit their and your problem will be solved http://toolsnyou.com/

Aug 12, 2017 | 2002 Pontiac Aztek

1 Answer

I have a 2003 mazda rx8 its a manuel anyway il be driving in 5th gear and il put my foot down and the rev needle will shoot up and then drop back down while my speed


Yes it is the clutch slipping, in high gear the greatest load is put on the clutch so that is when they slip the most.

Mar 16, 2012 | 2004 Mazda RX-8

2 Answers

BLUE SMOKE FROM AUDI RS6 ON DE ACCELERATION AND START UP THINK OIL STEM SEALS ARE LETTING OIL THROUGH. CAR RUNS FINE I THINK, AND EXCESSIVE BUILD UP OF OIL IN DRIVER SIDE TURBO PIPE, 62000 MILES WITH A...


General rules of thumb: Low speed engine on acceleration with smoke in the exhaust plume = worn piston rings High speed engine accelerating (spooled up turbo) with smoke = oil form turbo bearing and/or piston rings Engine on over run (coasting down, foot off the gas) with smoke = oil from valve guides. VW/Audi make good engines with tight tolerances so none of the above should apply at 62K miles; just make sure that the oil (the right oil) and oil filter are changed regularly.

Feb 04, 2011 | 2004 Audi RS6

1 Answer

2000 vw bug having problems


Sounds like possible block in catalyst or broken up and blocked catalyst or oxygen sensor fault causing fuel/air mixture confusion if you take first o2 sensor out of exhaust manifold/pipe and see if performance back then this will confirm blockage although will be slightly noisy while testing cos sensor removed.

Dec 12, 2008 | 2002 Volkswagen Beetle Turbo S

Not finding what you are looking for?
2005 Saab 9-3 1.9 Logo

Related Topics:

28 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saab Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

rgbypoet

Level 2 Expert

166 Answers

Are you a Saab Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...