Question about Dodge Ram 50

2 Answers

Good morning, thank you for the help with the comments. My truck was runnin fine till this mornin. I was drivinin up a grade and got a power loss, i had a small load of wood on but have pull this grade many times. i had to sift to 3rd. which is not unusual, but then i had to shift to second, which is unusual, on my way back, i went up the same grade, same thing, never had to go down to second, i was unload, i coulds still feel it. it feels like to me, when the truck is in third gear, almost to the peak of shifting to forth [about 40 mph]the power drops or almost feels like it bogs. When i do shift into forth, i can feel it again and if i give it more gas to pick up the speed, it bogs and there is a vibration. My truck is a 1983 Dodge Ram 50, 4x4. The Motor is a Mitsubishi, Model # L026, Engine # G63B, 2.0, 4 Banger.Thank You for your time and any help.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Dose any 1 no where I can find a cheep carboratur that will fit it

Posted on Dec 08, 2013

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Dodge Master
  • 3,204 Answers

Sounds like you are losing pressure could be the exhaust or the piston rings or the head manifold leaking. if you have the engine pressure tested should tell you witch is the problem rings is mostly the problem on a work hourse engine. .

Posted on Oct 15, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Need Help With Intermittent Power Loss


possible bad fuel cap vent?

Jul 20, 2015 | Cars & Trucks

2 Answers

Hi Gurus, My 4JX1 engine is vibrating (rough engine sound as if not much fuel is injected) on idle and loss of power while I am driving after I injected oil grade 40W. After I notice that the oil grade...


i would suggest doing a full tune up and engine flush, if this does not correct the problem then there is something else wrong and needs to be checked on a code machine

Nov 09, 2010 | Isuzu Rodeo Cars & Trucks

2 Answers

Runs fine till warms up then losses power and dies


Does the fuel line still have 55 PSI when engine warmed up? Any other codes show up?

Aug 22, 2009 | 1998 Chevrolet Blazer

1 Answer

Loss of power going up grade


sounds like a very common problem on turbo vag vehicles,the variable vains are sticking in the turbo,your fault code would have said....turbo boost pressure not reached.....common with v v t turbos,run a good quality fuel cleaner through it ,if that doesnt work then a new turbo is the only cure

Dec 29, 2008 | 2004 Audi A4

2 Answers

Rough runnin jetta


Try disconnecting the MAF sensor, if the problem clears either clean the MAF with brake clean or replace it, whichever works.

Aug 24, 2008 | 2001 Volkswagen Jetta TDI

1 Answer

Ruough runnin jetta


Did you check the timing? Also make sure the injectors are putting out the correct amount of fuel. By oxygen sensor I'm assuming you replaced the MAF (mass air flow) sensor? Are all the vacuum lines in good shape and is the EGR vavlve actuating correctly (they can get gunked up)? Is air getting into the fuel lines somewhere? Is the engine not getting enough air when the turbo isn't on? Maybe your intake is clogged up but this isn't extremely likely since you'd notice power loss at higher speeds. What was done recently to the vehicle that might have caused this?

Aug 24, 2008 | 2001 Volkswagen Jetta TDI

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8531 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...