Question about 1995 Chevrolet C1500

3 Answers

1995 chevy 1500 305 v-8 - 5-speed will not start

My son is in nc with the marines,he drove his truck from tn, it ran great. 130000 miles. it shuts down when he starts and drives a few miles, also sometimes it will not start at all. battery connections are tight, he poured a little gas down throttle body, still would not start, had the module checked inside the dist , it was good, changed the dist cap and rotor. truck still has the same symptons. any ideas or help

Posted by on

  • 2 more comments 
  • olds3031 Apr 24, 2009

    need more details, the truck did not start this morning, poured gas in throttle body, still no start, check engine light not on, but 1 hour later it started and ran 15 minutes and quit. help

  • olds3031 Apr 25, 2009

    the starter turns over great, had elec ing module checked , it was good, it is sort of weird you can pour gas down throtttle body and truck will not start either,truck started late yesterday but cut off after 15 minutes, what about fuel pump realy breaker? thanks mike

  • olds3031 Apr 25, 2009

    its turns over as soon as you turn key on, my boy sys it shuts down but not like gas problem.

  • olds3031 Apr 26, 2009

    ecm was checked good. mike

×

Ad

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,037 Answers

Does it crank over immediately when he tries to start it and has this problem? Also does it sound like it is starving for gas when it shuts off? Anything else on how it acts or sounds like when it has this problem will help me narrow down the solution. Let me know the above info and I will get back to you about what I think.


Benjamin

Posted on Apr 25, 2009

  • Benjamin Patri
    Benjamin Patri Apr 26, 2009

    I would have the ecm checked and tested then as the next step.

  • Benjamin Patri
    Benjamin Patri Apr 26, 2009

    The battery terminals are clean too, correct? How does the engine temperature look when it shuts off, does it have a sudden jump or is it really hot? I would also look into the camshaft and crankshaft sensors, one of them may be bad even if it returns no codes. You have had the codes checked, correct?

×

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 79 Answers

Possible bushes in starter motor worn or start solinoid ,, you can have the starter reconned but its best to pay the exstra and have a brand new one...   I sure at 99% that this with sort your problem out 

Posted on Apr 24, 2009

  • matthew davies Apr 24, 2009

    if the starters working then its going to be the electric ignition.. braking down.. this can be costly

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

Could be fuel pump, fuel filter, or sensor. GM sensors are well known to go out. If your check engine light is on, than the problem is definately sensor or electrical related.

Posted on Apr 24, 2009

  • Nate Stansfield
    Nate Stansfield Apr 25, 2009

    If your check engine light is on, that I would bet you have a bad sensor. Possibly CKP sensor. If the light is not on, it is likely bad injector or fuel pump. Do check the fuel pump relay. Those do have a tendency to go quick on the GMs

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

01 durango 5.9 no bus message but if I wiggle the black connector at the pcm the car starts but shuts down after a minute or so,meaning the fuel will not prime without me doing that ,prior to the no b


Remove the black connector to pcm . Check for corrosion pins . Then inspect the plug end for corrosion. I found moisture seep by the weather pack seal and wire on older vehicles.

Feb 11, 2015 | 2001 Dodge Durango

1 Answer

1996 deville runs then doesn't?


You need to find out what is missing when it won't start , spark - ignition system or fuel pressure . No Start Diagnostic Basics EricTheCarGuy

Apr 18, 2017 | 1996 Cadillac DeVille

2 Answers

1995 nissan pickup truck fuel problem


Fuel injected or carb? Make sure fuel line itself is clear. Some pumps are designed to self regulate (carb systems) some continually pump and a psi regulator sends back the excess fuel back to the tank (fuel inj systems) If the line is obstructed then pump can't deliver fuel fulltime.

If you think pump is not on consistent, try running a dedicated wire through a switch directly to the pump. If it works then you are looking for an electrical fault going to pump. Good luck.

Mar 10, 2010 | 1995 Nissan Pickup

1 Answer

Replaced transmission now abs light is on.


doing it your self is guessing
autozone and others do the code reading for free
at this point I would be checking the wires and connections as that distance after installing would be about right for a connection not put together properly would fall apart or a harness wire would burn through on the exhaust

May 27, 2017 | Chevrolet Cars & Trucks

1 Answer

95 wrangler yj. has no power at high speeds


Have you had fuel pressure tested, and/or filter changed. Have you checked for plugged exhaust, such as catalytic converter? Quite often engine will also run a little hotter than normal when exhaust is plugged.

Nov 05, 2009 | 1995 Jeep Wrangler

2 Answers

My sons 1990 626 ran great. I change the oil and reconnected the speedometer cable that had vibrated loose. took it for a drive to make sure I didn't have any oil leaks. It ran for about 5 minutes and just...


we'll assume fuel is good..leaving spark and air..and management of systems(computer /sensors)...so the speedo cable was disconnected? try taking it loose again , test drive and report back please

Nov 20, 2008 | Mazda 626 Cars & Trucks

2 Answers

1995 wont start


its probly the fuel pump

Sep 13, 2008 | 1995 Pontiac Bonneville

Not finding what you are looking for?
1995 Chevrolet C1500 Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...