Question about 2004 Ford Expedition

1 Answer

My 2004 ford expedition check engine light is on,and reading bank 1 and 2 changed them and it still is idling rough,so someone suggested to change the idle control sensor what a waste of $103 anything else i am overlooking please help cant drive with both feet at a red light forever,another problem is when i go to start the car it takes a couple of seconds to turn ova(not the sound that a bad starter would make,but the sound when you normally start a vehicle but turns over a couple seconds later thanks)

Posted by on

  • autoaccessor Apr 24, 2009

    the codes are sensor bank 1  and 2 before and after exhaust,i disconnect the battery it erased the code but stills does the same thing,check engine light came back on,asked another mechanic he said when there is a problem with your vac hose it does this,I dont know how to check or even where to check for the vaccum hoses,any suggestions or even pictures please help, thanks SNORKELBOBBY

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 4,369 Answers

What are the codes? Try disconnecting the battery for 1/2 hour. Then reconnect so the engine computer can relearn the strategy and the changes of parts you made. It will run rough for 10 miles or so.

Posted on Apr 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rough idle, stalls, extremley rich


Maybe sensor is not for a bigger engine

Mar 05, 2013 | 2000 Ford Expedition

1 Answer

My 2000 Ford Expedition 5.4L V8 4x4 idles really bad when stopped at a red light. Sometimes it will just stall. It always starts back up. It goes just fine when I hit the gas, real smooth and powerful. It...


Check the idle fuel pressure. Load the electrical with headlights and heater defrost etc and see if problem gets worse. Attempt again with all accessories off. Could be fuel pump is getting low voltage at idle or fuel pump is failing. Bad fuel pump would definitely be a problem high fuel demand. Check vacuum line between pressure regulator to intake manifold.

Check for a air leak in the intake manifold. Gasket/hose etc. The P0171/P0174 is an indication that not enough fuel or tow much air. You can sometimes hear the air leak during idle.


Best solution is to use a graphic capable scan tool and watch the fueling trim/idle.


scan-tool-software-graph-a-rikgbt5tk1ywbo1m3dxzkw2o-3-0.gif

Mar 04, 2017 | 2000 Ford Expedition

1 Answer

Does Ford 2004 Eddie Bauer Expedition have carburetor?


it is very possible that it is a idle air control motor.it is located in the intake

Jul 04, 2012 | 2004 Ford Expedition

1 Answer

2004 ford freestar van idles rough


For rough idle and error code issues on your ford freestar.Click the link below:----
http://howtobyme.blogspot.in/2012/01/2004-ford-freestar-van-idles-rough.html
--------This will help.Thanks.

Jan 31, 2012 | 2004 Ford Freestar

1 Answer

I have a 4 liter V6 2003 Ford Explorer ( 2 door). The check engine came on and then it started idling rough. When it idles rough the AC blows hot. Recently it has started stalling when idling at a...


Hello! Most probable cause is a leak in the vacuum line or broken elbow connection to the Positive Crankcase Ventilation (PCV) valve...Check PCV and its vacuum line...Send results...

Guru..............saailer

Aug 27, 2010 | 2003 Ford Explorer

1 Answer

My '04 ford expedition has been starting rough. Someone suggested we turn the key a few times before starting it and that worked great. This weekend I filled the truck with gas. The next morning the check...


if its a lean code p0171 p0174 then i would suggest looking for a vacuum leak or the air filter housing and air inlewt for leaks.
is this a 2v or a 3v engiune?

Jun 02, 2010 | 2004 Ford Expedition

1 Answer

2003 Ford Expd. running rough @ idle -


There could be many issues. These codes read your engine is running too lean. Check : all your vacuum hoses for leaks, PCV valve and hose, MAF sensor. This may require an experienced technician to figure this out. Hopefully I help'd!!

Apr 05, 2010 | 2003 Ford Expedition

2 Answers

P0136, P1131, and P1151 codes on Ford Expedition 2000 4.6L


Your auto has four O2 sensors. Two upstream and two downstream; With two banks. Bank 1, sensor 1...and bank 2, sensor 1 are the two upstream (exhaust manifold before the catalytic). Bank 1, sensor 2 and bank 2, sensor 2 (other side of catalytic)

Code 1131= upstream; bank 1..sensor 1
Code 1151= upstream; bank 2..sensor 1
Code P0136 (generic code) bank 1..sensor 2 (questionable)

I wouldn't spend the money to purchase 3 sensors. Highly unlikely all three are bad; Cost is about $40/ ea.
Since there isn't a code for the cat's themselves, I would suspect the O2 circuit is malfunctioning. The rough idle is another clue.


Take an ohmmeter set it on X10 scale and measure the resistance from engine to body and body to negative post on battery terminal. You should read zero ohms (full needle deflection). If you do go buy two upstream O2 sensors. If you read
open or a high resistance run two straps from eng. to body...and body to neg.batt. post.

FixYaWIZ................saailer

Dec 10, 2009 | 2000 Ford Expedition

1 Answer

Diagnostic Codes p0171 bank 1, and p0174 bank 2 (too lean)


Those codes are for the oxygen sensors, lean fuel mixture on both banks. Change them, problem with stalling and rough idle should go away.

Apr 23, 2009 | Ford Expedition Cars & Trucks

Not finding what you are looking for?
2004 Ford Expedition Logo

Related Topics:

757 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...