Question about Mazda Protege

Open Question

I recently bought a 2000 Mazda Protege ES 1.8L. It started to idle rough and started to stall while idling, coming to a stop, at red lights and turning onto streets. Once the rpm are over 1000 the vehicle runs smooth. I have tried changing the Air Intake Hose and MAF sensor with no luck. I currently want to try and change the Ignition Coils, Spark Plugs and wires. I want to make sure that the wires are in the correct position. Currently they are set as the following (from left to right) Wire #1 from plug 1 to Coil plug 3, Wire #2 from plug 2 to coil 3, Wire #3 from plug 3 to coil 1, Wire #4 fromplug 4 to coil 4.

Posted by on

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Code says system running too lean Bank1 and at stoplights I have to put car in neutral or it will stall


Lean Bank1 can be attributed to a faulty oxygen sensor or by unmetered air entering the system. A comon problem with the protege is cracks in the plastic air intake hose after the MAF which sucks air in that is not registed by the car and thus make it run lean and idle poorly
.
Another comon problem causing rough idle is the EGR valve being stuck because of carbon deposits, this will usually throw an EGR related check engine light but not always.

Feb 11, 2013 | 2000 Mazda Protege

1 Answer

2000 Mazda Protege LX 1.6. Recently changed Rad, Alt, Batt. Now when i am at a red light and the car is idling, the RMP's fluctuate between 1-0. As soon as the needle hits 0 the car stalls. Oil light and...


start the car but do not drive it. look at the belt when it is running. if belt hops around then the tensioner is bad and not holding belt tight enough. or the belt itself may be bad. alo check for a bad idler pully for the belt.

Apr 18, 2011 | 2000 Mazda Protege

1 Answer

I got a 2003 mazda protege 2.0 the check engin light came on. it drives great but when left to idle it sounds like its going to stall.


Could be the Mass Air Flow sensor. But I would check the cold air intake tube first, they are subject to cracking and any hole in it will cause the MAF to give false readings which will trigger the light and cause rough idle, stalling and hesitation.

Jan 31, 2011 | 2003 Mazda Protege

1 Answer

Rough idle when stopped in drive


hi barry i have the same problem did you ever fix yours ?

Sep 30, 2009 | 1995 Mazda Protege

7 Answers

2003 Mazda protege had rough idle and wants to stall when I stop.


The idle on my 2003 Mazda Protege started acting strange one day - it kinda surged forward a little bit. Then the RPM would drop and kept wanting to stall out. It stalled out at a stop sign. The check engine light came on. I drove it immediately to my Goodyear mechanic. It ended up being the Idle Air Control Valve. They had to order the part from Mazda which took 3 days to get there. The whole thing cost $700. Runs great now (again).

Dec 30, 2008 | 2003 Mazda Protege

1 Answer

Engine bogs and stalls


Check the air filter hose. My '99 Protege was idling rough and would sometimes shut off. The air filter hose was cracked half way around. I replaced it (easy just loosen two hose clamps and pull out the sensor) and the car is running fine.

Dec 27, 2008 | 2000 Mazda Protege

1 Answer

Idle 2001 mazda protege ES 2l


relpace the fuel rail pressure regulator

Dec 24, 2008 | 2001 Mazda Protege

1 Answer

1995 mazda protege having problems running during aceleration


change the transmission fluid, replace the oil and oil filter check spark plug cables, check starter coilpak, and make sure there is coolant

Jul 02, 2008 | 1995 Mazda Protege

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...