Question about 1998 Ford Escort

1 Answer

Help! i have discovered none of my rear lights are working when i turn lights on.brake lights are good,as is the rear fog light.Any ideas please as its dark a lot of the time i use car.thanks.Car is 1998 1.8 vetec ghia escort in uk

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 3 Answers

Check the dash fuses and open the trunk and inspect the wiring for breaks or other damage.

Posted on Oct 13, 2013

Testimonial: "sadly not the solution.has been suggeste to change the stems on steering column,"

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2 Answers

SOURCE: Brake lights

I have a 98 and had the same problem just today, I found the problem by looking up where the pedal goes to and you will see two switches that the pedal hits when released, its the switch on the left side of the car, you will notice two (well one is prolly missing since the lights wont go off) blueish rubber pads on the brake pedal that hit the switches. since the one that goes to the switch to turn the lights off is gone go out and buy a small plastic body push screw to insert in the hole the old pad was in. there ya go all fixed

Posted on Oct 20, 2008

  • 1 Answer

SOURCE: Ford Focus ZX5 - Rear brake lights stay on when car is running and in gear

You are the MAN, Just like you said TRocky, there was a short in the center brake light wiring. Found the short in the rubber boot that connects from the lift gate to the car. Inside that rubber boot the wires were cracked and some were shorting.Repaired the wiring and everything is back to normal.

Posted on Nov 03, 2008

  • 5 Answers

SOURCE: 95 escort rear park lights stay on

brake light switch

Posted on Dec 27, 2008

  • 345 Answers

SOURCE: front sidelights and tailights inoperative

the switches are a nightmare they always play up,if your good with a multimeter check the supply at the switch (feed in)flick the switch to on and check the output,no input broken or damaged wire or relay if you have input but no output its a switch fault....

Posted on Jan 29, 2009

billtec
  • 61 Answers

SOURCE: rear fog light not working on 1998 escort 1.8

HI,CHECK YOUR BULB FIRST, THEN FUSE,IF ALL OK THE ESCORT FOG LIGHT SWITH DO PLAY UP,RENEW WITH NEW/ GOOD S/HAND,THANKS.

Posted on Mar 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No rear brake lights and rear turn signals not working either front turn signals blink rapidly 2001 chevy HHR all fuses good all bulbs good no power to rear sockets 3rd level brake light works


Your front signals flash rapidly because your rear ones aren't working and that is normal and shows that a bulb in the circuit is out. At least that means the problem is not with the operation of the signal....good. Also your 3rd brake light works which shows the brake switch is working. Again...good.
Everything so far points towards your rear light clusters being at fault, although both at the same time is somewhat unusual.
You don't mention rear lights that come on with headlights or the reverse and fog lights. If nothing is working I would check the earth/grounds and the connection blocks that carry the power to the light clusters, but again both at the same time being faulty is suspicious and if the reverse, fog etc is working then why not the others?
I don't know about your model, but is there a separate fuse for the rear lights that are out? Probably not but worth a check.
Have you recently had something changed on the vehicle, or inspection work done? Maybe wires/connectors/grounds etc have been damaged or disconnected/reconnected wrongly in that area.
Try running a live directly to the cluster to see if that makes anything work as it may show a circuit break as the problem.
Sorry I can't be of more help.

Oct 28, 2015 | Cars & Trucks

1 Answer

On a 1999 hyundai excel is the rear fog light on a seperate fuse?


could you be talking about the backup lights? I have never seen rear fog lights on a car and I have had a bunch of them. With help, set the emergence brake and have someone start the car and place the shift in to reverse, be sure you are not standing right behind the car. see if the lights you are talking about light then. Remember have the person put thier foot on the brake while dooing this.

Feb 27, 2015 | Hyundai Cars & Trucks

1 Answer

On a 2000 hyundai excel is the rear fog light on a seperate fuse?


Could you be talking about the backup lights? I have never seen rear fog lights on a car and I have had a bunch of them. With help, set the emergence brake and have someone start the car and place the shift in to reverse, be sure you are not standing right behind the car. see if the lights you are talking about light then. Remember have the person put thier foot on the brakes.

Feb 27, 2015 | Hyundai Cars & Trucks

1 Answer

Service lights don't come on


check wire connections at light with ohm meter and at switch if replacing the bulb doesn't work

Oct 31, 2012 | 2004 Subaru Forester

2 Answers

2004 Saab 9.3 Conv Passenger side front & rear fog lights will not work. New bulbs. Why? What to do? Is there a fuse for just those on right side? All other lights work fine.


Sounds like similar problem I had on my older 93 - one side main beam and brake light not working. Turned out to be a problem with the filament testing relay. Got it resoldered and now ok.

Oct 16, 2009 | 2008 Saab 9-3

1 Answer

1989 Cadillac rear lights stay on


It may be a turn hazard module under dash.that is the culprit! The power to the third brake light does not go through the module, but the rear brake lamps power is controlled through this module. I am looking at a drawing of one and it looks like it has two connectors with about five wires in one and six in the other. It has some cooling fins on it also.

May 30, 2009 | 1989 Cadillac Brougham

1 Answer

99 A4 tali light assmbly missing top bulb passenger side


That's the rear foglight socket. The rear foglight idea is European, and they ship the Audi over with a rear foglight as well, but it's only on the driver's side (that's the way rear fogs are done in Europe). That socket is fully powered though, and wired to the same dash switch as the driver's side rear fog. What you can do (what I did on my 99 A4) was to use a drill and **** out the rectangular opening in the rear taillight panel, and then put a bulb in that socket. Voila, instant dual rear fogs.

This is a good idea because in Europe, the police understand that a rear fog is only on one side. In the US, our police don't always know that, and you may get pulled over if you have that on - they may think you have a blown taillight bulb. Do the dual fog mod as described above - it'll save you the hassle and it looks better too.

Feb 08, 2009 | 2006 Audi A4

5 Answers

Chevy s10 brake lights


If the problem is that the brake lights will not turn off, the problem is most likely the CHMSL relay. An easy check is to take the cover off the fuse block mounted on the driver's side fender well and swap the fog lamp relay with the CHMSL relay. If that fixes it, just get a new relay for the fog lamps and you're good to go. Note, my 2002 s10 does not have fog lamps, but it still had the relay populated in the fuse block.

Jul 25, 2008 | 2001 Chevrolet S-10

1 Answer

Rear Lights Malfunctioning


Hi,

Usually when this kind of thing happens it will be a bad earth, that means that somewhere within the lighting circuit the earth cable has broken down. Try and locate the earth cable that connects the rear bulbs, see if any rust or damage is visible.
If not you could try adding a seperate earth cable to a clean point close to the bulb holder in the rear.

If this fails to work then it may be an idea to talk with an auto electrician.

Good luck.

May 30, 2008 | 2002 Jaguar X-Type

Not finding what you are looking for?
1998 Ford Escort Logo

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...