Question about Cars & Trucks

Open Question

My Yamaha yzf r125 is not running correctly,when throttle held at constant position the engine revs go high and low.I have fitted new plug but made no difference

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 148 Answers

SOURCE: engine stalls

your on the right route but also check egr valve

Posted on Jul 07, 2008

SOURCE: Help - I have a

HI ! YOU HAVE PROBLEM WITH IGNITION CONTROL MODULE. YOU HAVE TO CHANGE IT

Posted on Jul 31, 2008

  • 1 Answer

SOURCE: Noisy engine idle and stutter at low or high speed

I had the same problem (X-type 2.0d 2004). The stutter was cured on mine by getting the ECU fashed with the latest firmware. This is a known problem and the update does cure it (£28), I didn't bother with all the tests the garage wanted to.
The noisey engine at idle is the alternator belt. It resonates at idle and causes the noise, There is a modified bottom pulley, tensioner and belt kit, but it is rather expensive ~£200 plus fitting (around 4 hours labour). Mondeo's have the same problem but that kit doesn't fit the Jag.
Hope this helps
KB

Posted on Mar 16, 2009

  • 3 Answers

SOURCE: 2004 Honda Civic -Code P0122 Throttle Position Sensor Voltage Low

yes, this is the case of a failed throttle body, in which case it needs replaced, the car is getting too much fuel causing the high idle. this needs replaced asap. you could proably find a small independant honda shop that could do the work for less.

Posted on May 12, 2009

  • 1 Answer

SOURCE: VW Polo Map sensor fault code idling pooly

Hi, I have a 2001 polo 1.4 mpi it lackes power when you hit a hill it just dies, It has had new cat, fuel filter, fuel pump and throttle body, but is still the same it just dose not want to give me full rev's?

Posted on Apr 11, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Over revving


I had similar problem on 98 Taurus. The plastic housing from air filter to Throttle body had crack on bottom, could not see from above...car would over rev sometimes, then almost stall, Replaced it, with good one from junkyard. Runs smooth again. Crack came from shoving that housing out of way from putting in new thermostat earlier.

Aug 27, 2014 | Hyundai Excel Cars & Trucks

1 Answer

Rev problem


There can be several reasons for this. A stuck throttle flap in the intake manifold, or an opening in a gasket.
Some of the engines have a part called a manifold runner. This part is like a 2 position shutter. When it sticks, the high speed chamber can be open at low speeds in error. This causes the engine to run faster. The part may need to be removed to clean or an attaching/operating assembly may be stuck.

Jul 15, 2013 | 2006 Ford Focus

1 Answer

High and low revving


check throttle positioning sensor or mass air flow (maf) sensor

Nov 13, 2011 | 2000 Ford Escort

1 Answer

03 mk4 vw golf 1.6 petrol 143000kms new tbelt and water pump and thermostat fitted 12 months ago. Fans running full time when engine is running. Overheats when engine is running at low speed ok at high...


Water pump is bad because overheats when engine is running at low speed, and good at high rev. The water pump impeller can not push the coolant with the required pressure.

Apr 19, 2011 | Volkswagen Golf Cars & Trucks

1 Answer

98 galant 2.4 engine speed uncontrollable after 1600 rpm


check automatic idle speed motor if equipped.

Jul 07, 2009 | 1998 Mitsubishi Galant

2 Answers

Throttle position sensor


Resetting it will not help, as the ECM (Electronic control module will readjust thus same issue. If the engine is running sluggish at a very low idle, but fine when the RMP is increased, it is probally the pcv valve, actually the hose part that goes into the back of your Carb., check this by spraying starting fluid, ether, towards the back of fuel intake while running at idle, if it revs, Bingo! Be very carefull not to start a fire, and keep an extinguisher handy!!!

Nov 25, 2008 | 1994 Mercury Villager

3 Answers

1998 Rodeo TF Series 2WD 5-speed manual


vacuum leak......bad tps.......bad mass airflow meter system........any of those are suspect...... also check for bad ground at battery to be sure all is not computer freak out from bad readings ...good luck

Oct 24, 2008 | 1998 Isuzu Rodeo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...