Question about Chevrolet Cars & Trucks

Open Question

6.6 duramax skips at idle but does not under load. no check engine light. no codes. just replaced all injectors. ballance rates are normal on all cylinders except number one wich is usually around -5.0 mm. truck runs fine when first started. after it gets warm it skips at idle. as soon as you put any oad on the engine at all the skip goes away. just the load of turning steering wheel or depressing brake pedal or putting into gear is enough to make it run smooth.

Posted by Anonymous on

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 2000 cadillac seville 140,000 miles,#5,#6 cylinders skipping at idle ,bring rpm up to 2500,skip gone

Bad Fuel injectors,replace them....................

Posted on Mar 06, 2012

Ad
  • 1 Answer

SOURCE: 2000 cadillac seville 140,000 miles,#5,#6 cylinders skipping at idle ,bring rpm up to 2500,skip gone

Maf sensor and map sensor had same problem its fix now

Posted on Feb 15, 2015

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Taurus 3.0 ffv pulsates at idle also pings pulling hills?


run the fault codes
you have detonation under load and that indicates air/ fuel ratio problem could be from problem HO2S ( heated oxygen sensor in the manifold). MAF/VAF sensors or low fuel pressure in the injector manifold

Jul 08, 2017 | Cars & Trucks

1 Answer

Duramax diesel


most likely a bad injector, you need to check balance rates for the injectors with a scanner. if the rates are farly equal then it is probably a rod bearing but injectors are a common problem that's why they changed the original LB7 duramax(2000-2004) from internal injectors to external so they would be easyer to change.

Nov 21, 2013 | Cars & Trucks

1 Answer

2003 monte carlo 3.4 130,000 skips on start up


I'd suspect a sticking injector--car should have set the check engine light. Read the code(s) to progress further. If the coil pack were a problem, it would not be likely to fix itself. If the codes indicate an injector problem, try an injector cleaner in the fuel--worst case, replace the bad injector. The codes should indicate which cylinder to change the injector.

Sep 09, 2012 | 2003 Chevrolet Monte Carlo

1 Answer

2003 gmc duramax wont start after engine is warm and turned off.it wont start until engine is cool again


You have high return rates on one of the injectors most likely. The test run by a dealer is the fuel return rate test. It checks the injectors return flow and tells which ones are leaking fuel under pressure.

Dec 20, 2009 | 2003 GMC Sierra

1 Answer

My 2003 Mustang Mach 1 has a skip in the engine when I first start it up. After I drive it for a short distance ( about 6-7 miles ) the skip goes away. I thought it might be a bad spark plug, so I replaced...


I'd suspect a sticking injector--car should have set the check engine light. Read the code(s) to progress further. If the coil pack were a problem, it would not be likely to fix itself. If the codes indicate an injector problem, try an injector cleaner in the fuel--worst case, replace the bad injector. The codes should indicate which cylinder to change the injector.

Jul 16, 2009 | 2003 Ford Mustang

2 Answers

I have a 2005 2.2 liter engine in my saturn vue. I have an intermittent rough idle or skip. I do not loose power and no codes have shown up when I borrowed a scanner and plugged it in under the dash. it...


It's either a carbon tracked spark plug & boot or a faulty fuel injector.They have alot of issues with the ecotec engine with idle concerns due to injectors.If it misses under a load it's more than likely a saprk plug & boot concern

May 06, 2009 | 2003 Saturn VUE

1 Answer

Check engine light comes on temporarily - engine chuggs at idle


Before changing you pcm try cleaning your egr valve. remove the valve and see if its stuck in the open position if so use a small pick to clean around the spring.

Mar 12, 2009 | 1999 Jeep Cherokee 4WD

1 Answer

Triton V10 Engine Shudders under load


have your fuel system vacuumed out our excursion did it as well the injectors are not at fault it is the fuel lines

Jul 09, 2008 | 2000 Ford Excursion

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

44 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

78919 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...