Question about 2000 Chevrolet S-10

Open Question

I have a chevy S-10 pickup, "2000", 4.3L CSEFI eng. 5 spd. standard, problem is rpm"s stay high until I either manage to downshift or slow down with the brakes/ come to a complete stop, also, sometimes the tach freaks out and bounces all over the place, then stops working altogether, after awhile it starts working again, when the tach freaks out the eng. runs rough and then smooths out again, I"ve already changed the IAC and TPS, checked for sticking trottle, does not stick, any help would be appreciated. D.S.

Posted by Anonymous on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 9 Answers

SOURCE: code po507

have you checked the idle control connector where it plugs into your throttle body for a good connection.

Posted on Apr 07, 2009

Ad
  • 10 Answers

SOURCE: Toyota pickup tach bounces and sometimes drops out

Sounds like a speed sensor. Commonly located on the transmission. I have seen these make gauges do some crazy stuff! Hope this helps! ~Derek~

Posted on Jun 20, 2009

  • 1214 Answers

SOURCE: MY 2002 TRAILBLAZER HAS STARTED TO RUN ROUGH

Have the codes read, that's the best place to start.

I am going to suspect there is a piece of trash in the EGR valve. I've had that happen before on a 4.3L Astro many years ago. Symptoms were just as you said.

Posted on Dec 18, 2009

johnjohn2
  • 5763 Answers

SOURCE: engine stalled out,would not start,

This truck is fuel injected, the problem sounds like a weak fuelpump, it runs when you pour gas into it until that gas runs out, the first thing is to test the fuel preasure, if the pump is weak it may run with gas poured into it but wont idle, also a common problem is the coolant temp sensor and the ground wires to thermostat housing bolt but i wont bet its the pump inside the fuel tank, if you put a fuel gauge on it there should be at least 55-61 psi if its a few pounds lower it can cause problems, you have everything else and it runs with gas poured so its a fuel problem check the preasure, theres a valve up top on the fuel line to connect a fuel gauge to it, start there hope this is helpful.

Posted on Dec 27, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1994 chevy pickup, 2500, witha 5 speed manual transmission. The idle is about 2000 RPM until warmup but is still too high @ 1200 RPM. What should i do? Note: 329,000 miles.


what engine would be more helpful. but just guessing i would say the engine is just tired and rings are worn and valves arent seating and you have a vacum causing the high idle from nothing seating properly.

Apr 07, 2010 | 1994 Chevrolet C1500

2 Answers

I'm having a transmission issuewith my 1985 toyota pickup 4x4. the tranny info is secondhand from a mechanic and i do not know auto transmissions. all i know is that the tranny seems to run and shift...


first things first. have you identified whether or not it is using a kick down cable? if it is, chances are this is your issue. if the colar breaks or the cable gets freyed and sticks inside the sheath, it will cause definate shift issues. let me know

Jan 11, 2010 | 1985 Toyota Pickup

2 Answers

Trying to find out how much oil the Triton V-10 takes when I do my oil change? I cant seem to find it or anyone who knows


It should be listed in the owners manual, but because of different oil cooler setups you may have to do the change yourself and add oil until the correct level is established..... for the first oil change.
Most likely 7 liters,but start with 5,run the engine to fill the oil filter,let it sit for 5 mins and recheck and fill to full.
Note the amount needed for next time.

Nov 08, 2009 | 2000 Ford F250 Super Duty Crew Cabs

1 Answer

Code po507


have you checked the idle control connector where it plugs into your throttle body for a good connection.

Apr 07, 2009 | 1999 Chevrolet Malibu

1 Answer

Service Engine Soon light + Changing oil pressure..


check engine light comes on when ecm detects a problem when information is out of spec.from 1 or more sensors.have ecm scan for problem code!depending on problem,sometimes ecm has bypass mode for some sensors,car will drive ok,or run little rough.but its up to u,if u don t feel safe dont drive it.oil pressure will vary with engine rpm,eng.temp.also,as long the gauges are in the good operating range!hope i could help!

Mar 22, 2009 | 1999 Chevrolet S-10 Pickup

1 Answer

'99 chevy Silverado Z71,5.3 engine.....will not rev when hot.....


try replacing your EGR Valve, or your Oxygen Sensor

Feb 10, 2009 | 2001 Chevrolet S-10

Not finding what you are looking for?
2000 Chevrolet S-10 Logo

Related Topics:

40 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...