Question about 1999 GMC Safari

1 Answer

The blower in my 99 Safari stopped working on all settings the other day. Before this, only the middle 2 speed settings would work, and then one day, nothing on any setting. So, I removed the switch which looked very worn, and replaced it with a new one. Still nothing. I then pulled the motor, thinking it was bad. After removing it, I noticed the wheel spins relatively freely, so I grabbed a couple jumper wires and connected it to the battery. The motor functions fine. I'm aware of the resistor going bad and causing only the high speed setting to work, so I didn't think that was the issue given no settings work at all. Now that I've checked everything else, including fuses and relays, I decide to remove the connector from the resistor. In jostling the connector, the motor kicked on in High. Bingo, or so I thought. I turned off the key, and went to remove the resistor, and found that the motor was still going with key off and out... I disconnected the connector from the resistor, and found that the far left (large red wire) prong is quite charred. I then removed the resistor and found that on the board, the line leading to the big red wire had a bubble in it, so I went and picked up a new resistor. Before connecting the resistor, I grabbed my multimeter, and found that a constant 12v is going to the red wire in the connector. I pulled the AC relay in the underhood fuse panel, and no change, so then I pulled the MAXI 30 amp fuse, and the reading dropped to 0. So, in conclusion, I need to figure out why the power isn't being cut off when the ignition is off...

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • GMC Master
  • 1,250 Answers

The blower in my 99 Safari stopped working on all - a6ac071b-d9a2-4d9b-bc42-f0ea22168d59.gif
Hope it helps

Posted on Oct 11, 2013

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 217 Answers

SOURCE: 94 gms safari van heater blower not working

This van has a resistor under hood for the blower motor and is the blower motor getting power to it

Posted on Jan 17, 2009

  • 61 Answers

SOURCE: 1998 GMC Sierra. Blower

could it be the blower motor it self? sometimes they have a "bad spot" when it is not working, can you hit it and make it run? pretty common on these trucks. the switch is also common. they often melt at the connector on the back making a bad connection. i would double check the motor first.

Posted on Aug 18, 2010

vetteman3002
  • 2299 Answers

SOURCE: 2003 GMC Yukon XL - same as Suburban ("Rear Blower

You don't have any voltage to the blower motor? Are you getting power to the switch?

Posted on Oct 19, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Gmc safari heater blower not working


blower motor is worn. hit it while its on and it will start working again but will need to be replaced eventually

Mar 25, 2013 | 2004 GMC Safari

1 Answer

Why does my blower motor wotk on all speeds except high on a 92 s10


you need a blower resister most likely. or the speed control switch. 99 out of a 100 times the resister shot craps

Jul 12, 2012 | Chevrolet S 10 Cars & Trucks

2 Answers

What does a 99 maxima gle have a resister or amp that controls heater blower motor


It has a blower motor speed control resistor or module, it is located right next to the blower motor under the dash in most cars and one end of the resistor goes into the air ducting for cooling and the other has the electrical connector on it.

Apr 27, 2012 | Cars & Trucks

1 Answer

I have a 1998 olds aurora and the blower fan was working then one day it just stopped a day later it started working again and now it don't work at all is there a relay switch or something that i could...


I see quite a few of these that the connector on the blower motor side goes bad. One thing you can do is remove the panel under the passenger side of the dash. You will see the blower motor when you remove it. With the key on and the blower motor set to any speed wiggle/pull/twist the connector. If the blower motor changes speed or stops it need to be replaced.

Jul 01, 2011 | 1998 Oldsmobile Aurora

1 Answer

My 99 Camry has done 400K. The blower motor fan stopped working. I checked thge manual, removed the resistor and tried a direct battery feed to motor to check if motor is OK. Motor started working on full...


you know the thing has run 400k miles, that is 300k past it designed life. break down and buy a new fan for it, it will set you back about 60 bucks. if you can replace the resistor, you can change the fan. a new set of plugs, plug wires, and a set of tires may be warranted as well.

Jan 12, 2011 | 1999 Toyota Camry

1 Answer

GMC Safari 2000 blower motor works only on high speed. how can i


you ahould be able to purchase that at any parts store. they are easy to install

Sep 09, 2009 | 2000 GMC Safari

1 Answer

A/C blower not working on high


check for voltage at high-speed blower relay with ingnition switch in run positionin run position and switch in Hi position . if voltage is not present, check for voltage at blower switch. (note*) relay is under hood about the middle of pass side wiper.

Jun 27, 2009 | 1996 Chevrolet Blazer

2 Answers

Heater/ blower on 1999 mitsubishi galant 2.0gls


Most likely the resistors are stuffed.
Top speed the electricity goes straight to the fan motor.
The other settings go via a resistor to slow the speed, hence the 3 speeds. So the resistor feed is main suspect

Jun 10, 2009 | 1999 Mitsubishi Galant

1 Answer

Blower motor only works on HI speed


I had the same problem with my 2002 Safari. The blower resistor/relay pack (mounted on the ductwork below the blower motor) in the engine compartment went bad- poor design. A replacement unit (about $120) is available from the dealer. Removal of the coolant overflow / WWasher bottle is required, as well as enlarging the the mounting opening. A Chilton 1985-2005 Astro/Safari manual has the diagrams...

Apr 23, 2009 | 2003 GMC Safari

1 Answer

Heater not working


The problem is probably the blower motor resistor. I'm not sure where yours is located exactly. They can be on the firewall under the hood or some are near the blower motor under the dash.

Dec 23, 2008 | 2006 GMC Sierra 1500 2WD

Not finding what you are looking for?
1999 GMC Safari Logo

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...