Question about 2003 Oldsmobile Alero

2 Answers

2003 ALERO CUTT OFF ON ME WHILE DRIVING, I SEEM 2

2003 ALERO CUT OFF ON ME WHILE DRIVING, I SEEM 2 HAVE THE SAME PROBLEM TOO, TODAY WHEN I WAS DRIVING IT WAS FINE UNTIL I TURNED THE CORNER & WHEN I DID, THAT S WHEN MY CAR JUST LOSS POWER IN THE GAS PEDAL AND IT CUT OFF RIGHT IN THE MIDDLE OF THE ROAD THANK GOD NO OTHER CAR WAS BEHIND ME, THEN WHEN I TRIED TO START IT AGAIN IT ACTED LIKE IT WAS GOING TO BUT IT KEPT CUTTING OFF, BUT.... IT ACTS LIKE IT WILL START BUT IT CUTS OFF IT WONT START THIS HAS NEVER HAPPENED TO ME BEFORE I AM SOOOOOO FRUSTRATED AND I NEED MY CAR FOR WORK, HELP ME PLEASE

Posted by on

  • 1 more comment 
  • MSLEO1977 Apr 23, 2009

    WHATS THE MASS FLOW SENSOR???????????/

  • MSLEO1977 Apr 29, 2009

    HELLO THANKS FOR THE ADVICE IT WAS ACTUALLY THE FUEL PUMP THAT WENT OUT......... I TOLD THE GUY THAT IT MIGHT BE THE MASS AIR FLOW SENSOR AND HE SAID NO ITS JUST YOUR FUEL PUMP WELL UPADATE: 4/28/09 HE PUT ME A NEW FUEL PUMP IN ON FRIDAY AND MY CAR HAS BEEN RUNNING EVER SINCE I AM SO HAPPY :):):) TOTAL COST. PLUS PART 320.00

  • MSLEO1977 Apr 29, 2009

    HELLO & I WOULD LIKE TO SAY THANK YOU FOR YOUR ADVICE, IT ACTUALLY WAS MY FUEL PUMP THAT WENT OUT I JUST BROUGHT A BRAND NEW ONE FROM PEP BOYS FOR ABOUT 240.00 AND THEN I PAID MY FRIEND TO PUT IT ON THAT HAS BEEN DOING CARS FOR A WHILE I TOLD HIM ABOUT THE MASS AIR FLOW SENSOR AND HE SAID NO IT'S YOUR PUMP SO HE PUT THE NEW PUMP ON AND IT;S BEEN RUNNING EVER SINCE I AM SOOOOOOOOO HAPPY :):) ONLY COST ME TOTAL 350.OO

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had a similar problem. Mine had 200,00 miles and what was diagnosed was a problem with the carburetor . There was a vacuum problem. A part had worn and need to be replaced in order for the vacuum to be pulled.

Posted on May 01, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 183 Answers

Mass Air Flow Sensor.

Posted on Apr 23, 2009

  • Calvin Hart
    Calvin Hart Apr 23, 2009

    It's the sensor on the box. It controls how much air is getting into the engine. When it goes, the car just dies, try to start it, it will try, but never quite start. Sound about right?

    Calvin.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Chevy impala 2003 it cutt off when put in Drive the reverse gear work will drive in low but when put into drive ,3 or 2 gear it cut off


Low trani fluid check.Then if you have over 200000 km then I can tell this transmissions are so bad (4T65E) for sure you need to get yours rebuilt.The seals and clutches are need to be replaced.

Jul 31, 2014 | 2003 Chevrolet Impala

1 Answer

Cant find the crank position sensor in 2000 alero


Check that the cam shaft is turning as it may have broken a timing belt. Run fault codes to check for cam/crank position sensor problems.

Jan 06, 2014 | 1999 Oldsmobile Alero

1 Answer

03 olds alero wont start but lights on


Could be the key switch or the neutral safety switch. Will it crank in neutral instead of park ?

Jul 11, 2013 | 2003 Oldsmobile Alero

1 Answer

When driving my alero oldsmobile it wants to cut back like its misfireing what is the cause of that?


Could be your fuel filter being clogged up. Get a new fuel filter. If that doesn't work then just do a normal tune- up and have your fuel pressure tested. Hope this helps, James Booth

May 18, 2011 | 2003 Oldsmobile Alero

1 Answer

While driving the engin cut out. it will not turn over.


Do the headlights work, and are they bright? Do they dim to almost all the way off when you try to start the car?

Dec 18, 2009 | 2003 Oldsmobile Alero

1 Answer

Alero: low beams as bright as Daytime runners while brights work?


Look for the relay for the head lights,it may be bad.Also look for a bad ground.And check the bulbs too.

Nov 04, 2009 | 2003 Oldsmobile Alero

2 Answers

03 Oldsmobile alero vibration will running


it would be a good i dear to have it scand.that would help you pin point the prolbem. look at your cv joint you may have one going bad. good luck

Jun 04, 2009 | 2003 Oldsmobile Alero

1 Answer

2003 olds alero igntion/starting problem


i own a 03 alero ... aleros have history of igniton switches going bad... replace it or take it to dealer then ull be charged arm and leg...

Jun 01, 2009 | 2003 Oldsmobile Alero

2 Answers

2003 Alero dash lights out temporarily


a posible BCM problem. take to shop and have tested...
BCM= body control modual

Nov 06, 2008 | 2003 Oldsmobile Alero

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

Related Topics:

299 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7726 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...