Question about 2003 Chevrolet Silverado 1500

1 Answer

Engine shakes periodically; warm or cold. Bad Coil?

Engine shakes periodically; warm or cold. Did vacuume test and found nothing. Will run fine and then engine shakes with engine light blinking. I know i'm missing because i'm losing power up hills. Codes say i have a 'P0300 and P0200.' Multiple cylinder misfires, Circuit cylinder mulfunction. Also, my friend pulled some plugs while the engine was running and didn't hear a difference when he pulled the wire on the passenger side, first from the front. Could it be a bad coil? Do chevys' usually have these problem?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 40,646 Answers

The p 0300 codes gives you the clue
it is random misfires and that is predominately from injector and low fuel pressure
pulling a plug lead will amke no difference if there is no fuel in that cylinder to ignite
bad coils will be a constant miss regardless
try putting a can of quality injector cleaner in the tank to see if that fixes the problem
have a fuel pressure tset done to check for pump, filter or pressure regulator problems

Posted on May 18, 2017

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

tripletauto
  • 1450 Answers

SOURCE: Engine light code P0300

I would recommend going back with ac/delco platinum plugs.Some of these "high performance" plugs dont work well in newer gm vehicles.The computer is sensing more than one cylinder misfiring and cant determine the cylinders the style of plug your using could very well be causing this

Posted on Sep 03, 2008

  • 217 Answers

SOURCE: 1998 Cavalier No Spark in cylinders 1 & 4

ignition mod. grounds,pcm or timing belt could all be it but, I would have to look at timing first.

Posted on Jan 17, 2009

  • 753 Answers

SOURCE: setting code P0300- random multiple

This could be any number of problems in your spark system but most likely your control module for your spark plug coils.

Posted on Aug 22, 2009

  • 14036 Answers

SOURCE: Chevy 3500 Express truck. fuel problem?

IF YOU GOT CYLINDER MISFIRE.OR OPEN FUEL INJECTOR.THAT WILL CAUSE THE PCM TO ENRICHEN FUEL MIXTURE.TO ADJUST TO DEAD CYLINDER.WHICH ACT AS A LARGE VACUUM LEAK.THATS WHY YOUR EXHAUST TAIL PIPES HAS A RAW FUEL SMELL AND WHITE SMOKES.

Posted on Sep 03, 2009

wireguy212
  • 1627 Answers

SOURCE: get multiple misfire codes. P0300 - P0303. If this

This could be a coil problem but i would start by changeing the plug wires and checking each plug.

Posted on Nov 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

06 dakota 4.7. P0300 replaced plugs,injectors,coils,o2 sensors & all other sensors,intake cleaned.bad ecm? cats show same temp both sides of cat, bad cat? Or??


Have you checked for vacuum leaks? Poor idling when cold that gets better when the engine warms up, or at higher RPMs are symptoms of vacuum leaks. Check all hoses and connectors. If it's a manifold gasket, you will want to use a smoke machine (check when the engine is cold).

Apr 03, 2017 | Dodge Dakota Cars & Trucks

1 Answer

Engine miss when cold, engine light on, new gas, air filter. fuel pump in tank. hot engine loght goes on off, when off at stop stalls out engine light off.


Diagnose Engine Misfire - Auto Diagnosis Repair Help

www.aa1car.com/library/misfire.htm
The engine may shake so badly at idle that it causes vibrations that can be felt in ...The engine may only misfire and run rough when cold but then smooth out as ...

What is causing an intermittent misfire only when engine is ...

community.cartalk.com/.../what-is-causing-an-intermittent-misfire-only-...
Jun 27, 2013 - NOTE: You MUST restart the engine for the misfire to go away. ... in an expert to do that test, but it might be worth it to prove/disprove the injectors being thecause. 0 ... The first is that the car should run fine even on cold starts.

Engine misfires when cold but runs fine after warming up few ...

https://answers.yahoo.com/question/index?qid...
Mar 24, 2009 - They also gave it to me because of this misfire problem it has. ...Engine misfires when cold but runs fine after warming up few minutes later? ... and you start next morning will also cause a misfire until it burns off the coolant.

"Miss/splutter" with cold engine, but fine when warm? M103 / also ...

www.peachparts.com > ... > Tech Help
Jul 13, 2011 - My moms old 300SEL (with the M103) that was once my car is now my "work car" again as she is getting a brand new SUV very soon.

Cold start misfire solved (finally!) - Bimmerforums


Dec 16, 2015 | Cars & Trucks

1 Answer

Ok i unpluged my iac on my 93 chevy 5.7l at a warm idle and nothing happened. Is anything suposed to happen? My truck had a high idle when warm and a little rough idle when cold. And if im driving and...


Have you check for a vacuum leak? The 5.7 throttle body base gasket can get a crack in it and cause the running issues that the engine is having.Easy test is to plug the hole in the throttle body where the IAC draws air, if the idle slows down then suspect a vacuum leak.

Feb 25, 2015 | Cars & Trucks

2 Answers

I have a 1987 ranger 2.3 EFI and sometimes it will not start when it's cold. after it warms up outside it starts. When it does start it runs great. It always starts when warm. some times it will


Timing belt being off one tooth will not cause this problem but rather loss of power and hard starting all the time,

in the cold it will not start, the engine will spin but wont fire is this correct?

There are many things that can cause this, a little testing will be needed, the first thing that comes to mind with the ford and cold weather is the coolant temp sensor, it give computer a false reading and can cause hard starting or even no start, a scan tool would be helpful to see what temp it is give computer.
The best way to narrow this down to to check for spark when it wont start, a weak coil in cold weather will cause this problem or bad coil wire to cap, but if you can see if it has spark and let me know,
another test is to check fuel pressure, to see if it is getting fuel, and the fuelpump relay,

Let me know if it has spark or fuel when is does not start, good day

Oct 01, 2012 | 2002 Ford Ranger Regular Cab

1 Answer

Idling problem


Mike,
First check for small vacuum leaks by spraying aerosol carb cleaner at any area which might leak [ie vacuum hoses] Any vacuum operated device which contains a diaphragm needs to be checked using a hand vacuum pump. Sears sells a nice one.
Also check to make sure that the purge valve for the charcoal emissions canister is not leaking when the engine is cold.
If this does not help or you find no leaks, I would strongly suspect that you have dirty and/or leaking fuel injectors. Fords are notorious for fuel injector problems. Dirty fuel injectors first show up as a problem with engine stalling or rough idling when cold. Fuel tank cleaners like Chevron Techron will sometimes work. However, the BEST way is to remove all the injectors and have them sent out to a shop with proper testing/cleaning [ultrasound] equipment. Generally, shops which specialize in diesel fuel injection have this equipment. Should cost you around $25 per injector for testing/cleaning.

Dec 31, 2011 | 2005 Ford Taurus

1 Answer

Every time I start my truck it misfires very badly. I actually gotta hold the pedal down pretty far to make it stay running. But once it warms up, it's fine but sometimes has a slight miss while driving...


idle air control valve does your vehicle have one check to see if your geting the correct amount of fuel at rail sounds like a fuel issue cloged injector

Dec 02, 2010 | 1992 Ford F250

1 Answer

Code 15 ignation output car runs good when cold gets warm check eng light miss.lacks power not hitting on all cyl. suspect bad ignitor..


Check the EGR valve. Look up on the internet where on your car it is located. Find the vacuum line connected to it. Start the engine cold and as it warms up and starts to miss and stumble, pull off the vacuum line from the EGR. If the car idles fine, replace the EGR. Ignition system problems are more likely to occur at idle or lower rpm. Besides, testing the EGR is free, easy and do fail in high mileage vehicles.

Jun 02, 2010 | 1988 Acura Legend

2 Answers

My 97 taurus takes a long time to start sometimes not until engine cools down after driven. obd2 codes 443 174 171 keep showing up then engine light comes on then sputters and stalls can anyone tell me...


P171 and 174 is running lean that means you have either no fuel pressure, bad fuel pump, cloged fuel filter and somethimes vacum leak on your intake manifold gasket.
443 indicates EGR valve solenoid malfunction.

Dec 30, 2009 | 1997 Ford Taurus

1 Answer

Cold starts ok warms up shakes and stalls


check engine coolant temperature when it gets warmer, or at operating temperature, and verify that the temperature gauge is showing warmed up to operating temperature. If the coolant temperature sensor tells the computer the engine is cold it will over fuel and miss and the engine will die. When cooled down it will run fine until it warms up. Also could be coil if it starts missing after warmed up.

Aug 18, 2009 | 1990 Ford Bronco II

2 Answers

1997 dodge 1500 starts fine when cold, won't restart when warm.


No, the coil the is not the problem. I would take the ignition module and have it tested. Even though it may not test bad b/c it is still cold, it is more than likely the problem. Have you checked to see if you are getting spark when the trouble occurs?

Apr 13, 2009 | 1997 Dodge Ram 1500 Club Cab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

294 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...