Question about 1999 Oldsmobile Alero

2 Answers

Every Gauge quit working

I have a 1999 Oldsmobile Alero. I was driving down the street, coming to a stop sign and looked at the speedometer because I felt I was going a little fast for the stop. As I was coming to a stop, looking at the gauges, every single one went to zero.. as if the car was off. I continued to drive the car to my home, with no clue on how fast i was going, how much gasoline I had or what temperature the car was. The light on the gear indicator went off, and the miles do not add anymore. Every single light that could turn on in the dash ( Traction, ABS, Security, Coolant, Battery, Service Engine Soon, and Check Engine), turned on when the gauges dropped to zero.
When I got home and turned the car off, I took the key out of the ignition and the odometer stayed on. Along with the battery light on the far right side of the instrument panel next to the speedometer. Every other light went off. It seemed as if the starter was still engaged. So I popped the hood, and unplugged the positive from the battery. I went to sleep as it was night time.
The next day I plugged the Positive back into the battery, and turned the car on. All of the lights that were on the day before had gone off, except for the battery and the odometer. I drove the car like this for a couple of days.
All of a sudden, another situation as when it first occured, I went to look at the speedometer thinking it worked, trying to figure out how fast I was going, and the car chimed three times, and the gauges started to work again. It started to read miles and only had the security light and traction off light on.
If someone has any clue what this might be, please help. I am in DESPERATE need of some sort of help, as I have absolutely no idea.

I appreciate your work, Jeremy.

P.S. - I went to Auto-Zone and had my alternator checked, it was strong.
- I checked every fuse in the car.
- Cannot check every relay... would not have a clue which relay it would be.
- Tried to have auto zone diagnose from inside the car, came up with no codes.

Posted by on

  • Christine Dewater
    Christine Dewater Nov 14, 2015

    Your BCM may have gotten wet. It's in the area of the glove box. My window leaked and got mine wet. Lost all gages, lights wouldn't turn off. I unplugged it, opened it up and allowed it to dry overnight.
    When i plugged it back in in the am, it worked fine. I sealed up my window and haven't had it happen agsin

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 14,036 Answers

Check the ipc bfc acc fuse make sure fuses are not loose.

Posted on Apr 27, 2009

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 21 Answers

Check for moisture at fuse panel at dash, these Aleros can leak water from windshield to under dash and into fuse block shorting everything.... WD-40 dry vac and blow area well

Posted on Dec 04, 2009

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 14036 Answers

SOURCE: 1999 oldsmobile alero the traction and cruise not working

use a scanner to check the abs system . most of the time the abs brakes and traction control system work together. your cruise control . unit has a servo motor .in front right fender well. check the fuse and relay also the cruise control brake release switch. and the brake light switch.if all is good you have a cruise control module problems. dealer ship job.

Posted on Apr 02, 2009

  • 1024 Answers

SOURCE: my service vechile soon light is on and my

you need to extract the engine code so you can find out what is wrong with it. you can go to any parts store and they will do it for free

Posted on Mar 08, 2010

tbyoung
  • 154 Answers

SOURCE: I have a 2001 Oldsmobile Alero. What does it mean

I am assuming its not the service engine soon light it is probably the service vehicle soon light, There are 2 lights service vehicle soon upper left side, and service engine soon upper right side.

When all these come on at the same time it is the wheel bearing sensor. Usually the wheel bearing needs to be replaced which houses the sensor. A sure way to check is to press your sls button by your shifter and see if the light goes out, If it does not, u will need to have a wheel bearing put in.

Posted on Jun 22, 2010

  • 14036 Answers

SOURCE: where is the traction control switch located on a

LOOK FOR ETS BUTTON ON THE CENTER OF THE CONSOLE.THE INDICATOR LIGHT WILL TURN OFF BUT LONG AS CURRENT NEED TO LIMIT WHEEL SPIN THE TRAC LIGHT WILL REMAIN ON.TAKE VECHICLE TO GARAGE OR DEALERSHIP.HAVE THEM SCAN THE ABS AND TRAC CONTROL SYSTEM.MOST OF THE TIME A BAD WHEEL SENSOR WILL SET OFF TRAC WARNING LIGHT.

Posted on Mar 06, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer stop working


I think may be the vehicle speed sensor.
___________
VAS 5054a english setup instruction

Apr 02, 2013 | 1999 Oldsmobile Alero

2 Answers

My fuel gauge tach gauge speedometer heater temp gauge and driver power seat quit working


check the fuses. they are under the back seat just pull up on the lower part of the back seat and it will come out. fuse box is on the drivers side. check to see if water is getting in that could be the cause.

Feb 10, 2012 | 1996 Oldsmobile Aurora

1 Answer

99 alero speedometer stuck at 140 remedy?


SOUND LIKE SPEEDOMETER GAUGE BROKEN.

Sep 23, 2011 | 1999 Oldsmobile Alero

1 Answer

I have a 2000 Alero and the speedometer quit working what could be wrong?


SOUND LIKE VECHICLE SPEED SENSOR BAD.BUT CHECK THE ELECTRICAL CONNECTOR AND WIRING FOR DAMAGE.ALSO MAKE SURE CONNECTOR IS INTACT NOT LOOSE.

Mar 15, 2010 | 1999 Oldsmobile Alero

1 Answer

1999 Oldsmobile Alero Gauge problem


Could be lose connection on the back of the instrument cluster ,which means you would need to pull it out of the vehicle . Check pin fit to instrument cluster . for the B+ voltage suppy an ground connection's .
You said autozone - Tried to have auto zone diagnose from inside the car, came up with no codes. That's in the PCM - engine computer . There scan tool will not communicate with the instrument cluster ,which is also a computer in it's self. Need a factory scan tool to check instrument cluster.
Speedometer and/or Odometer Inaccurate
Step
Action
Value(s)
Yes
No
Important: A short to ground will cause an open fuse(s). Before performing this diagnostic procedure, inspect the fuse(s) for an open.
1
Did you perform the Instrument Cluster System Check?
--
Go to Step 2
Go to Instrument Cluster System Check
2
Turn the ignition switch to the ON position.
With the scan tool select Instrument Panel Cluster, Special Functions, Instrument Panel Cluster (IPC) gauges.
Perform the Speed Gauge Sweep Test.
Does the speedometer complete a full sweep when commanded?
--
Go to Powertrain On Board Diagnostic (OBD) System Check in Engine Controls
Go to Step 3
3
Replace the instrument cluster. Refer to Instrument Cluster Replacement .
Did you complete the repair?
--
Go to Instrument Cluster System Check
--
With a scan tool select the instrument panel cluster, data display, gear status.
Monitor the gear range status.
Move the gear lever through each gear.
Does the scan tool display the correct gear selected?
Your best bet , take it to a qualified repair shop .

Feb 27, 2017 | 2001 Oldsmobile Alero

1 Answer

My 1999 Oldsmobile Alero Gas gauge and fuel system


well # 1 the full gauge when empty is a sign that your fuel pump is bad and that needs to be replaced the part about spitting the gas back out is probrobly a clog between the fuel door and the tank itself or their might be a vapor lock door that might be stuck shut so fuel cant get in im not 100%sure about that but im 100%sure that the fuel guage is the fuel pump being dead.

--THB--

Aug 22, 2008 | 1999 Oldsmobile Alero

2 Answers

99 Oldsmobile Alero - Speedometer Problem - needle is stuck at 140mph


I replaced the radio with an aftermarket one and now my dash lights, power windows and my headllights have dont come on automataclly like they did before. my alarm on my remote dont work either, I think i did something to the alarm system, that is why they are not working.

Aug 18, 2008 | 1999 Oldsmobile Alero

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

825 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...