Question about 1991 Saturn SL2

2 Answers

Erratic >>> DRIVING EXPERIENCE

April 20, 2009 {Monday} Hello Folks [EXPERTS]: Thank you in advance for reading my note. I need help! I just recently purchased an older model [1991 Saturn SL2] and was acting a bit strange. Sometimes it is running fine and the next thing is that it felt like it was going to die while driving. It shifts so hard, practically slams. When parked, the indicator lights turns on as follows: "SERVICE ENGINE SOON", "OIL PRESSURE", & "SEAT BELT". Tachometer reads 800 rpm. I had the following changed recently thinking that it might cure & resolve the issue: 1. AUTOLITE SPARK PLUGS-correct gapped to .040 2. FUEL FILTER-changed this morning. 3. AIR FILTER-changed this morning also. 4. WIRE SETS- new 5. OIL CHANGED 6. NEW TRANS FLUID 7. NEW RADIATOR FLUID 8. CHECKED FOR AIR LEAKS--none found 9. CHECKED FOR OTHER LEAKS-- none on white paper on driveway. 10. USING BP & SHELL PREMIUM GASOLINE 11. Also added STP AND GUM OUT but it is still the same. I'm trying to make my money last and hoping that an honest expert might be able to shed some light to that causes this to happen and a fix it for good. I'm on a budget and need your bright mind to pinpoint what needs to be replace bearing in mind limited $$$. Thanks you again in advance and have a great evening. Ted

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 139 Answers

First using premium there no need those car are made to run on 87 oct. and aditif is not require
there real good aditif in gasoline already, next the
plug i would of use AC plug as original equipment.
next i would bring the car to a big auto parts
<autozone-pepboy> they have code reader to see if
there is any code in comp.of the car.code check is a free service. good luck

Posted on Apr 21, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 204 Answers

Ted i will have to say this dosent sound good at all. especially when i hear Very Hard shifting. i see that you have changed the transmission fluid and am guessing you did the tranny filter also. when the fluid came out was it burnt and did it have an awfull Smell? if so i am willing to bet your transmission is about done. sorry to say. but if you go to your local auto parts store and Get a couple of bottles of what is called (Lucas Trans Slip) and add it to your tranny fluid. this stuff works great and really helps out the old seals here at the shop any tranny job we do we add it in because it is a great conditioner allso. but i wish icould help you more with the other problems. but i would have to take it for a drive or hook up a scanner and see why the engine light is on to start with. I hope some of the information is helpfull to you. please rate my solution
thank you
Aaron
Ps the Lucas is only about $10 a bottle and it does do wonders

Posted on Apr 21, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Weber 38 carb on my Toyota 22r I recently rebuilt seems to be no change in how it's running , very erratic idle , sometimes runs fine now has developed a miss and or "pop" through exhaust


That's a GREAT CLUE that guess was a BAD ONE...

Count yourself lucky (and somewhat talented) most folks don't get away with tampering with carbs... and things not getting WORSE.

The kind of erratic you are talking about could just as well be a rotted muffler or collapsing muffler...

Got any other details you feel might help your FREE VOLUNTEERS here... help you??

Carnac the Magnificent

Mar 10, 2017 | Toyota Cars & Trucks

1 Answer

Preglow light turned on during driving


If there is a problem with any electrical sensors,switches,motors in and on the engine anylon slight fault can bring the glowplug light on. I would suggest that you take to a independent Mercedes specialist and have the code read most fault are logged.

Jun 10, 2017 | 2010 Mercedes-Benz GLK 220

1 Answer

Have an 05 sonata, 4 cylinder. tach started dropping out or being erratic. few weeks later check engine light came on. Several codes pop up (p300,302,303,304,320). Still runs, gas mileage took slight hit....


Take it to an AutoZone or an Advance Auto Parts and ask them to read the codes. My guess is that your ECU's gone bad or may need resetting, which is something the dealership may need to do.

Aug 31, 2012 | 2005 Hyundai Sonata

1 Answer

When the ford is idaling it fefes up and down runs ryff and some times dies


Hello and welcome to FixYa!
As a first course of action, please check if the vacuum hoses are disconnected or may have some leak. Vacuum leak can cause the idle to be erratic. If the problem still persists then it can be a faulty IACV (idle air control valve) or MAF (mass air flow) sensor. This two controls the air and may need replacement if idle is erratic.
Hope this helps and thank you for using FixYa! Have a good one!

Jul 12, 2011 | 2003 Ford Explorer

1 Answer

I have a 1997 Grand vitara V6 2 Litre The check engine light has been coming on intermittently for some time but has been okay.As of yesterday the engine RPM at idle has been very erratic rising and...


Hello and welcome to FixYa!

If the check engine light is on then there's definitely a problem. The engine rpm is erratic right? This can be caused by a faulty MAF (mass air flow) sensor. If the MAF sensor is faulty the idle will surely be erratic and may cause stalling.

You will need to have it replaced to make the vehicle back to it's normal operation again.

Hope this helps and thank you for using FixYa! Have a good one!

May 01, 2011 | 2000 Suzuki Vitara

1 Answer

ERATIC INJECTOR PULSE NO START


You describe an electrical issue. First of all, how do you know the injector pulse is 'erratic'?
Is the ignition spark ALSO erratic? If so, how so? I need specifics, details regarding your description of 'erratic'. I can assume/presume you have experience/education/training in automotive diagnostics... ??

In my electrical/eagelectronics experience, you definitely have an electrical/electrodynamic problem/issue.

Tell me what you've done, diagnostically, to determine (isolate) the 'CAUSE' of this erratic injector pulse. What have you inspected/checked? What have you NOT inspected/checked?

Get back to me, then we can go from there.

However, first thoughts
The engine management computer (ECM/ECU/PCM) can cause/create the symptom you describe
The engine wiring harness also (chafed wires, bad ground circuits, etc.)
Malfunctioning senors (Crank Position Sensor (CKP), Cam Position Sensor (CPS),
Low Voltage Condition, etc.

Feb 08, 2011 | Hyundai Tiburon Cars & Trucks

2 Answers

Hello Experts, How is everyone today. Well the problem I have has been going on for about a month now. My brother bought the car home one night and told me the following morning that it had a problem...


Try this two simple tricks.
1. Check the fuel filter & change if required.
2. Spray some carb cleaner into the air intake when the engine is running.

Lets see if it helps.

Nov 21, 2010 | 1999 Hyundai Accent

2 Answers

Stabily system diabled - error


Your stability control uses the ABs wheel speed Sensors and the steering collumn sensor to know "when you need more stability". It sounds as if the front wheel speed sensor is sending bad info due to:
A) corrosion under the sensor causing erratic readings
B) front wheel bearing failing causing erratic readings
C) column sensor failing causing erratic readings


The GM dealer is the only place I know to have THOSE components tested. You can change any of these sensors yourself once you know which one it is. The "service stability" indicator is on because one of the sensors is not giving correct data, and the default mode is to disable the system. 

Good luck and hope this helps, 

Jun 28, 2009 | 2004 Cadillac Escalade

1 Answer

Problem with temp, battery and oil gauges, speedometer erratic.


get the original company service and repair manual from the given link it will help you to fix all the facing problem along with diagram

Oct 09, 2017 | 2005 Ford Mustang

1 Answer

Erratic Dash Temperature Gauge Readings


assuming there is nothing wrong with the water pump, it may be the sending unit is going bad, or it could also be the thermostat going out. it is more likely that the t-stat is the problem as it is the erratic behaviour of the guage inside that is the concern.

Nov 22, 2008 | 1996 Ford Taurus

Not finding what you are looking for?
1991 Saturn SL2 Logo

129 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8557 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...