Question about 1994 GMC Safari

1 Answer

1994 gmc safair 4.3 wont run at idle and bad enough at high rpm you can't drive it. replaced plugs,wires,cap.roter,o2 sensor,used throttle body,used computer,new fuel pump,new fuel filter,can't figure it out ?

Posted by on

  • Larry Sabin
    Larry Sabin Apr 22, 2009

    egr valve was the problem cleaned it the van runs grate. but the service engine light is still coming on even after disconnecting the battery ill take it down to the locale shop and se what codes pops up thanks for the info very much appreciated

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • GMC Master
  • 1,000 Answers

Is the "service engine" light on at all?
If so, what codes are present.
Have you checked the EGR valve. If the valve is stuck, the engine will idle very poorly. You can remove it and clean the carbon deposites and make sure it moves freely.
The EVAP purge solenoid will also cause an idle problem but should show up as a service engine light problem.
Let me know.
Regards,

Posted on Apr 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 Saturn SL-1 idles fast


The ECM maybe stuck, disconnect the battery and wait 5 mins then reconnect.

Other things that normal cause high rpm at idle:
  • PCV hose to throttle body has a leak
  • vacuum line to brake has a leak.
  • the throttle plate maybe dirty and is open partly
  • the IAC is bad. Which is on the throttle body.
  • the throttle plate sensor is bad, just unplug it and see if the rpm goes down. If it does, replace the sensor.
  • the egr value maybe stuck
  • bad front o2 sensor
  • bad coolant senor. You should have this replace since the original sensor where plastic tip and crack. The new ones has a brass tip. the transmission and air( IAT) have the same sensor part.

May 11, 2014 | Saturn SL Cars & Trucks

1 Answer

Surging idle


Bad throttle position sensor.

Nov 24, 2013 | GMC Yukon Cars & Trucks

2 Answers

How to locate o2 sensor in chrysler town and town 1994


that is your idle air control valve . it is located on the throttle body next to the throttle position sensor

Dec 02, 2012 | 2001 Chrysler Town & Country

2 Answers

I have a 1994 gmc 1500 truck with a 5.7 v8.one fuel injector is pumping fuel and the other injector is not!!!!i swapped the injectors and its not the injector.


Go to the parts store and get a noid light for your truck, plug it into the injector electrical and turn the engine over to see if there is electrical pulse, also check the fuel pressure, the pump needs 9-13 psi with the engine running. you know if there is no pulse your going to need to check the wireing first. let me know

Feb 10, 2011 | 1994 GMC Sierra

2 Answers

Misfires 96 gmc sierra 5.0


if the check engine light starts flashing its probably setting a code may have an injector problem

Aug 05, 2009 | 1996 GMC Sierra

1 Answer

Rough idle


Yes bad o2 sensor,check for vacuum leaks also.do you cross your plug wires?

Jun 26, 2009 | 1999 GMC Sierra

1 Answer

94 chevy 5.7 2 wheel drive


computer wiring could be bad /computer bad..should be spitting codes....tired motor / internal damage ? timing chain/gear set up improper?

Nov 09, 2008 | 1988 Chevrolet K1500

Not finding what you are looking for?
1994 GMC Safari Logo

271 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...