Question about 1994 Chevrolet S-10 Blazer

1 Answer

'94 Blazer S-10 Fuel/Starting Problem.

Just bought it. Starts & runs well, then gas flow begins to cut out while accelerating, then stalls & won't always restart!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Chevrolet Master
  • 420 Answers

Sounds like a fuel air mixture problem. If the check engine light is on take it to a Auto Zone and they will read the codes for free.

Posted on Apr 19, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

98 s70 starts but won't stay running when given gas


It sounds to me like it is not getting any fuel. Please note that when you step on the accelerator, you are not stepping on the "gas", you are really stepping on the "air". If the engine stalls when you do this, it is most likely because there is not enough fuel to go with the air that you are giving it. There are many things that could possibly cause this, ranging from a defective fuel pump assembly to a bad Mass Air Flow (MAF) sensor as well as several other things.

I would recommend BEGINNING diagnosis of the problem by scanning your engine control computer for possible Diagnostic Test Codes (DTCs) A.K.A. "fault codes". Then you may want to follow with a fuel pressure test (depending on whether there are any DTCs present that must be fixed first.)

Mar 06, 2012 | 1998 Volvo S70

1 Answer

Have a '94 S-10 Blazer Tahoe 4X4 and it starts


My suspicion is a starter going bad. Sometimes when starters get old and worn they will start good when the engine is cold but not when the engine is warmed up. Did you perhaps notice that lately is seemed to drag when you tried starting, especially warm or it seemed to crank a little slower? I'd replace the starter. Hope this helps.

Aug 14, 2011 | 1994 Chevrolet S-10 Blazer

1 Answer

94 s10 4x4 4.3 w eng. after sitting awhile sometimes no start


How does it start after sitting for several days? If she fires right-up I'd say the fuel injectors require replacement. Next ime you try to start it and it won't pull several spark plugs. If they appear wet with gas that would be from leaking fuel injectors. When you try to start it you may breath some new air in to the cylinders causing the gas to evaporate off and 30 minutes later she'll fire up for you. If it is caused from leaking injectors (flooding) Try starting it with the accelerator to to the floor and hold it to the floor. Try starting it for 3-5 seconds and the wait 10-15 seconds but keep your foot to the floor (doing this at start-up fuel flow to the injectors) try this several times. Caution though: As it begins to start remove your foot fom the accelerator to avoid over rev-ing the engine. If this is the cause replace your injectors.
I hope this may have helped,
Tom

Sep 07, 2009 | 1994 Chevrolet S-10

2 Answers

94 s10 blazer wont start


HAVE YOU TRIED CHECKING THE IDLE CONTROL VALVE IT MIGHT HAVE TO MUCH CARBON...OR IT MIGHT BE FUEL INJECTORS CLOGGED....

Aug 23, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

I have a 94 chevy s10 blazer that skips when accelerating and idl


low compression - worn spark plugs and wires - weak coils-clogged fuel filter.

Apr 27, 2009 | 1994 Chevrolet S-10 Blazer

2 Answers

Problems with my 91 s10 chevy blazer


  1. check for fuel prusser if it going low than 35 psi u have to replace the fuel pump
  2. check for bad crank sensor
  3. make sure the TPS work fine
u need to send it to work shop

Apr 07, 2009 | 1991 Chevrolet S-10 Blazer

2 Answers

Poor Acceleration Stalls at idle


It likely needs a fuel pump, hook up a fuel pressure gauge, it needs to be 11-13 psi

Feb 28, 2009 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

Related Topics:

171 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...