Question about 2001 Saturn L-Series

1 Answer

Cluster problem. none of the gages work

Posted by on

  • tr6rider2002 May 11, 2010

    is there a specific fuse for the instrument panel

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 126 Answers

Check fuses

Posted on Apr 18, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer tachometer temp guage not working 2001firebird. All fuses are good


The sending units for those gages are not hard-wired to instrument cluster. That info goes to pcm. The pcm then sends serial data to instrument cluster telling the cluster what to do with the gages. If some gages work and some don't, I suspect the instrument cluster. Some instrument clusters are able to do a self-test. I don't know the models years involved? Even so you would need a scanner with by-directional controls to try the self-test. Don't take my work for it, check around.

Jun 24, 2017 | Pontiac Firebird Cars & Trucks

1 Answer

Why does my dashboard gauge not work on my Nissan Maxima 1998


I may need more info? If none of gages on instrument cluster work, check voltage and ground circuit. Not only check the fuse, check the fuse circuit for voltage, use test lite to check for voltage, the fuse on the left is hot all the time. The one in middle goes hot with key on. The fuse on the right appears to be for cluster lamps. The ground wire for instrument cluster is black.
I can't rule out problem with instrument cluster, itself?

26395234-l0niljk1xn3va3ubzuxqsa0h-1-0.jpg

Dec 11, 2016 | 1998 Nissan Maxima

1 Answer

Gas gage not working


Maybe a problem with instrument cluster?
Usually the circuit works off resistance to ground. The sending unit in gas tank provides resistance to ground. The signal wire for fuel gage is a purple wire, if goes to fuel pump wiring connector. With key on, use digital multimeter, check for voltage. If no voltage, either problem with wiring circuit or instrument cluster. W/0 looking at instrument cluster, I don't know if you can replace gage itself w/o replacing instrument cluster?

If voltage on the purple wire, ground it, while a helper watches the gage, if the gage starts reacting, then check the grounds for fuel pump wiring connector, if that checks ok, suspect the fuel pump sending unit has a problem.

Apr 23, 2016 | 1991 Chevrolet Lumina

1 Answer

Gauges such as oil, fuel and battery not working. Which fuse affects them and where is it located?


If none of your gages are working your cluster is the problem replace it.

Dec 31, 2015 | 2003 Chevrolet Tahoe

1 Answer

Instrument cluster stopped working


Check the fuse panel to see if you have a fuse labeled instrument cluster or gauges, if not on the side of the dashboard (or underneath) check under the hood the relay box and look for your problem there. If none of these, then take it to an electrician to have them check it out.

Jan 16, 2014 | 2004 Chevrolet Tahoe

1 Answer

Could bad fuses cause all dash gages to not work


ABSOLUTELY!!!!

Check your Owners Manual and check where the Instrument Cluster Fuse is and then see if it is burned ....

Apr 06, 2013 | 1999 Chevrolet Lumina

1 Answer

Cluster problem,transmation temp gage ,engine temp gage not working but in info message center flashing other problem like battery voltage flashing but working gage no high beem indecater only sometimes...


This sounds like a few problems, the first thing i would is to have the computer scanned for any storeed codes, have the engine computer and body computer checked then scan the cluster for any problems, these trcks had a few problems with the cluster and the throtlebody just to name a few things, start with the scanning then maybe replace the cluster, on most of these newwer trucks the replacement cluster must be program to truck inorder for the truck to run correctly and cluster to operate correctly. hope this is helpful also check with your dealer for any recalls on this cluster problem you may be able to get free repairs.

Jan 10, 2011 | 2002 GMC Sierra 1500

1 Answer

Gage cluster not working and buzzing noise from gage cluster area


them guages do give trouble..id say you need to replace the whole cluster to solve the problem..get one with low milage ina breakers yard ,,way cheaper too

Apr 25, 2009 | 1994 BMW 3 Series

Not finding what you are looking for?
2001 Saturn L-Series Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...