Question about Yugo Hatchback

1 Answer

Wont start i have a 2006 yamaha grizzly 660 that ont start.It turns has good compression and i have changed the plug for a new one,I put a little start fluid in the air intake and it fired up only for a second and then stalled.Any suggestions??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Make sure the gas valve is on. I had to replace the coil in mine because of a tiny crack in the coil. Also replaced the float valve in the carb. and all is good.

Posted on Mar 15, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2006 Yamaha rhino 660 that makes a clanking grinding noise coming out of the middle drive. The U joint is in good condition. It does it going down hill


I went google and found a breakdown of the transmission for a yamaha rino atv parts 660 4wd--yxr66 favgr transmission
It is a lot different from a bike or a car
the breakdown shows a link belt chain driving from the main shaft to the output shaft number 23 which will be the weakest part of the transmission
chain ( 23rh302-34asm)
94591-54034-00--$24.95
the site for this is partzilla.com and it is a print from yamaha motor corporation usa

Nov 30, 2015 | Cars & Trucks

1 Answer

Yamaha grizzly check engine light stays on. why?


Try to reset the code and drive. Does the error code pops again after resetting? Can you please tell that is your ride starting and running fine or not? Try self diagnostic system if your ride is equipped with it. You can also check the forum: http://www.grizzlycentral.com/forum/grizzly-electrical-lighting/33258-grizzly-700-check-engine-light-problem.html Hope this might be useful to you.

Jun 24, 2013 | Cars & Trucks

1 Answer

94 lexus sc300, Been sitting for 3years. was running fine when parked. Recently need to use car again. I changed out the old fuel with new fuel. replaced battery. Car turns over but wont start. I am...


CHANGE FUEL FILTER.SQUIRT FEW DROPS OF OIL IN EACH CYLINDER REMOVE SPARK PLUGS SQUIRT A LITTLE ENGINE OIL DOWN IN THE CYLINDERS TO SEAL THE COMPRESSION RINGS BUILD UP COMPRESSION SO ENGINE WILL START.

Oct 24, 2011 | 1992 Lexus Sc 300

1 Answer

Just bought a 1984 mustang its not run for years and wont start it turns over getting gas to the carb and has fire not sure about wiring


Any time a car sits for a long period of time you should completely drain the gas tank. The gas is more then likely stale. Try pouring a little new gas into the carb or use starting fluid. If it starts you have found your problem and will more then likely have to drain and clean the tank and replace the fuel filter.
If it does not start with the new gas, it is either a compression or timing issue. If you have spark at the plugs, and GOOD fuel in the carb and it still wont start I would check the timing. If the timing is on, check compression. If the engine sat to long with no oil in the cylinders they can build up condensation and rust. Then when you try to start it with the rust in the cylinders it can destroy the rings and cause compression loss.

Apr 08, 2010 | 1984 Ford Mustang

1 Answer

My car felt like it was losing power and i couldn't get passed 50mph. i then pulled into a junction and then car juddered and died. a mechanic changed then distributor cap, rotor arm and spark plugs as he...


This is just an educated guess without actually looking at it myself, but it sounds like your catylatic converter might be clogged. Have it checked before you spend any more money,and please take your car to a garage with a good reputation.

Feb 26, 2010 | 2006 Mitsubishi Colt

1 Answer

97 crown victoria wont start. ran great last night, this morning ont start. good battery and fuses.


GET A TUNEUP CAP&ROTOR,PLUGS WIRES,CHANGE THE ELECTRIC COIL,CHANGE THE FUEL FILTER

Oct 29, 2009 | 1992 Ford Crown Victoria

3 Answers

1966 mustang engine cranks but wont start


Guide to starting a dead horse!
1- Spray a little starter fluid down the carbuerator. If it tries to fire, your timing and ignition is probably OK. This could indicate a carb or fuel pump problem.
2- If it doesn't fire, check out the points, condenser, coil, distributor cap and rotor. Look for condensation inside the cap. Check that the high tension wire from the coil to distributor is in good shape and not touching the engine or any brackets,etc.
3- Verify that your timing is correct. You may have a timing train problem (Worn or broken).
4- The distributor may have come loose and changed positions. Check for proper timing.
5- It may be a compression problem. If it has set long enough for the oil that coats the cylinder walls to drain down, you won't have enough compression to allow firing. Check your compression and if this seems to be the case, remove the spark plugs and squirt a little Marvel Mystery oil, or similar light weight oil into each cylinder. When it starts, it will smoke for a few minutes, but that will go away.
Hope this helps and if not, get back to me.
Have a super day!
Ron


Jan 11, 2009 | 1966 Ford Mustang

2 Answers

1985 Chevey Chevette wont start up


I would try checking the Fuel filter and if none put one on their.

Aug 12, 2008 | 1985 Chevrolet Chevette

4 Answers

1998 ford explorer turn over but wont start.


Under the hood there is a grey box on the right side open it and then you will see some plugs there is a 3prong plug take it out and get it replaced it will cost about $4.00 or no more then $10.00 or so and it should start after that I had the same problem.
Nikki2913

Jul 08, 2008 | 1996 Ford Explorer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

215 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yugo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Sam Akber
Sam Akber

Level 3 Expert

987 Answers

graybeard32301

Level 3 Expert

352 Answers

Are you a Yugo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...