Question about 2004 Audi A4

Open Question

2004 audi 1.8 turbo runs rough

Engine runs rough in park when i have it in drive at idle it stops misfiring if its in park and not running rough if i raise idle above 2000 rpm and let it idle it starts running rough p0171 but cant find any vaccum leaks fuel trim is at +25% also have p0301 p0302 p0303 p0304 its also setting a code for the turbo diverter valve any help? email me mexicano66@gmail.com i put on new dealer plugs new ngk v power plugs and new fuel injectors and still runs the same

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 116 Answers

SOURCE: 98 E-250 Rough Idle; codes p0156,p1131,p1151,p0301,p0171,p0174+

po301 thru po306 all misfire codes cylinder 1-6 remove plugs and replace them..... set the plug gap first
i suggest u replace the wires also if they never been replaced all these misfire codes can set the others and one is for the oxygen sensor ( 02s or HO2S) CIRCUT MALFUNCTION do u know how to check wireing systems
do the tune up plugs (set gap) .052-.056 change the fuel filter also. clear the codes hows it run
this info is for 98 E-250 4.2Litre
what engine do u have 4.2L or 4.6L i know it is a v-6 by the codes

Posted on Dec 15, 2008

Ad
  • 1 Answer

SOURCE: miss fire and lean codes

i have lost my mobile

Posted on Apr 17, 2009

  • 51 Answers

SOURCE: start and diesss

p0456: evap system. sensor failure
p0172: evap system. intake blocked
p0778: exaust valve control. solenoid/ecu faukt
p0300: cylinders misfire. check ht/ignition leads
p0301,303,304,305,306: same ht leads

hope this helps..

Posted on Apr 27, 2009

SOURCE: mil is on the codes

Multiple Misfires on 4 cylinders

Need a repair shop

That is only a code report,doubt you
have more than one, unless you have
a bad intake manifold vacuum leak

Stop using it before you damage
something

Posted on Jun 10, 2011

dttech
  • 4803 Answers

SOURCE: p0136 p0156 p0401 p0402 p1131 p1151 p0171 p0174

All of that going on all at the same time is not likely at all. Are you sure the engine is actually overheating or is that just what your instrument panel is telling you?
With all of those things going on at the same time, here is what I would do. First I would take a REAL HARD look at the charging system. Goofy stuff like this is often caused by a battery with a shorted cell or an alternator with bad diodes that is feeding AC current into the computer network. The computers tend to do really goofy things when they are suffering from malnutrition.

Once I am satisfied that the charging system is in good condition, then I would clear the codes and go on a road test. If the check engine light comes back on, I would immediately scan the engine controller to find out which of the codes came back and fix it FIRST. Many times, fixing one code can fix ALL the codes. By doing it this way, you are more likely to find which one is your MAIN problem.

If your engine is actually overheating, all I can say is you need to diagnose your engine cooling system to find out why...all of the misfire codes could very likely be a result of the engine overheating and fixing the engine cooling system will most likely fix these codes.

Posted on Sep 28, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

I have a 99 ford f150. Sometimes it runs perfect, then out of no where when I try to accelerate it vibrates bad and becomea hesitant. When I came to a stop I switched threw all gears and it seems like it...


This sounds like you might have a bad plug wire or something else in the ignition system is arcing to ground. A quick way to verify this is to run the truck in Park at idle. Next, spray the ignition wires with Windex. You'll notice the truck starting to rough up and might even see the bad wire arcing to ground. A complete tuneup would be recommended in this case.
I hope this helps! :)

Jun 11, 2014 | Cars & Trucks

1 Answer

1995 jeep gr cherokee laredo jumps when first star in morning and runs rough when ac or heat on


my guess, car unseen.
car has an A/T trans, and all A/T jump from park to drive
selection is made on a cold engine, due to the very fast idle speed.
what was the park and cold idle speed. and out door temps.
the lower out door temps, make idle speed , cold engine, even higher
but when the engine reaches 180F or more and holds, the RPM
is about 800 RPM (the FSM tells the exact amount and does vary for the unstated engine option) so at 800 the tranny don;t lurch, did it on a hot engine. so if idle speeds are wrong say so and say it with engine temps. or its all meaningless.
next :
runs rough, the engine (even parked?) is called misfire.
misfire on a good engine (full compression)
is:
1: bad spark (or never had a tune up ever) every 60k miles.
2: bad fueling. too rich, too lean (low idle) bad injectors (stuck or clogged, or wrong fuel pump pressure or bad Fuel pressure regulator)
3: bad fuel.

there is a test for each possible failure. all very simple test.
it takes $80 in gauge tools to find engine problems.

Dec 30, 2013 | 1995 Jeep Cherokee

1 Answer

Audi 1.8t back pressure out exhaust rough idle


There is misfire to the engine.. Misfiring means, bad spark Plugs or there is ignition coil is not working well

Dec 28, 2013 | Audi Cars & Trucks

1 Answer

My 2004 ford expedition idles rough like its going to cut off The idling jumps up and down in park or drive only when stopped Service engine light cuts off and on periodically what could be happening


run a teat. Remove the vacuum line from the brake booster and plug off. Start engine and see if it idles normally. . Put your foot on the brake pedal and apply the brakes . If the idle is still normal replace the brake booster as there is an air leak in the diaphram.. The service light is probably recording misfiring and air fuel mixture problems.. run fault codes any way just to check it out .

Dec 23, 2013 | Cars & Trucks

1 Answer

Drive rough with foot on gas


if that is engine related, we dont know here , we cant drive it and feel it.
if that was engine vibration, its most likely MISFIRE.
the #1 cause of MISFIRE, is not doing the 60k mile tune up.

is the CHECK engine lamp off driving? if not scan the ECU/PCM
any scan tool works. (new types) even a $9 tool.
scan it for P03xx codes, misfire.

rough hot or cold engine.
rough only driving and not at idle and not racing RPM parked?
does engine ever stall>?

Dec 12, 2013 | 2004 Jeep Grand Cherokee

1 Answer

Car idles rough in park also runs rough in overdrive


Sometimes a rough idle like that is a fuel filter. As you've already done the plugs and wires the fuel filter would be my next bet.

Mar 15, 2010 | 1993 Buick LeSabre

1 Answer

Miss fire and lean codes


i have lost my mobile

Apr 17, 2009 | 2004 Audi A4

1 Answer

2004 audi s4 b6


Very weird, a bad cat should not make it mis-fire, if it is just one cylinder it is mis-firing on, its worth checking the coil pack for that cylinder

Feb 21, 2009 | 2004 Audi S4

3 Answers

Rough idel/no power


0475c6f.jpg As a former Audi technician, I can pretty much guarantee the coil packs are your problem.

Jan 25, 2009 | 2004 Audi A4

2 Answers

Very Rough running engine


I think the auto-lite plugs are probably your problem. yes it sounds like mis-firing. That's one of the few times the check engine light flashes. I'd suggest changing the plugs to a NGK plug, that's the ONLY plug we use in our Audi's and VW's (work at a VW/Audi shop). Try that, and it should take care of the rough running, if not, it will probably need coils too.

Jan 13, 2009 | 2004 Audi TT

Not finding what you are looking for?
2004 Audi A4 Logo

Related Topics:

431 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audi Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14363 Answers

Are you an Audi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...