Question about 1995 Lexus Sc 400

2 Answers

Sc400 has lost acceleration!!!!

I have replaced plugs,,wires,filters and it still isn't what it used to be!!!

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 60 Answers

A simple loss of power could be contributed to several different things without knowing the exact symptoms. Throttle position sensor, a slipping transmission, faulty coil pack(s) or fuel pump can all cause power loss. Is it intermittent? constant? does the car run smoothly and just experience power loss or does it run rough? The more information provided the better I may be able to help.

Posted on Jun 07, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

One of your coils is bad I assure you jus had this problem

Posted on May 21, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the fuel filter on a 93 sc400


FUEL FILTER IS LOCATED UNDER THE VECHICLE.ON THE DRIVER SIDE.BEFORE THE REAR AXLE.

Apr 18, 2010 | 1993 Lexus SC

1 Answer

Car stutters at stoplights lexus ls400 1990


I had the same issue with my SC400, it was due to low compression in one of the cylinders, due to a leaking head gasket... I was in the process of swapping out the engine for a new 1uzfe, so it wasnt a huge problem, I had been expecting it due to the fact that I had 301,000 miles on it when I finally replaced the engine last week.

Oct 06, 2009 | 1991 Lexus LS 400

1 Answer

Lexus sc400 electrical problem


the computer is bad and also these cars are known for the insturment clusters to go bad along with the computer. get them both fixed and it will solve your problem.

Aug 10, 2009 | 1992 Lexus Sc 400

1 Answer

1990 Camry runs roughly when accelerating, especially up hills...


This could be a problem with plugs, wires, distributors, fuel filter or fuel injectors. Try changing the plugs and wires first, then the fuel filter. If you are changing the plugs and wires, make sue you use anti seizing compound and dielectric grease.

Jun 29, 2009 | 1999 Suzuki Vitara

1 Answer

I need instructions for replacement of 1995 lexus sc400 spark plug wires.


http://www.lexls.com/tutorials/ignition/sparkplugs.html

This should help, I did mine yesterday, it is a piece of cake... just make sure you have a good spark plug socket that fits VERY snugly on the extension,and make sure you have a LONG extension for the socket... I have a 10 inch one, and I wish I used one that was longer for the back plugs on each side... Oh, and be careful to not crack the plugs in there by over tightening them... I know that it says its for an LS400 but they both have 1UZ-FE engines so its the same thing...

And make sure to spend the extra money for the Good Plugs and Wires... I got NKG's for my '93 SC400... well worth it...

Jun 07, 2009 | 1995 Lexus Sc 400

2 Answers

Under heavy acceleration the car stumbles, runs rough


I am having the same problem with my mustang, have replaced tps, egr valve and sensor, clean maf, new plugs and wires, new fuel filter, cleaned throtle body and still having same problems....Please help!!!!!

May 29, 2009 | 2002 Ford Mustang

1 Answer

Hesitates on acceleration


Does the car always hesitate during acceleration? If it ALWAYS struggles when it starts or ALWAYS hesitates on acceleration then I would say the issue is fuel delivery. If the problems are more intermittent and come-and-go then it could be an electrical issue.

I would start by changing the fuel filter. Changing plugs, wires, cap, and rotor are all good things to do as your budget will allow. I doubt you will have to change your injectors.

If you end up replacing any rubber fuel line, be sure to use the high-pressure stuff made for use on fuel injected cars.

I hope this helps! -Nick

Apr 10, 2009 | 1983 Chevrolet Chevy

1 Answer

Nissan Stanza 1986 car bucks and cuts out when accelerating


I would check the vacuum advance. or maybe an O2 sensor

Feb 19, 2009 | 1985 Nissan Stanza

1 Answer

Acceleration issues


I would suggest replacing the spark plugs, the spark plug wires, and the air filter before I would try anyhing else. Use Toyota plugs and wires. Slightly more expensive, but the extra is worth the cost.
Note that "aftermarket" plugs may make your car run WORSE.

A FixYa rating for my assistance would be greatly appreciated.

Jan 23, 2009 | 1996 Toyota Avalon

Not finding what you are looking for?
Cars & Trucks Logo

653 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexus Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

874 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Lexus Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...