Question about 1992 Plymouth Sundance

1 Answer

No power at take off

92 sundance 2.2
timing belt broke last week
changed belt step by step with the manual
new plugs and wires
idles nice runs good except
sometimes taking off from a stop it has no power just crawls along at 25 untill it feels like taking off
im thinking some kind of vacume leak

Posted by on

  • chilibobba
    chilibobba May 23, 2009

    plug wires are new and secure,checked all vacum hoses cant find leak,seems like a clogged catalitic converter but once it gets up to speed its runs fine and a clogged converter would be worse at higher speeds.

    just turned 100000 miles,just replaced fuel pump and fuel filter.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,902 Answers

Check all your vacum lines and make sure that your plug wires are properly secured this seems like a minor problem

Posted on Apr 17, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 95 acura is slow to build up r.p.ms after it is ok untel it goes to anoth er gear then does it all over again.


If you are very lucky, the installation of the timing belt was most likely done "out of time". The cam must be exactly aligned with the position of the crankshaft during the timing belt installation. The tech that installed the new timing belt should be responsible for making this adjustment, although if he/she didn't know enough to get it right the the first time you may want to have another mechanic get involved. There's a myriad of other problems unrelated to the timing belt that could be present if the other parts of the engine were installed incorrectly. Look at the mass air flow sensor wire connection, and the entire intake system from the air filter to the throttle body, throttle position sensor, the idle air control - a small air "bypass" that allows enough air to bypass the throttle body so the engine can idle, it has wires running to it so the computer can control the idle speed. Seriously consider replacing the fuel filter if you don't know the last time it was changed, look closely at the spark plugs just to be sure none were cracked during the timing belt work. Lastly, look at the oxygen sensors - look for the wires going to the sensors in the exhaust manifold and the exhaust pipe behind the catalytic converter. While there is little you can do to know if one or more of the oxygen sensors is bad, at least check to be sure the wires are firmly connected. Usually if the oxygen sensors are failing there will be a "Check Engine" light. Be aware the it would be a coincidence to have an Ox sensor go bad at the same time as the timing belt breaking, but it's worth checking if you are getting a CEL. Respond with engine type, and current mileage, and we may be able to come up with more things you can try Does the engine make any "new" noises since the timing belt failure and repair. The worst case would be if the timing belt broke while the engine was running at high speed, in many engines this can cause serious valve train damage or even damage to the pistons. If this was the case with your engine, ithe damage would almost certainly have led to a knocking, hissing, or growling noise that was not present before the timing belt broke. A third possibility might be a problem with the spark plug wires, if they were not placed back in the correct positions after the repair, the engine would run very poorly, if at all - a six cylinder MIGHT start and run with two or more of the wires placed incorrectly, a four cylinder wouldn't start at all.

Jul 21, 2012 | Acura Integra Cars & Trucks

1 Answer

92 plymouth laser rs turbo won't will crank but not start


If the cam belt broke, you need a new head.

Apr 02, 2017 | Cars & Trucks

1 Answer

My sidekick will just die or barely run it died


last year, OBD1 car (dumbb ECU)
no scan tools for it
if you run on the road with that hack , and wreck
expect a nice fire. fuel fire.
if you used a voltmeter and say 12vdc there, all hotwiring stuff
need not be done. (
it stalled (misfire)
and then would not what? start but cranks ok?
4wd?
3sp ,4sp auto or 5speed stick
16v engine or 8v, both are G16s but EFI radially different.
16v is MPI with 4 injectors, 8v is 1 injector TBI
try a new
cap,.rotor spark wires and spark plugs yet?
cant burn fuel with bad spark
i guess the cam bent did not slip as it run ok later, but is 60,000 mile belt. and will slip ignored.

next time it stalls
check headlamps they work, and all electric
then see if CEL glows key on, i must or ECU lost power
it has 3 fuse that can rust, IG coil, FI, and DOME.
the CEL must glow, is first checks.

Mar 21, 2017 | 1995 Suzuki Sidekick

1 Answer

I have a 1993 Plymouth Sundance Duster. Over the past three weeks it has been running fine and just dies. I replaced the spark plug wires and the coil and now it idles and runs fine until I put it into 4th...


Have fuel pressure tested, or at the least, change fuel filter. Fuel pump may be on it's way out but it only takes 5 minutes to test the fuel pressure to confirm.

Jul 20, 2010 | Plymouth Sundance Cars & Trucks

2 Answers

92 ranger - piece of **** rebuilt starter ?


run scanner for trouble codes, some auto parts store will do this for free, check starter solenoid, check voltage at battery , 12+volts not started ,  14+ amps when running 

Oct 04, 2009 | 1992 Ford Ranger

1 Answer

Stall as soon as oil light came on..92 sundance


I don't think a 92 sundance will shut the fuel pump down when the oil pressure is low, but it might. Can you get it to run on carb cleaner. If it is oil pressure, the car should start then run a few seconds and die. Have you checked the timing belt? If it broke the distributor will stop turning which would stop the oil pump.

Jun 05, 2009 | 1992 Plymouth Sundance

1 Answer

Chevy Aveo 1.6 Engine, Timing Belt Broke, Replaced,Runs Rough?


Did you have the dealer change the belt because it broke ?
If this is the case they should know if it is an interfearance engine and if it is in fact an interference engine they should have checked the valves. If you had the belt changed just because you were scared it was going to break on you then I am sure the car ran fine when you took it in.
The explanation you gave sounds to me like they have the belt a tooth off and they need to re do it because the timing is out.
I hope this helps
Regards
Sam

May 11, 2009 | 2004 Chevrolet Aveo

1 Answer

Can anybody tell me why elantra keeps popping up when i need a manual for a lantra 1600 is there a manual that matches this from another model


I found the best way is to take the idle pulley off first then with a little effort you can slide it over the cam pulley. Then reinstall the belt tensioner/ idler pulley and adjust. Do not over tension the belt .

Apr 17, 2009 | Hyundai Elantra Cars & Trucks

1 Answer

95 GMC Jimmy 4.3l W vin rough idle


My problem was solved when I repaired my 4 wd activation dash switch. The switch was contacting on 2WD & 4HI at the same time. The front differential activation is vacuum activated possibly creating a tug of war that didn't actually engage it but drained off vacuum from the engine? A theory at best but stumbbled across it because I knew the switch wasn't working properly I repaired it and low and behold rough idle disappeared and all is good for 3 weeks running.

Nov 17, 2008 | 1995 Chevrolet Blazer

2 Answers

Rough and noisy idle


i have a 2000 kia sportage the timing belt broke and the 2.0 is a zero clearance motor.you need to find out if it bent the valves.it did in mine.

Aug 24, 2008 | 2000 Kia Sportage

Not finding what you are looking for?
1992 Plymouth Sundance Logo

Related Topics:

183 people viewed this question

Ask a Question

Usually answered in minutes!

Top Plymouth Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Plymouth Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...